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Prologue
Welcome

Welcome to Geing Started with Ubuntu, an introductory guide wrien to
help new users get started with Ubuntu.
Our goal is to cover the basics of Ubuntu (such as installation and working with the desktop) as well as hardware and soware management, working with the command line, and security. We designed this guide to be
simple to follow, with step-by-step instructions and plenty of screenshots,
allowing you to discover the potential of your new Ubuntu system.
Canonical releases new versions of Ubuntu every six months; every
fourth release is a so-called long-term support () version. Each Ubuntu
release has a version number that consists of the year and month number
of the release, and an alliterative code name using an adjective and an
animal. Code names are in consecutive alphabetic order, allowing a quick
determination of which release is newer. Ubuntu . (code-named Saucy
Salamander) is considered a regular release and is supported by Canonical
with patches and upgrades for nine months. e most recent  version is
Ubuntu . (Precise Pangolin), and has support for ﬁve years (until April
). Whenever a new version of Ubuntu is released, we will incorporate
updates and changes into our guide, and make a new version available at
http://www.ubuntu-manual.org.
Geing Started with Ubuntu . is not intended to be a comprehensive
Ubuntu instruction manual. It is a quick-start guide that will get you doing the things you need to do with your computer easily, without geing
bogged down with technical details. Ubuntu . incorporates many new
and improved features, including new icons (some dynamic), more appearance options, locally integrated menus, and smart scopes, to name just a
few. With the help of this guide, it should not take long before new users
get used to the Unity desktop environment. Unity includes the Starter, the
Dash, the , indicators, and an on-screen display notiﬁcation system
(). All these features will be explained in this guide.
For more detailed information on any aspect of the Ubuntu desktop, see
the “Ubuntu Desktop Guide,” which can be obtained in any of the following
ways:
‣ in the Dash, type help.
‣ in the indicator area, click Session indicator ‣ Ubuntu Help.
‣ go to https://help.ubuntu.com, Ubuntu . ‣ Ubuntu Desktop Help.
ere are also many excellent resources available on the Internet. For
example, on https://help.ubuntu.com you will ﬁnd documentation on installing and using Ubuntu. At the Ubuntu Forums (http://ubuntuforums.org)
and Ask Ubuntu (http://askubuntu.com), you will ﬁnd answers to many
Ubuntu-related questions.
If something isn’t covered in this manual, chances are you will ﬁnd the
information you are looking for in one of those locations. We will try our
best to include links to more detailed help wherever we can.

You can ﬁnd more information about Ubuntu’s
online and system documentation in Chapter 8:
Learning More.
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Ubuntu Philosophy

e term “Ubuntu” is a traditional African concept originating from the
Bantu languages of southern Africa. It can be described as a way of connecting with others—living in a global community where your actions
aﬀect all of humanity. Ubuntu is more than just an operating system: it is
a community of people coming together voluntarily to collaborate on an
international soware project that aims to deliver the best possible user
experience.

People sometimes wonder how to pronounce
Ubuntu. Each u is pronounced the same as in
the word put except for the last u which is
pronounced the same as in the word due.

The Ubuntu Promise

‣ Ubuntu will always be free of charge, along with its regular enterprise
releases and security updates.
‣ Ubuntu comes with full commercial support from Canonical and hundreds of companies from across the world.
‣ Ubuntu provides the best translations and accessibility features that the
free soware community has to oﬀer.
‣ Ubuntu’s core applications are all free and open source. We want you to
use free and open source soware, improve it, and pass it on.
A brief history of Ubuntu

Ubuntu was conceived in  by Mark Shuleworth, a successful South
African entrepreneur, and his company Canonical. Shuleworth recognized
the power of Linux and open source, but was also aware of weaknesses that
prevented mainstream use.
Shuleworth set out with clear intentions to address these weaknesses
and create a system that was easy to use, completely free (see Chapter :
Learning More for the complete deﬁnition of “free”), and could compete
with other mainstream operating systems. With the Debian system as a
base, Shuleworth began to build Ubuntu. Using his own funds at ﬁrst,
installation s were pressed and shipped worldwide at no cost to the
recipients. Ubuntu spread quickly, its community grew rapidly, and soon
Ubuntu became the most popular Linux distribution available.
With more people working on the project than ever before, its core
features and hardware support continue to improve, and Ubuntu has gained
the aention of large organizations worldwide.
While large organizations oen ﬁnd it useful to pay for support services,
Shuleworth has promised that the Ubuntu desktop operating system
will always be free. Ubuntu is installed on an estimated % of the world’s
computers. is equates to tens of millions of users worldwide, and is
growing each year. As there is no compulsory registration, the percentage
of Ubuntu users should be treated as an estimate.
What is Linux?

Ubuntu is built on the foundation of Linux, which is a member of the Unix
family. Unix is one of the oldest types of operating systems, and together
with Linux has provided reliability and security for professional applications for almost half a century. Many servers around the world that store
data for popular websites (such as YouTube and Google) run some variant
of Linux or Unix. e popular Android system for smartphones is a Linux
variant; modern in-car computers usually run on Linux. Even the Mac  

To learn more about Canonical, go to http://
www.canonical.com.

Debian is the Linux operating system that
Ubuntu is based upon. For more information
visit http://www.debian.org/.

For information on Ubuntu Server Edition, and
how you can use it in your company, visit http://
www.ubuntu.com/business/server/overview.

 

is based on Unix. e Linux kernel is best described as the core—almost the
brain—of the Ubuntu operating system.
e Linux kernel is the controller of the operating system; it is responsible for allocating memory and processor time. It can also be thought of as
the program which manages any and all applications on the computer itself.
While modern graphical desktop environments have generally replaced
early command line interfaces, the command line can still be a quick and
eﬃcient way of performing many tasks. See Chapter : Advanced Topics
for more information, and Chapter : e Ubuntu Desktop to learn more
about  and other desktop environments.
Linux was designed from the ground up with security and hardware
compatibility in mind, and is currently one of the most popular Unix-based
operating systems. One of the beneﬁts of Linux is that it is incredibly ﬂexible and can be conﬁgured to run on almost any device—from the smallest
micro-computers and cellphones to the largest super-computers. Unix was
entirely command line-based until graphical user interfaces (s) emerged
in  (in comparison, Apple came out with Mac  ten years later, and
Microso released Windows . in ).
e early s were diﬃcult to conﬁgure, clunky, and generally only
used by seasoned computer programmers. In the past decade, however,
graphical user interfaces have grown in usability, reliability, and appearance. Ubuntu is just one of many diﬀerent Linux distributions.

To learn more about Linux distributions, see
Chapter 8: Learning More.

Is Ubuntu right for you?

New users to Ubuntu may ﬁnd that it takes some time to feel comfortable when trying a new operating system. You will no doubt notice many
similarities to both Microso Windows and Mac   as well as some differences. Users coming from Mac   are more likely to notice similarities
due to the fact that both Mac   and Ubuntu originated from Unix. e
Unity shell, which is the default in Ubuntu, is a completely new concept,
which needs some exploring to get used to it. See Chapter : e Ubuntu
Desktop for more information about the Unity shell.
Before you decide whether or not Ubuntu is right for you, we suggest
giving yourself some time to grow accustomed to the way things are done
in Ubuntu. You should expect to ﬁnd that some things are diﬀerent from
what you are used to. We also suggest taking the following into account:
Ubuntu is community based. at is, Ubuntu is developed, wrien, and
maintained by the community. Because of this, support is probably
not available at your local computer store. Fortunately, the Ubuntu
community is here to help. ere are many articles, guides, and manuals
available, as well as users on various Internet forums and Internet Relay
Chat () rooms that are willing to assist beginners. Additionally, near
the end of this guide, we include a troubleshooting chapter: Chapter :
Troubleshooting.
Many applications designed for Microso Windows or Mac   will not run
on Ubuntu. For the vast majority of everyday computing tasks, you
will ﬁnd suitable alternative applications available in Ubuntu. However,
many professional applications (such as the Adobe Creative Suite) are
not developed to work with Ubuntu. If you rely on commercial soware
that is not compatible with Ubuntu, yet still want to give Ubuntu a try,
you may want to consider dual-booting. Alternatively, some applications

To learn more about dual-booting (running
Ubuntu side-by-side with another operating
system), see Chapter 1: Installation.
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developed for Windows will work in Ubuntu with a program called
Wine. For more information on Wine, see Chapter : Advanced Topics.
Many commercial games will not run on Ubuntu. If you are a heavy gamer,
then Ubuntu may not be for you. Game developers usually design games
for the largest market. Since Ubuntu’s market share is not as substantial
as Microso’s Windows or Apple’s Mac  , fewer game developers
allocate resources towards making their games compatible with Linux. If
you just enjoy a game every now and then, there are many high quality
games that can be easily installed through the Ubuntu Soware Center.
ere are also a lot of games available at http://store.steampowered.com/
browse/linux/.
Contact details

Many people have contributed their time to this project. If you notice any
errors or think we have le something out, feel free to contact us. We do
everything we can to make sure that this manual is up to date, informative,
and professional. Our contact details are as follows:
‣
‣
‣
‣
‣

Website: http://www.ubuntu-manual.org/
Reader feedback: feedback@ubuntu-manual.org
: #ubuntu-manual on irc.freenode.net
Bug Reports: https://bugs.launchpad.net/ubuntu-manual/+filebug
Mailing list: ubuntu-manual@lists.launchpad.net

About the team

Our project is an open-source, volunteer eﬀort to create and maintain quality documentation for Ubuntu and its derivatives.
Want to help?

We are always looking for talented people to work with, and due to the size
of the project we are fortunate to be able to cater to a wide range of skill
sets:
‣
‣
‣
‣
‣
‣
‣
‣
‣

Authors and editors
Programmers (Python or TEX)
User interface designers
Icon and title page designers
Event organizers and ideas people
Testers
Web designers and developers
Translators and screenshoers
Bug reporters and triagers

To ﬁnd out how you can get started helping, please visit http://ubuntumanual.org/getinvolved.
Conventions used in this book

e following typographic conventions are used in this book:
‣ Buon names, menu items, and other  elements are set in boldfaced
type.

See Chapter 5: Software Management to learn
more about Ubuntu Software Center.

 

‣ Menu sequences are sometimes typeset as File ‣ Save As…, which means,
“Choose the File menu, then choose the Save As….”
‣ Monospaced type is used for text that you type into the computer, text
that the computer outputs (as in a terminal), and keyboard shortcuts.

1 Installation
Getting Ubuntu

Before you can get started with Ubuntu, you will need to obtain a copy of
the Ubuntu installation image for  or . Some options for doing this
are outlined below.

Many companies (such as Dell and System76)
sell computers with Ubuntu preinstalled. If
you already have Ubuntu installed on your
computer, feel free to skip to Chapter 2: The
Ubuntu Desktop.

Minimum system requirements

If you are unsure whether it will work on your computer, the Live  is a
great way to test things out ﬁrst. Below is a list of hardware speciﬁcations
that your computer should meet as a minimum requirement.
‣
‣
‣
‣
‣
‣

 GHz x processor (Pentium  or beer)
  of system memory ()
  of disk space (at least   is recommended)
Video support capable of × resolution
Audio support
An Internet connection (highly recommended, but not required)

Downloading Ubuntu

e easiest and most common method for geing Ubuntu is to download
the Ubuntu  image directly from http://www.ubuntu.com/download.
Choose how you will install Ubuntu:
‣ Download and install
‣ Try it from a  or  stick
Download and Install / Try it from a DVD or USB stick

For the Download and install, or Try it from a  or  stick options, select
whether you require the -bit or -bit version (-bit is recommended for
most users), then click “Start download.”
32-bit versus 64-bit

Ubuntu and its derivatives are available in two versions: -bit and -bit.
is diﬀerence refers to the way computers process information. Computers capable of running -bit soware are able to process more information
than computers running -bit soware; however, -bit systems require
more memory in order to do this. Nevertheless, these computers gain performance enhancements by running -bit soware.
‣ If your computer has a -bit processor, install the -bit version.
‣ If your computer is older, a netbook, or you do not know the type of
processor in the computer, install the -bit version.
If your computer has a -bit processor, select the “-bit” option before
you click “Start download.”

32-bit and 64-bit are types of processor
architectures. Most new desktop computers
have a 64-bit capable processor.
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Downloading Ubuntu as a torrent

When a new version of Ubuntu is released, the download servers can get
“clogged” as large numbers of people try to download or upgrade Ubuntu
at the same time. If you are familiar with using torrents, you can download
the torrent ﬁle by clicking “Alternative downloads,” and then “BitTorrent
download.” Downloading via torrent may improve your download speed,
and will also help to spread Ubuntu to other users worldwide.

Torrents are a way of sharing ﬁles and information around the Internet via peer-to-peer ﬁle
sharing. A ﬁle with the .torrent extension is
made available to users, which is then opened
with a compatible program such as uTorrent,
Deluge, or Transmission. These programs
download parts of the ﬁle from other people all
around the world.

Burning the DVD image

Once your download is complete, you will be le with a ﬁle called ubuntu.-desktop-i.iso or similar (i here in the ﬁlename refers to the -bit
version. If you downloaded the -bit version, the ﬁlename contains amd
instead). is ﬁle is a  image—a snapshot of the contents of a —
which you will need to burn to a .

While the 64-bit version of Ubuntu is referred
to as the “AMD64” version, it will work on Intel,
AMD, and other compatible 64-bit processors.

Creating a bootable USB drive

If your  is able to boot from a  stick, you may prefer to use a 
memory stick instead of burning a . Scroll down to “Burn your 
or create a  drive,” select  or  stick, choose the  you are using
to create the  drive, and then click Show me how. If you select the “
Stick” option, your installation will be running from the  memory stick.
In this case, references to Live , will refer to the  memory stick.
Trying out Ubuntu

e Ubuntu  and  stick function not only as installation media, but
also allow you to test Ubuntu without making any permanent changes to
your computer by running the entire operating system from the  or 
stick.
Your computer reads information from a  at a much slower speed
than it can read information oﬀ of a hard drive. Running Ubuntu from
the Live  also occupies a large portion of your computer’s memory,
which would usually be available for applications to access when Ubuntu is
running from your hard drive. e Live / experience will therefore
feel slightly slower than it does when Ubuntu is actually installed on your
computer. Running Ubuntu from the / is a great way to test things
out and allows you to try the default applications, browse the Internet, and
get a general feel for the operating system. It’s also useful for checking that
your computer hardware works properly in Ubuntu and that there are no
major compatibility issues.
To try out Ubuntu using the Live / stick, insert the Ubuntu 
into your  drive, or connect the  drive and restart your computer.
Aer your computer ﬁnds the Live / stick, and a quick loading screen, you will be presented with the “Welcome” screen. Using your
mouse, select your language from the list on the le, then click the buon
labelled Try Ubuntu. Ubuntu will then start up, running directly from the
Live / drive.
Once Ubuntu is up and running, you will see the default desktop. We
will talk more about how to actually use Ubuntu in Chapter : e Ubuntu
Desktop, but for now, feel free to test things out. Open some applications,
change seings and generally explore—any changes you make will not be

In some cases, your computer will not recognize
that the Ubuntu DVD or USB is present as it
starts up and will start your existing operating
system instead. To run Ubuntu from the Live
DVD or USB, we want the computer to look
for information from the Live DVD or USB
ﬁrst. Changing your boot priority is usually
handled by BIOS settings; this is beyond the
scope of this guide. If you need assistance with
changing the boot priority, see your computer
manufacturer’s documentation for more
information.

 

Figure 1.1: The “Welcome” screen allows you to
choose your language.

saved once you exit, so you don’t need to worry about accidentally breaking
anything.
When you are ﬁnished exploring, restart your computer by clicking
the “Power” buon in the top right corner of your screen (a circle with
a line through the top) and then select Restart. Follow the prompts that
appear on screen, including removing the Live  and pressing Enter
when instructed, and then your computer will restart. As long as the Live
 is no longer in the drive, your computer will return to its original state
as though nothing ever happened!

Alternatively, you can also use your mouse to
double-click the “Install Ubuntu 13.10” icon that
is visible on the desktop when using the Live
DVD. This will start the Ubuntu installer.

Installing Ubuntu—Getting started

At least   of free space on your hard drive is required in order to install
Ubuntu. We recommend   or more. is will ensure that you will
have plenty of room to install extra applications later on, as well as store
your own documents, music, and photos. To get started, place the Ubuntu
 in your  drive and restart your computer. Your computer should
load Ubuntu from the . When you ﬁrst start from the , you will
be presented with a screen asking you whether you want to ﬁrst try out
Ubuntu or install it. Select the language you want to view the installer
in and click on the Install Ubuntu buon. is will start the installation
process.
If you have an Internet connection, the installer will ask you if you
would like to “Download updates while installing.” We recommend you
do so. e second option, “Install this third-party soware,” includes the
Fluendo  codec, and soware required for some wireless hardware. If
you are not connected to the Internet, the installer will help you set up a
wireless connection.
e “Preparing to install Ubuntu” screen will also let you know if you
have enough disk space and if you are connected to a power source (in case
you are installing Ubuntu on a laptop running on baery). Once you have
selected your choices, click Continue.

Clicking on the underlined “release notes” link
will open a web page containing any important
information regarding the current version of
Ubuntu.
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Figure 1.2: Preparing to install.

Internet connection

If you are not connected to the Internet, the installer will ask you to choose
a wireless network (if available).
. Select Connect to this network, and then select your network from the
list.
. If the list does not appear immediately, wait until a triangle/arrow appears next to the network adapter, and then click the arrow to see the
available networks.
. In the Password ﬁeld, enter the network  or  key (if necessary).
. Click Connect to continue.

We recommend that you connect to the
Internet during install, although updates and
third-party software can be installed after
installation completes.

Figure 1.3: Set up wireless.

Allocate drive space

e Ubuntu installer will automatically detect any existing operating system installed on your machine, and present installation options suitable for
your system. e options listed below depend on your speciﬁc system and
may not all be available:
‣ Install alongside other operating systems

If you are installing on a new machine with no
operating system, you will not get the ﬁrst
option. The upgrade option is only available if
you are upgrading from a previous version of
Ubuntu.

 

‣ Upgrade Ubuntu … to .
‣ Erase … and install Ubuntu
‣ Something else
Install alongside other operating systems.

For more complicated dual-booting setups, you will need to conﬁgure the partitions manually.

Figure 1.4: Choose where you would like to
install Ubuntu.

Upgrade Ubuntu … to 13.10

is option will keep all of your Documents, music, pictures, and other
personal ﬁles. Installed soware will be kept when possible (not all your
currently installed soware may be supported on the new version). Systemwide seings will be cleared.
Erase disk and install Ubuntu

Use this option if you want to erase your entire disk. is will delete any
existing operating systems that are installed on that disk, such as Microso
Windows, and install Ubuntu in its place. is option is also useful if you
have an empty hard drive, as Ubuntu will automatically create the necessary partitions for you.
Formaing a partition will destroy any data currently on the partition.
Be sure to back up any data you want to save before formaing. More
information and detailed instructions on partitioning are available at:
https://help.ubuntu.com/community/HowtoPartition.

Aer you have chosen the installation type, click Continue, or Install
Now.
Conﬁrm Partition choices and start install

If you chose Something else, conﬁgure the partitions as you need. Once
you are happy with the way the partitions are going to be set up, click the
Install Now buon at the boom right to move on.
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To reduce the time required for installation, Ubuntu will continue the
installation process in the background while you conﬁgure important user
details—like your username, password, keyboard seings and default timezone.
Where are you?

Figure 1.5: Tell Ubuntu your location.

e next screen will display a world map. Using your mouse, click your
geographic location on the map to tell Ubuntu where you are. Alternatively,
you can type your location in the ﬁeld below the map. is allows Ubuntu
to conﬁgure your system clock and other location-based features. Click
Continue when you are ready to move on.
Keyboard layout

Figure 1.6: Verify that your keyboard layout is
correct.

Next, you need to tell Ubuntu what kind of keyboard you are using.
In most cases, you will ﬁnd the suggested option satisfactory. If you are
unsure which keyboard option to select, you can click the Detect Keyboard
Layout buon to have Ubuntu determine the correct choice by asking you
to press a series of keys. You can also manually choose your keyboard
layout from the list of options. If you like, enter text into the box at the

 

boom of the window to ensure you are happy with your selection, then
click Continue.
Who are you?

Ubuntu needs to know some information about you so it can set up the
primary user account on your computer. When conﬁgured, your name will
appear on the login screen as well as the user menu, which we discuss in
Chapter : e Ubuntu Desktop.
On this screen you will need to tell Ubuntu:
‣
‣
‣
‣
‣

your name
what you want to call your computer
your desired username
your desired password
how you want Ubuntu to log you in

Figure 1.7: Setup your user account.

Enter your full name under Your name. e next text ﬁeld is the name
your computer uses, for terminals and networks. You can change this to
what you want, or keep the predetermined name. Next is your username,
the name that is used for the user menu, your home folder, and behind the
scenes. You will see this is automatically ﬁlled in for you with your ﬁrst
name. Most people ﬁnd it easiest to stick with this. However, it can be
changed if you prefer.
Next, choose a password and enter it into both password ﬁelds. When
both passwords match, a strength rating will appear to the right that will
show you whether your password is “too short,” “weak,” “fair,” or “strong.”
You will be able to continue the installation process regardless of your
password strength, but for security reasons it is best to choose a strong
one. is is best achieved by having a password that is at least six characters long, and is a mixture of leers, numbers, symbols, and uppercase/lowercase. Avoid obvious passwords that include your birth date,
spouse’s name, or the name of your pet.
One account to log in to everything on Ubuntu

During the installation you have the possibility to log in into your existing
Ubuntu One account or to create a new one. Fill in all the needed information such as your email address and password and click Continue.
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If you don’t want to use Ubuntu One or if you want to create your new
account later, click Log in later.
Figure 1.8: Log in to your Ubuntu One account.

Login Options

Finally, at the boom of this screen you have two options regarding how
you wish to log in to Ubuntu. You may also choose to have Ubuntu encrypt
your home folder.
‣ Log in automatically
‣ Require my password to log in
– Encrypt my home folder
Log in automatically

Ubuntu will log in to your primary account automatically when you start
up the computer so you won’t have to enter your username and password.
is makes your login experience quicker and more convenient, but if
privacy or security are important to you, we don’t recommend this option.
Anyone who can physically access your computer will be able to turn it on
and also access your ﬁles.
Require my password to login

is option is selected by default, as it will prevent unauthorized people
from accessing your computer without knowing the password you created earlier. is is a good option for those who, for example, share their
computer with other family members. Once the installation process has
been completed, an additional login account can be created for each family
member. Each person will then have their own login name and password,
account preferences, Internet bookmarks, and personal storage space.
Encrypt my home folder

is option provides you with an added layer of security. Your home folder
is where your personal ﬁles are stored. By selecting this option, Ubuntu
will automatically enable encryption on your home folder, meaning that
ﬁles and folders must be decrypted using your password before they can
be accessed. erefore if someone had physical access to your hard drive

 

(for example, if your computer was stolen and the hard drive removed), they
would not be able to see your ﬁles without knowing your password.
If you choose this option, be careful not to enable automatic login at a later date.
It will cause complications with your encrypted home folder, and will potentially
lock you out of important ﬁles.

Finishing Installation

Ubuntu will now ﬁnish installing on your hard drive. As the installation
progresses, a slideshow will give you an introduction to some of the default
applications included with Ubuntu. ese applications are covered in more
detail in Chapter : Working with Ubuntu. e slideshow will also highlight
the Ubuntu support options:
Figure 1.9: Ubuntu community support options.
Where to get help for Ubuntu.

Aer approximately twenty minutes, the installation will complete and
you will be able to click Restart Now to restart your computer and start
Ubuntu. e  will be ejected, so remove it from your  drive and
press Enter to continue.
Figure 1.10: You are now ready to restart your
computer.

Wait while your computer restarts, and you will then see the login window (unless you selected automatic login).
Login Screen

Aer the installation has ﬁnished and your computer is restarted, you will
be greeted by the login screen of Ubuntu. e login screen will present you
with your username and you will have to enter the password to get past it.
Click your username and enter your password. Once done, you may click
the arrow or press Enter to get into the Ubuntu desktop. Ubuntu’s login
screen supports multiple users and also supports custom backgrounds for
each user. In fact, Ubuntu automatically will pick up your current desktop
wallpaper and set it as your login background.
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e login screen allows you to update your keyboard language, volume
intensity and enable/disable accessibility seings before you log in to your
desktop. It also displays date/time and baery power for laptops. You can
also shut down or restart your system from the login screen.
Figure 1.11: Login Screen.

2 The Ubuntu Desktop
Understanding the Ubuntu desktop

Initially, you may notice many similarities between Ubuntu and other
operating systems, such as Microso Windows or Mac  . is is because
they are all based on the concept of a graphical user interface ()—i.e.,
you use your mouse to navigate the desktop, open applications, move ﬁles,
and perform most other tasks. In short, things are visually-oriented. is
chapter is designed to help you become familiar with various applications
and menus in Ubuntu so that you become conﬁdent in using the Ubuntu
.
Figure 2.1: The Ubuntu 13.10 default desktop.

Unity

All -based operating systems use a desktop environment. Desktop environments encompass many things, including (but not limited to):
‣ e look and feel of your system
‣ e way the desktop is laid out
‣ How the desktop is navigated by the user
In Linux distributions (such as Ubuntu), a number of desktop environments are available. Ubuntu uses Unity as the default desktop environment.
Aer installing and logging in to Ubuntu, you will see the Unity desktop.
is initial view is comprised of the desktop background and two bars—a
horizontal one located at the top of your desktop called the menu bar and a
vertically-oriented bar at the far le called the Launcher.

To read more about other variants of Ubuntu,
refer to Chapter 8: Learning More.
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The Desktop Background

Below the menu bar at the top of the screen is an image covering the entire
desktop. is is the default desktop background, or wallpaper, belonging to
the default Ubuntu . theme known as Ambiance. To learn more about
customizing your desktop (including changing your background), see the
section on Customizing your desktop below.
The Menu Bar

e menu bar incorporates common functions used in Ubuntu. e icons on
the far-right of the menu bar are located in an area of the menu bar called
the indicator area, or notiﬁcation area. Each installation of Ubuntu may
contain slightly diﬀerent types and quantities of icons based on a number of
factors, including the type of hardware and available on-board peripherals
upon which the Ubuntu installation is based. Some programs add an icon to
the indicator area automatically during installation (e.g., Ubuntu One). e
most common indicators are:
Keyboard indicator ( ) allows you to select a keyboard layout, if more
than one keyboard layout is chosen. e keyboard indicator menu
contains the following menu items: Character Map, Keyboard layout
Chart, and Text Entry Seings.
Network indicator ( ) manages network connections, allowing you to
connect quickly and easily to a wired or wireless network.
Ubuntu One indicator ( ) allows you to backup ﬁles online and share ﬁles
with your friends, family, and coworkers.
Messaging indicator ( ) incorporates your social applications. From here,
among others, you can access instant messenger and email clients.
Sound indicator ( ) provides an easy way to adjust the sound volume as
well as access your music player and sound seings.
Clock displays the current time and provides a link to your calendar and
time and date seings.
Session indicator ( ) is a link to the system seings, Ubuntu Help, and
session options (like locking your computer, user/guest session, logging
out of a session, restarting the computer, or shuing down completely).
Every application has a menuing system where diﬀerent actions can be
executed in an application (like File, Edit, View, etc.); the menuing system
for an application is appropriately called the application menu. In Unity,
the application menu isn’t on the title bar of the application as is commonly
the case in other  environments. Instead, it is located to the le area
of the menu bar. To show an application’s menu, just move your mouse
to the desktop’s menu bar (at the top of the screen). While your mouse is
positioned here, the active application’s menu options will appear in the
desktop’s menu bar, allowing you to use the application’s menuing options.
When clicking on the desktop, the desktop’s menu bar reappears. is
capability in Unity to display the application’s menu only when needed is
especially beneﬁcial for netbook and laptop users with limited viewable
screen space. Apple uses a similar approach in   where all application
menus appear on a bar at the top of the screen. It diﬀers, however, in that
the menus in Ubuntu appear only when the mouse is over the desktop’s
menu bar.

For more about:

‣ the Ubuntu One indicator see Ubuntu One
on page 76;

‣ the Messaging indicator see Using instant
messaging on page 60;

‣ the Network indicator see Getting online on
page 39;

‣ the Session indicator see Session options on
page 34.

Figure 2.2: The indicators of the menu bar.

Note that some older applications may still
display their menu within the application
window.

   

The Launcher

e vertical bar of icons on the le side of the desktop is called the Launcher.
e Launcher provides easy access to applications, mounted devices, and
the Trash. All running applications on your system will place an icon in the
Launcher while the application is running.
To change the Launcher icon size, go to Session Indicator ‣ System
Settings ‣ Appearance, tab Look.
e ﬁrst icon at the top of the Launcher is the Dash, a component of
Unity. We will explore the Dash in a later section of this chapter. By default,
other applications appear in the Launcher, including the Files ﬁle manager,
LibreOﬃce, Firefox, any mounted devices, and the Trash, which contains
deleted folders and ﬁles, at the boom of the Launcher.
Holding the Super key, also known as the Windows key (Win key),
located between the le Ctrl key and Alt key, will cause Ubuntu to superimpose a number onto the ﬁrst ten applications in the Launcher and also
display a screen full of useful shortcuts. You can launch an application with
a number n on it by typing Super+n.
If you open more applications than can be shown in the Launcher, the
Launcher will “fold” the application icons at the boom of the Launcher.
Simply move your mouse to the boom of the Launcher, and you’ll see
the Launcher icons “slide” and the folded application icons unfold for easy
access.

Figure 2.3: The Ubuntu Launcher on the left
with a sample of applications on it.

Running applications

To run an application from the Launcher (or cause an already-running
application to appear), just click on the application’s icon.
Applications that are currently running will have one or more triangles
on the le side of the icon indicating the number of application windows
open for this application. Running applications also have a back-lit icon on
the Launcher.
e application in the foreground (i.e. the application that is on top of all
other open application windows is indicated by a single white triangle on
the right side of its icon.
You can also run an application through the Dash which will be explored
in the upcoming e Dash section.

Some also refer to an application in the
foreground as being in focus.

Adding and removing applications from the Launcher

ere are two ways to add an application to the Launcher:
‣ Open the Dash, ﬁnd the application you wish to add to the Launcher, and
drag its icon to the Launcher.
‣ Run the application you want to add to the Launcher, right-click on the
application’s icon on the Launcher, and select Lo to Launer.

Figure 2.4: The triangles on each side of the
Firefox icon indicate Firefox is in the foreground
and only one window is associated with Firefox
at this time.

To remove an application from the Launcher, right-click on the application’s icon, then select Unlo from Launer.
The Dash

e Dash helps you quickly ﬁnding applications and ﬁles on your computer.
If you’ve used Windows in the past, you’ll ﬁnd the Dash to be similar to
the Windows Start menu or the Start Screen in Windows . Mac users will

For more information about the Dash and its
lenses, see: https://wiki.ubuntu.com/Unity.
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ﬁnd the Dash similar to Launchpad in the dock. If you’ve used a previous
version of Ubuntu or another  Linux distribution, the Dash serves
as a replacement for the various   menus. e Dash allows you
to search for information, both locally (installed applications, recent ﬁles,
bookmarks, etc.) as well as remotely (Twier, Google Docs, etc.).
Figure 2.5: The Dash

To explore the Dash, click on the top-most icon on the Launcher; the
icon contains the Ubuntu logo on it. Aer clicking the Dash icon, the desktop will be overlaid by a translucent window with a search bar on top as
well as a grouping of recently accessed applications, ﬁles, and downloads.
Ubuntu also includes results from popular web services. e search bar
provides dynamic results as you enter your search terms.
Lenses

Searching is accomplished by utilizing one or more lenses, also known as
scopes; each lens is responsible for providing a category of search results
for the Dash. e seven lenses installed by default at the boom are links
to your Home lens ( ), Applications lens ( ), Files and Folders lens ( ),
Music lens ( ), Photo lens ( ), Videos lens ( ), and Social network
messages lens ( ).
Lenses act as specialized search categories in the Dash. From the user’s
perspective, lenses are simply icons. To the Ubuntu purist, the pictures that
appear horizontally at the boom of the Dash are lenses; to the rest, these
are icons.
Many sites exist on the Internet dedicated to creating and releasing
lenses for the Ubuntu Unity desktop. Some sites even teach you how to
make your own lenses in order to maximize the operational eﬃciencies of
the Ubuntu Unity interface.
Search for ﬁles and applications with the Dash

e Dash is an extremely powerful tool allowing you to search your computer for applications and ﬁles.

   

Find ﬁles/folders

e Dash can help you ﬁnd names of ﬁles or folders. Simply type a portion
of the ﬁle or folder name. As you type, results will appear in the Dash. e
Files and Folders lens will also assist in ﬁnding ﬁles or folders—showing
you the most recently accessed ﬁles as well as the most recent downloads.
You can use the ﬁlter results buon in the top-right corner of the Dash to
ﬁlter results by aributes such as ﬁle or folder modiﬁcation times, ﬁle type
(.odt, .pdf, .doc, .txt, etc.), or size.
Find applications

A standard Ubuntu installation comes with many applications. Users can
also download thousands more applications from the Ubuntu Soware
Center. As you collect an arsenal of awesome applications (and get a bonus
point for alliteration!), it may become diﬃcult to remember the name of a
particular application; the Applications lens on the Dash can assist with
this search. is lens will automatically categorize installed applications
under “Recently Used,” “Installed,” or “More Suggestions.” You can also
enter the name of an application (or a part of it) into the search bar in the
Dash, and the names of applications matching your search criteria will
appear. Even if you don’t remember the name of the application at all, type
a keyword that is relevant to that application, and the Dash will ﬁnd it. For
example, type music, and the Dash will show you the default music player
and any music player you’ve used.

Ubuntu Software Center and software management will be discussed in detail at Chapter 5:
Software Management.

If you are new to the world of Ubuntu, be sure
to read the Chapter 3: Working with Ubuntu.
It will provide you assistance in choosing
application(s) to suit your needs.

Figure 2.6: You can see the default results when
you press the Applications lens.

External search results

In addition to searching your local computer for applications and ﬁles, the
Dash will also search various online resources (e.g., Amazon.com). Results
pertinent to your search criteria are returned to you in the Dash. If you are
concerned about local search terms being sent over the Internet, you can
disable this feature in the Privacy section of the System Seings.
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e online search results within the Dash are turned on by default during installation. If you do not want external search results, go to System Settings ‣
Privacy ‣ Sear Results and set the “Include online search results” switch to
the Oﬀ position. As an added layer of privacy, you can also prevent any search
activity from being recorded.

Workspaces

Workspaces are also known as virtual desktops. ese separate views of
your desktop allow you to group applications together, and by doing so,
help to reduce cluer and improve desktop navigation. For example, you
can open all of your media applications in one workspace, your oﬃce suite
in another, and your web browser in a third workspace. Ubuntu has four
workspaces by default.
e workspaces feature is not activated by default in Ubuntu. To activate
workspaces, click on Session Indicator ‣ System Settings… ‣ Appearance
then click on the Behavior tab and click on the Enable workspaces box.
When this box is checked, you’ll notice another icon is added to the boom
of the Launcher that looks like a window pane. is is the workspaces
switcher.
Switching between workspaces

If you’ve activated the workspace switcher as described above, you can
switch between workspaces by clicking on the workspace switcher icon
located on the Launcher. is utility allows you to toggle through the
workspaces (whether they contain open applications or not) and choose the
one you want to use.
Managing windows

Figure 2.7: The workspace switcher on the
Launcher.

When opening a program in Ubuntu (such as a web browser or a text editor
—see Chapter : Working with Ubuntu for more information on using
applications)—a window will appear on your desktop. e windows seen in
Ubuntu are very similar to those in Microso Windows or Mac  . Simply
stated, a window is the box that appears on your screen when you start a
program. In Ubuntu, the top part of a window (the title bar) will have the
name of the application to the le (most oen, the title will be the same
as the application’s name). A window will also have three buons in the
top-le corner. From le to right, these buons represent close window,
minimize window, and maximize window. Other window management
options are available by right-clicking anywhere on the title bar.
Closing, maximizing, restoring, and minimizing windows

To close a window, click on the close buon ( ) in the upper-le corner of
the window—the ﬁrst buon on the le-hand side. e buon immediately
to the right of the close buon is the minimize buon ( ) which removes
the window from the visible screen and places it in the Launcher.
is buon doesn’t close the application; it just hides the application
from view. When an application is minimized to the Launcher, the le-side
of the icon in the Launcher will display a triangle showing you the application is still running. Clicking the icon of the minimized application will

Figure 2.8: This is the top bar of a window,
named title bar. The close, minimize, and
maximize buttons are in the top-left corner of
the window.

   

restore the window to its original position. Finally, the right-most buon
is the maximize buon ( ) which causes the application to completely ﬁll
the unused displayable space on the desktop. Clicking the maximize buon
again will return the window to its original size. If a window is maximized,
its top-le buons and menu are automatically hidden from view. To make
them appear, just move your mouse to the menu bar.
Moving and resizing windows

To move a window around the workspace, place the mouse pointer over the
window’s title bar, then click and drag the window while continuing to hold
down the le mouse buon. You can also move a window by holding the
Alt key and then clicking and holding the le mouse buon while pointing
at the title bar of the window and dragging the window to a new location.
To resize a window, place the pointer on an edge or corner of the window
so that the pointer turns into a larger, two-sided arrow (known as the resize
icon). You can then click and drag to resize the window.
Switching between open windows

In Ubuntu, there are many ways to switch between open windows.
. If the window is visible on your screen, click any portion of it to raise it
above all other windows.
. Use Alt+Tab to select the window you wish to work with. Hold down
the Alt key, and keep pressing Tab until the window you’re looking for
appears highlighted in the popup window. en, release the Alt key, and
the application highlighted in the popup will move to the foreground of
your desktop.
. Click on the corresponding icon on the Launcher by moving your mouse
to the le side of the screen and right-clicking on the application’s icon.
If the application has multiple windows open, double-click on the icon in
order to select the desired window.
. Press Ctrl+Super+D to hide all windows and display the desktop; the
same works to restore all windows.
Moving a window to diﬀerent workspace

To move a window to a diﬀerent workspace, verify that the window isn’t
maximized. If it is maximized, click on the right-most buon on the le
side of the title bar to restore it to its original size. en right-click on the
window’s title bar and select:
‣
‣
‣
‣

Move to Workspace Le, to move the window to the le workspace
Move to Workspace Right, to move the window to the right workspace
Move to Workspace Down, to move the window to the boom workspace
Move to Another Workspace, and then choose the workspace to where
you wish to move the window.

Note that the options available when moving windows to diﬀerent
workspaces depends on which workspace contains the window you are
moving. If the window exists in the lower-right workspace, you will not see
a Move to Workspace Down because there is no workspace available below
the lower-right quadrant of a four quadrant workspace.
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Window always on the top or on visible workspace

At times, you may want to force a window to always be in the foreground
so that it can be seen or monitored while you work with other applications.
For example, you may want to browse the web and, at the same time, view
and answer incoming instant message. To keep a window always in the
foreground, right-click on the window’s title bar, then select Always On
Top. is window will now be on the top of all windows opened in the
current workspace. If you want to have a window always on the top regardless of the workspace, right-click on the window’s title bar, then select
Always on Visible Workspace. is window will now be on top of all other
windows across all workspaces.
Browsing ﬁles on your computer

ere are two ways to locate ﬁles on your computer—search for them or access them directly from their folder. You can search for a ﬁle using the Dash
or the Files ﬁle manager. You can also use the Dash or Files ﬁle manager to
access commonly used folders (such as Documents, Music, Downloads) as
well as the most recently accessed ﬁles.
Your Home Folder

e Home folder is used to store personal ﬁles. Your Home folder matches
your login name and is created when your user account is created. When
opening your personal folder, you will see a collection of several folders,
including Desktop (which contains any ﬁles that are visible on the desktop),
Documents, Downloads, Music, Pictures, Public, Templates, and Videos.
ese folders are created automatically during the installation process. You
can add more ﬁles and folders as needed.
Files ﬁle manager

Just as Windows has Windows Explorer and Mac   has Finder to browse
ﬁles and folders, Ubuntu . uses the Files ﬁle manager by default.
The Files ﬁle manager window

When you select the Files shortcut in the Launcher, click on a folder in the
Dash, or double-click a folder on the desktop, Ubuntu should open the Files
ﬁle manager. e default window contains the following features:
menu bar e menu bar is located at the top of the screen. e Files menu
allows you to modify the layout of the browser, show, browse and remove bookmarks, open a Help document, open a new window, connect
to a server, or quit. Choosing Enter Location will open the Locations
text ﬁeld where you can enter any location directly.
title bar e title bar shows the name of the currently selected folder. It
also contains the Close, Minimize, and Maximize buons.
toolbar On the right side of the toolbar, there are ﬁve buons: Sear
(represented by a magnifying glass), View items as a grid, View items
as a list, View options (represented by a down arrow), and Location
options (represented by a cog); clicking on the Sear icon opens a ﬁeld
so you can search for a ﬁle or folder by name. Clicking on the options
buons Location options or View options opens a menu with options.

Folders are also called directories.

   

On the le side of the toolbar, you will see a representation of your
current browsing. is is similar to the history function in most web
browsers; it keeps track of where you are and allows you to backtrack if
necessary. You can click on any of the locations to navigate back through
the ﬁle browser. e buons Previous location and Next location allow
you to navigate through previously visited locations.
le pane e le pane of the ﬁle browser—titled Places—has shortcuts to
commonly used folders. You can also bookmark a folder through the
toolbar by choosing Location options (gear) ‣ Bookmark this Location.
Once you have bookmarked the folder, it should appear in the le pane.
Regardless of the folder you are currently browsing, the le pane will
always contain the same folders.
right pane e largest pane shows the ﬁles and folders within the folder
you are currently browsing.

Figure 2.9: Files ﬁle manager displaying your
home folder.

To navigate to a folder in Files, double-click on its icon; this may be in
the right pane, the le pane, or the toolbar.
Opening ﬁles

A ﬁle, in its simplest form, is data. Data can represent a text document,
database information, or other media such as music or videos. To open a
ﬁle, you can double-click on its icon. Ubuntu will to ﬁnd an appropriate application with which to open the selected ﬁle. In some cases, you may wish
to open the ﬁle with a diﬀerent application than the one Ubuntu selected.
To select an application, right-click the icon and select one of the Open
With options.
Creating new folders

To create a new folder from within the Files ﬁle manager, right-click in the
blank area of the right pane and select New Folder from the popup menu
(this action will also work on the desktop). Replace the default “Untitled
Folder” title with your desired label (e.g., “Personal Finances”). You can also
create a new folder by pressing Ctrl+Shift+N.
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Hidden Files and Folders

If you wish to hide certain folders or ﬁles, place a dot (.) in front of the
name (e.g., “.Personal Finances”). In some cases, it is impossible to hide ﬁles
and folders without preﬁxing them with a dot.
You can easily view hidden ﬁles by clicking View options ‣ Show Hidden
Files or by pressing Ctrl+H. Hiding ﬁles with a dot (.) is not a security
measure—it is simply a way to help you organize your ﬁles.
Copying and moving ﬁles and folders

You can cut, copy, and paste ﬁles or folders in the Files ﬁle manager by
right-clicking on the item and selecting the corresponding buon from the
popup menu. You can also use the keyboard shortcuts Ctrl+X, Ctrl+C, and
Ctrl+V to cut, copy, and paste ﬁles and folders, respectively.
Multiple ﬁles can be selected by le-clicking in an empty space (i.e.,
not on a ﬁle or folder), holding the mouse buon down, and dragging the
cursor across the desired ﬁles or folders. is “click-drag” action is useful
when you are selecting items that are grouped closely together. To select
multiple ﬁles or folders that are not positioned next to each other, hold
down the Ctrl key while clicking on each item individually. Once the
desired ﬁles and/or folders are selected, right-click on any of the selected
items to perform an action just like you would for a single item.
When one or more items have been “copied,” navigate to the desired
location, then right-click in an empty area of the window and select Paste
to copy them to the new location. While the copy command can be used
to make a duplicate of a ﬁle or folder in a new location, the cut command
can be used to move ﬁles and folders. at is, a copy will be placed in a new
location, and the original will be removed from its current location.
Note that when you “cut” or “copy” a ﬁle or folder, nothing will happen until you “paste” it somewhere. Paste will only aﬀect the most recent
item(s) cut or copied.
To move a ﬁle or folder, select the item to move, then click Edit ‣ Cut.
Navigate to the desired location, then click Edit ‣ Paste. If you click on
a ﬁle or folder, drag it, then hold down the Alt key and drop it to your
destination folder, a menu will appear asking whether you want to copy,
move, or link the item.
As with the copy command above, you can also perform this action using
the right-click menu, and it will work for multiple ﬁles or folders at once.
An alternative way to move a ﬁle or folder is to click on the item, and then
drag it to the new location.
Using multiple tabs and multiple Files windows

Opening multiple Files ﬁle manager windows can be useful for dragging
ﬁles and folders between locations. You can also have multiple tabs to
browse multiple locations at once.
To open a second window when browsing a folder in Files, select File ‣
New Window or press Ctrl+N. is will open a new window, allowing you
to drag ﬁles and/or folders between two locations. To open a new tab, click
Location options (cog) ‣ New Tab or press Ctrl+T. A new row will appear
above the space used for browsing your ﬁles containing two tabs—both will
display the folder you were originally browsing. You can click these tabs
to switch between them to click and drag ﬁles or folders between tabs the
same as you would between windows.

   

When dragging items between Files windows or tabs a small symbol
will appear over the mouse cursor to let you know which action will be
performed when you release the mouse buon. A plus sign (+) indicates
you are about to copy the item, whereas a small arrow means the item will
be moved. e default action will depend on the folders you are using.
Searching for ﬁles and folders on your computer

You can search for ﬁles and folders using the Dash or the Files ﬁle manager.

Search for ﬁles and folders quickly by pressing
Ctrl+F in Files and then typing what you want
to ﬁnd.

Search using the Dash

In the Dash, simply type your search terms in the search bar at the top of
the Dash.
Alternatively, you may use the Applications or Files & Folders lenses;
here you can use a ﬁlter to narrow down your search. Open the drop-down
menu on the right side of the search bar. If you’ve selected Applications,
you will be able to ﬁlter by application type. If you’ve chosen Files & Folders, you can ﬁlter by a host of options, including Last modiﬁed, Type (e.g.,
Documents), or Size. It is suﬃcient to type the ﬁrst few leers of the ﬁle or
folder for which you are searching.
Search using Files ﬁle manager

In Files ﬁle manager, click on the magnifying glass buon or press Ctrl+F.
is opens the search ﬁeld where you can type the name of the ﬁle or folder
you want to ﬁnd.
Customizing your desktop

Figure 2.10: You can change most of your
system’s settings here.

One of the advantages to a windowed environment through Unity is the
ability to change the look and feel of your desktop. Don’t like the default
Ubuntu theme? Do you have a picture of your third cousin’s aunt’s uncle’s
nephew’s pet chihuahua that you’d love to see on your desktop as wallpaper? All of this (and more) is possible through desktop customizations in
Unity. Most customizations can be reached via the Session Indicator and
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then selecting System Settings to open the System Seings application window. e Dash, desktop appearance, themes, wallpapers, accessibility, and
other conﬁguration seings are available here. For more information see
Session options.
Appearance

Figure 2.11: You can change the theme in the
Look tab of the “Appearance” window.

The Look tab

rough the Look tab you can change the background, fonts, and window
theme to further modify the look and feel of your desktop. To begin, open
Appearance by either right-clicking on your background and selecting
Change Desktop Baground or selecting Session Indicator ‣ System
Settings ‣ Appearance. Select the Look tab.
eme e “Appearance” window will display the current selected background wallpaper and theme. emes control the appearance of your windows, buons, scroll bars, panels, icons, and other parts of the desktop. e
Ambiance theme is used by default, but there are other themes from which
you can choose. Just click once on any of the listed themes to give a new
theme a try. e theme will change your desktop appearance immediately.
Desktop background To change the Baground, either select Wallpapers,
Pictures Folder, or Colors and Gradients from the drop-down list. When
Wallpapers is selected, you will see Ubuntu’s default selection of backgrounds. To change the background, simply click the picture you would like
to use. You’re not limited to this selection. To use one of your own pictures,
click the + buon and navigate to the image you would like to use. en
double-click the image, and the change will take eﬀect immediately. is
image will then be added to your list of available backgrounds. Selecting
Pictures Folder opens your Pictures folder where you can choose a picture
for the background. e Colors and Gradients buon allows you to set
the background to a solid or gradient color. Click on the Solid Color button, then the Pi a Color to choose a solid color. e Vertical Gradient
and Horizontal Gradient buons bring up two Pi a Color buons. Just

   

choose any two colors you like and see if you have achieved the desired
result.
Launcher icon size At the boom of the Look tab you ﬁnd a slider to
change the size of icons on the Launcher. You may choose from a range
between  and  pixels.
The Behavior tab

rough the behavior tab there are several options to change the behavior
of your desktop.
Auto-hide the Launcher Switch the Auto-hide the Launer to either show
the Launcher or reveal it when moving the pointer to the deﬁned hot spot.
When turned on, you can choose the reveal location—Le side or Top le
corner—and the reveal sensitivity.
Enable workspaces By default, workspaces are not enabled. You can enable
workspaces by checking this option.
Add show desktop icon to the launcher Check this option if you want to
show the desktop icon on the Launcher.
Accessibility

Ubuntu has built-in tools that make using the computer easier for people
with certain physical limitations. You can ﬁnd these tools by opening the
Dash and searching for “Universal Access” or by selecting Session Indicator ‣ System Settings ‣ Universal Access. Use the Seeing tab to manage the
text size, the contrast of the interfaces, enable a zoom tool, or even a screen
reader. Selecting high-contrast themes and larger on-screen fonts can assist
those with vision diﬃculties. You can activate “Visual Alerts” through the
Hearing tab if you have hearing impairment. You can also adjust keyboard
and mouse seings to suit your needs through the Typing and Pointing and
Cliing tabs, respectively.
Figure 2.12: Universal Access allows you to
enable extra features to make it easier to use
your computer.
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Orca screen reader

Orca is a useful tool for people with visual impairments. Orca comes preinstalled in Ubuntu. To run Orca, click on the Dash, type Orca, and click
on the displayed result. Orca is the “Screen Reader” part of Universal Access and can be launched once the “Screen Reader” is activated. Orca’s
voice synthesizer will activate and assist you through the various options
such as voice type, voice language, Braille, and screen magniﬁcation. Once
you have ﬁnished selecting your seings, you will need to log out of the
computer (Orca will oﬀer to do this for you). When you log back in, the
Orca seings you selected will automatically run every time you use your
computer.
Session options

When you have ﬁnished working on your computer, you can choose to log
out, suspend, restart, or shut down through the Session Indicator on the far
right side of the top panel.
Logging out

Logging out will leave the computer running but return the desktop to
the login screen. is is useful for switching between users, such as when
a diﬀerent person wishes to log in to their account or if you are ever instructed to “log out and back in again.” You can also log out by pressing
Ctrl+Alt+Del. Before logging out, always verify that you have saved your
work in any open application.
Suspend

To save energy, you can put your computer into suspend mode which will
save the current opened applications to internal memory, power oﬀ all
internal devices and hardware, and allow you to start back up more quickly.
While in a suspended state, the computer will use just a trickle of energy;
this is required because the session is saved to internal memory, and if no
power goes to internal memory, the data will be lost. To put your computer
in suspend mode, select suspend from the “Session Indicator”.
Rebooting

To reboot your computer, select Shut Down from the “Session Indicator”
and click the Restart icon.
Shut down

To totally power down your computer, select Power Oﬀ from the “Session
Indicator” and click Power Oﬀ.
Other options

From the “Session Indicator”, select Lo/Swit Account to either lock the
screen of the current user or switch user accounts. You can lock your screen
quickly by using the keyboard shortcut Ctrl+Alt+L. Locking your screen is
recommended if you are away from your computer for any amount of time.

   

Getting help
General Help

Like with any other operating system, Ubuntu has a built-in help reference
called the Ubuntu Desktop Guide.To access it, click on the Dash and type
Figure 2.13: The built-in system help provides
topic-based help for Ubuntu.

Help.

Alternatively, you can press F1 while on the desktop, or select Ubuntu
Help from the Help menu in the menu bar. Many applications have their
own help section which can be accessed by clicking the Help menu within
the application window.
Online Help

If you can’t ﬁnd an answer to your question in this manual or in the
Ubuntu Desktop Guide, you can contact the Ubuntu community through
the Ubuntu Forums (http://ubuntuforums.org).
Many Ubuntu users open an account on the forums to receive help and
in turn provide support to others as they gain more knowledge. Another
useful resource is the Ubuntu Wiki (https://wiki.ubuntu.com/community), a
website maintained by the Ubuntu community. On https://help.ubuntu.com
you ﬁnd the Oﬃcial Ubuntu Documentation. On this web page you can
choose between diﬀerent versions of Ubuntu.
Heads-Up Display help

Figure 2.14: The HUD (heads-up display) shows
application-speciﬁc help information based on
your general input.
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e  (heads-up display) is a keyboard-friendly utility to help you ﬁnd
commands, features, and preferences embedded deep within the stacked
menu structure of an application.
Activate the  by tapping the le Alt key on the keyboard. If you
want to know how to load Rhythmbox, the default music player in Ubuntu,
then just type rhythmbox in the  and the options related to Rhythmbox
will come up in the list of matching results. You can press the Enter key
to active the command. e  also works for some applications running
under WINE.  comes in handy in applications with deep menus such as
LibreOﬃce and Gimp.

3 Working with Ubuntu
All the applications you need

If you are migrating from a Windows or Mac platform, you may wonder
if the programs you once used are available for Ubuntu. Some of the programs you already use have native Linux versions. For those that don’t,
there are free and open source applications that will cover your needs. is
section will recommend some alternatives that will work well on Ubuntu.
Most of the applications listed in this section are available via the Soware Center. ose followed by an asterisk (*) can be downloaded directly
from their oﬃcial websites.
Oﬃce Suites

‣ Windows: Microso Oﬃce, LibreOﬃce
‣ Mac  : iWork, Microso Oﬃce, LibreOﬃce
‣ Linux: LibreOﬃce, KOﬃce,  Oﬃce, Kexi (database application)
In Ubuntu you may choose among many oﬃce suites. e most popular
suite is the LibreOﬃce (formerly OpenOﬃce). Included in the suite:
‣
‣
‣
‣
‣
‣

Writer—word processor
Calc—spreadsheet
Impress—presentation manager
Draw—drawing program
Base—database
Math—equation editor

LibreOﬃce Suite is installed by default. Note that Base is not installed by
default and it can be installed through Ubuntu Soware Center.
Email Applications

‣ Windows: Microso Outlook, Mozilla underbird
‣ Mac  : Mail.app, Microso Outlook, Mozilla underbird
‣ Linux: Mozilla underbird, Evolution, KMail
As with oﬃce suites, there are multiple options for email applications.
One very popular email application is Mozilla underbird, which is also
available for Windows. underbird is the default email application in
Ubuntu. Another option is Evolution—similar to Microso Outlook, it also
provides a calendar.
Web Browsers

‣ Windows: Microso Internet Explorer, Mozilla Firefox, Opera, Chromium,
Google Chrome
‣ Mac  : Safari, Mozilla Firefox, Opera, Chromium, Google Chrome
‣ Linux: Mozilla Firefox, Opera*, Chromium, Google Chrome*, Epiphany
e most popular web browsers can be installed directly from the
Ubuntu Soware Center. Opera is available for download from http://www.
opera.com/browser/download/. Google Chrome is available for download
from https://www.google.com/chrome/.
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PDF Readers

‣ Windows: Adobe Acrobat Reader, Foxit
‣ Mac  : Adobe Acrobat Reader
‣ Linux: Evince, Adobe Acrobat Reader, Okular
Evince is a user-friendly and minimalistic reader, and it is the default
 reader. If Evince doesn’t cover your needs, Adobe Acrobat Reader is
available for Ubuntu, too.
Multimedia Players

‣ Windows: Windows Media Player, 
‣ Mac  : icktime, 
‣ Linux: Totem, , MPlayer, Kaﬀeine
For multimedia, Ubuntu users have a wide variety of options for high
quality players. VLC is a perennial favorite among videophiles. e classic
and user-friendly Totem is the default media player in Ubuntu.
Music Players and Podcatchers

‣ Windows: Windows Media Player, iTunes, Winamp
‣ Mac  : iTunes
‣ Linux: Rhythmbox, Banshee, Amarok, Audacity, Miro
ere are several options for listening to music with Ubuntu: Rhythmbox
(installed by default) and Amarok among many others. ese applications
allow you to listen to music and to your favorite podcasts. Amarok is similar to Winamp. ere is Miro for those who watch video podcasts and 
shows from the Internet.
CD/DVD Burning

‣ Windows: Nero Burning , InfraRecorder
‣ Mac  : Burn, Toast Titanium
‣ Linux: Brasero, Kb, Gnome-baker
ere are several popular disk burning applications such as Gnomebaker, Brasero (Ubuntu’s default burner application),  burner, and Kb.
ese burners are powerful tools, oﬀering user-friendly interfaces and
many features. ey are all open source and free of charge!
Photo Management

‣ Windows: Microso Oﬃce Picture Manager, Picasa
‣ Mac  : Aperture, Picasa
‣ Linux: Shotwell, gumb, Gwenview, F-Spot
You can view and manage your favorite photos with Shotwell, Ubuntu’s
default photo manager, or with gumb, Gwenview, and F-Spot.
Graphics Editors

‣ Windows: Adobe Photoshop, 
‣ Mac  : Adobe Photoshop, 

Firefox and Google Chrome are also able to
view PDF ﬁles.

  

‣ Linux: , Inkscape
 is a very powerful graphics editor. You can create your own graphics, taper your photographs, and modify your pictures. , a powerful
alternative to Photoshop, covers the needs of novice users, professional
photographers, and designers alike.  is not installed by default, but the
application can be installed through the Ubuntu Soware Center.
Instant Messaging

‣ Windows: Windows Live Messenger, , Yahoo! Messenger, Google
Talk
‣ Mac  : Windows Live Messenger, , Yahoo! Messenger, Adium,
iChat
‣ Linux: Empathy, Pidgin, Kopete, aMSN
None of the other platform  clients have Linux versions. However,
you can use Pidgin, Empathy, or Kopete to communicate over most protocols including: , , Google Talk (Jabber/), Facebook, Yahoo!,
and . is means you need only one client to communicate with all of
your friends. e drawback is that some of these clients have limited video
support. If you are using  exclusively, aMSN may be worth a try.
VoIP Applications

‣ Windows: Skype, Google Video Chat
‣ Mac  : Skype, Google Video Chat
‣ Linux: Ekiga, Skype, Google Video Chat
VoIP technologies allow you to talk to people over the Internet. e
most popular application is Skype, which is available for Linux. An opensource alternative called Ekiga supports voice communication using the 
protocol. Note that Ekiga isn’t compatible with Skype.
BitTorrent Clients

‣ Windows: µTorrent, Vuze
‣ Mac  : Transmission, Vuze
‣ Linux: Transmission, Deluge, KTorrent, Flush, Vuze, BitStorm Lite
ere are a number of BitTorrent clients for Ubuntu: Transmission,
Ubuntu’s default client, is simple and light-weight. Deluge, Vuze, and KTorrent oﬀer many features and can satisfy the most demanding of users.
Getting online

is section of the manual will help you to check your connection to the
Internet and help you conﬁgure it where needed. Ubuntu can connect to the
Internet using a wired, wireless, or dialup connection. Ubuntu also supports
more advanced connection methods, which will be brieﬂy discussed at the
end of this section.
A wired connection is when your computer connects to the Internet
using an Ethernet cable. is is usually connected to a wall socket or a
networking device—like a switch or a router.
A wireless connection is when your computer connects to the Internet
using a wireless radio network—usually known as Wi-Fi. Most routers now
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come with wireless capability, as do most laptops and netbooks. Because of
this, Wi-Fi is the most common connection type for these types of devices.
Wireless connectivity makes laptops and netbooks more portable when
moving to diﬀerent rooms of a house and while travelling.
A dialup connection is when your computer uses a modem to connect to
the Internet through a telephone line.
NetworkManager

In order to connect to the Internet using Ubuntu, you need to use the NetworkManager utility. NetworkManager allows you to turn network connections on or oﬀ, manage wired and wireless networks, and make other
network connections, such as dialup, mobile broadband, and s.

(a)
(b)
(c)
Figure 3.1: The network connection states: (a)
disconnected, (b) wired, and (c) wireless.

Figure 3.2: Here you can see the currently active
connection is “Wired connection 1.”

You can access NetworkManager by using its icon found in the top panel.
is icon may look diﬀerent depending on your current connection state.
Clicking this icon will reveal a list of available network connections. e
current connection (if any) will have the word “disconnect” underneath it.
You can click on “disconnect” to manually disconnect from that network.
is menu also allows you to view technical details about your current
connection or edit all connection seings. In the image to the right, you
will see a check mark next to “Enable Networking.” Deselect “Enable Networking” to disable all network connections. Select “Enable Networking” to
enable networking again. is can be very useful when you are required to
turn oﬀ all wireless communications, like in an airplane.
Establishing a wired connection

If you are already online at this point as indicated by the NetworkManager
icon in the top panel showing a connection, then you may have successfully
connected during the Ubuntu setup process. You can also simply open a
browser and see if you have access to the Internet. If so, you do not need to
do anything for the rest of this section. If not, then continue reading.
If you have an Ethernet cable running from a wall socket or networking
device, such as a switch or router, then you will want to setup a wired
connection in Ubuntu.
In order to connect to the Internet with a wired connection, you need to
know whether your network supports  (Dynamic Host Conﬁguration
Protocol).  is a way for your computer to automatically be conﬁgured
to access your network and/or Internet connection.  is usually automatically conﬁgured on your router. is is usually the quickest and easiest
way of establishing a connection to the Internet. If you are unsure whether
your router is setup to use , you may wish to contact your ’s (Internet Service Provider) customer service line to check. If your router isn’t
conﬁgured to use  then they will also be able to tell you what conﬁguration seings you need in order to get online.

  



Automatic connections with DHCP

Figure 3.3: This window displays your IP address
and other connection information.

If your network supports , then you may already be set up for online access. To check this, click on the NetworkManager icon. ere should
be a “Ethernet Network” heading in the menu. If “Wired connection ” appears directly underneath, then your machine is currently connected and
probably setup for . If “Disconnected” appears in gray underneath the
wired network section, look below to see if an option labeled “Wired connection ” appears in the list. If so, click on it to aempt to establish a wired
connection.
To check if you are online, click on the NetworkManager icon in the
top panel and select the Connection Information option. You should see a
window showing details of your connection. If your  address is displayed
as ... or starts with ., then your computer was not successfully
assigned connection information through . If it shows another address
(e.g., ...), then it is likely that your  connection to the
router was successful. To test your Internet connection, you may want to
open the Firefox web browser to try loading a web page. More information
on using Firefox can be found later in this chapter.
Manual conﬁguration with static address

If your network does not support , then you need to know a few items
of information before you can get online. If you do not know any of this
information, then you call your .
‣ An  address—is is a unique address used for identifying your computer on the network. An  address is always given in four numbered
groups, separated by dots, for example, .... When connecting using , this address will periodically change (hence, the name
“dynamic”). However, if you have conﬁgured a static  address, your 
address will never change.
‣ A network mask—is tells your computer the size of the network to
which it is being connected. It is formaed the same way as the  address, but usually looks something like ....
‣ A gateway—is is the  address of the device that your machine looks
to for access to the Internet. Usually, this will be the router’s  address.
‣  server—is is the  address of the  (Domain Name Service)
server.  is what your computer uses to resolve  addresses to domain

An IP (Internet Protocol) address is a unique
number assigned to your machine so that your
router can identify you on the network. Think
of it like a phone number for your computer.
Having this unique address allows the router
to speak to your computer, and therefore
send/receive data.
If you are still not online after following these
steps, you may need to try setting up your
network connection manually using a static IP
address.
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names. For example http://www.ubuntu.com resolves to ....
is is the  address of the Ubuntu website on the Internet.  is
used so you don’t have to remember  addresses. Domain names (like
ubuntu.com) are much easier to remember. You will need at least one
 server address but you can enter up to three addresses in case one
server is unavailable. If you do not know your ’s  server addresses,
Google has  servers that anyone in the world can use for free. e
addresses of these servers are: Primary—... Secondary—....
To manually conﬁgure a wired connection, click on the NetworkManager
icon and select Edit Connections. Make sure you are looking at the Wired
tab inside the “Network Connections” window. e list may already have
an entry, such as “Wired connection ” or a similar name. If a connection is
listed, select it and click the Edit buon. If no connection is listed, click the
Add buon.
If you are adding a connection, you need to provide a name for the
connection. is will distinguish the connection being added from any
other connections added in future. In the “Connection Name” ﬁeld, choose a
name such as “Wired Home.”
Figure 3.4: In this window you can manually edit
a connection.

To setup the connection:
. Make sure that the Connect automatically option is selected under the
connection name.
. Switch to the v Settings tab.
. Change the Method to “Manual.”
. Click on the Add buon next to the empty list of addresses.
. Enter your  address in the ﬁeld below the Address header.
. Click to the right of the  address, directly below the Netmask header
and enter your network mask. If you are unsure, “...” is the
most common.
. Click on the right of the network mask directly below the Gateway
header and enter the address of your gateway.
. In the  Servers ﬁeld below, enter the address of your  server(s).
If you are entering more than one, separate them with commas—for
example, “..., ...”.
. Click Save to save your changes.

  

A  address is a hardware address for your computer’s network card. Entering
this information is sometimes important when using a cable modem connection.
If you know the  address of your network card, this can be entered in the
appropriate text ﬁeld in the Wired tab of the editing window. To ﬁnd the 
addresses for all installed networking devices, open a terminal window, and at
the command line prompt, type ifconfig. is will display a lot of information
about each of the network devices installed on the computer. e wired devices
will be labeled as LAN, LAN, etc. e wireless devices will appear as WLAN,
WLAN, etc.

When you have returned to the Network Connections screen, your
newly added connection should now be listed. Click Close to return to the
desktop. If your connection was conﬁgured correctly, the NetworkManager
icon should have changed to show an active wired connection. To test if
your connection is properly set up, simply open a web browser. If you can
access the Internet, then you are connected!
Wireless

If your computer is equipped with a wireless (Wi-Fi) card and you have a
wireless network nearby, you should be able to set up a wireless connection
in Ubuntu.
Connecting to a wireless network for the ﬁrst time

If your computer has a wireless network card, you can connect to a wireless
network. Most laptops and netbooks have a built-in wireless networking
card.
Ubuntu is usually able to detect any wireless network in range of your
computer. To see a list of wireless networks, click on the NetworkManager icon. Under the “Wireless Networks” heading you should see a list of
available wireless networks. Each network will be shown by its name and a
signal meter to the le showing its relative signal strength. e signal meter
looks like a set of bars similar to what is seen when viewing signal strength
of a cell phone. Simply put, the more bars, the stronger the signal. To improve speed and reliability of your wireless connection, try moving closer to
your router or wireless access point.
A wireless network can be open to anyone, or it can be protected with
a password. A small padlock will be displayed by the signal bar if any
wireless network within range are password-protected. You will need to
know the correct password in order to connect to these secured wireless
networks.
To connect to a wireless network, select the desired network by clicking
on its name within the list. is will be the name that was used during
the installation of the wireless router or access point. Most s (Internet
service providers) provide pre-conﬁgured routers with a sticker on them
detailing the current wireless network name and password. Most publicly
accessible wireless networks will be easily identiﬁable by the name used for
the wireless network—for example “Starbucks-Wireless.”
If the network is unprotected (i.e., the signal meter does not show a padlock), a connection should be established within a few seconds—and without a password required. e NetworkManager icon in the top panel will
animate as Ubuntu aempts to connect to the network. If the connection
is successful, the icon will change to display a signal meter. An on-screen
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notiﬁcation message will also appear informing you that the connection
was successful.
If the network is password-protected, Ubuntu will display a window
called “Wireless Network Authentication Required” as it tries to make a
connection. is means that a valid password is required to make a connection. is is what the screen should look like:
Figure 3.5: Enter your wireless network
password.

If you know the password, enter it in the Password ﬁeld and then click
on the Connect buon. As you type the password, it will be obscured from
view to prevent others from reading the password as you type it. To verify
the characters you are entering for the password, you can view the password by selecting the Show Password check box. en, you can make the
password obscure again by deselecting the Show password check box.
Once the password is entered, click on the Connect buon. e NetworkManager icon in the top panel will animate as Ubuntu aempts to connect
to the network. If the connection is successful, the icon will change to display a signal meter. An on-screen notiﬁcation message will also appear
informing you that the connection was successful.
If you entered the password incorrectly, or if it doesn’t match the correct password (for example if it has recently been changed and you have
forgoen), NetworkManager will make another aempt to connect to the
network, and the “Wireless Network Authentication Required” window will
re-appear so that you can re-type the password. You can hit the Cancel button to abort the connection. If you do not know the correct password, you
may need to call your ’s customer support line or contact your network
administrator.
Once you have successfully established a wireless connection, Ubuntu
will store these seings (including the password) to make it easier to connect to this same wireless network in the future. You may also be prompted
to select a keyring password here. e keyring stores passwords in one
place so you can access them all in the future by remembering just the
keyring password.
Connecting to a saved wireless network

Ubuntu will automatically try to connect to a wireless network in range
if it has the seings saved. is works on both open and secure wireless
networks.
If you have numerous wireless networks in range that are saved on
your computer, Ubuntu may choose to connect to one network while you
may want to connect to another network. To remedy this action, click on
the NetworkManager icon. A list of wireless networks will appear along
with their signal meters. Simply click on the network to which you wish to
connect, and Ubuntu will disconnect from the current network and aempt
to connect to the one you have selected.
If the network is secure and Ubuntu has the details for this network

  

saved, Ubuntu will automatically connect. If the details for this network
connection are not saved, are incorrect, or have changed, then you will be
prompted to enter the network password again. If the network is open (no
password required), all of this will happen automatically and the connection
will be established.
Connecting to a hidden wireless network

In some environments, you may need to connect to a hidden wireless network. ese hidden networks do not broadcast their names, and, therefore,
their names will not appear in the list of available wireless networks even
if they are in range. In order to connect to a hidden wireless network, you
will need to get its name and security details from your network administrator or .
To connect to a hidden wireless network:
. Click on NetworkManager in the top panel.
. Select Connect to a hidden wireless network. Ubuntu will then open
the “Connect to Hidden Wireless Network” window.
. In the Network name ﬁeld, enter the name of the network. is is also
known as the  (Service Set Identiﬁer). You must enter the name exactly how it was given to you. For example, if the name is “UbuntuWireless,” entering “ubuntu-wireless” will not work as the “U” and “W”
are both uppercase in the correct name.
. In the Wireless security ﬁeld, select one of the options. If the network
is an open network, leave the ﬁeld set to “None.” If you do not know the
correct seing for the ﬁeld, you will not be able to connect to the hidden
network.
. Click the Connect buon. If the network is secure, you will be prompted
for the password. Provided you have entered all of the details correctly,
the network should then connect, and you will receive an on-screen
notiﬁcation informing you that the connection was a success.
As is the case with visible wireless networks, hidden wireless network
seings will be saved once a connection is made, and the wireless network
will then appear in the list of saved connections.
Disabling and enabling your wireless card

By default, wireless access is enabled if you have a wireless card installed in
your computer. In certain environments (like on airplanes), you may need
to temporarily disable your wireless card.
To disable your wireless card, click on the NetworkManager icon and
deselect the Enable Wireless option. Your wireless radio will now be turned
oﬀ, and your computer will no longer search for wireless networks.
To reactivate your wireless card, simply select the Enable Wireless option. Ubuntu will then begin to search for wireless networks automatically.
If you are in range of a saved network, you will automatically be connected.
Many modern laptops also have a physical switch/buon built into the
chassis that provides a way to quickly enable/disable the wireless card.
Changing an existing wireless network

At times you may want to change the seings of a saved wireless network
—for example, when the wireless password gets changed.
To edit a saved wireless network connection:
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. Click on the NetworkManager icon and select Edit Connections…
. A “Network Connections” window will open. Click on the Wireless tab.
. By default, saved networks are in chronological order with the most
recently connected at the top. Find the network you want to edit, select
it, and click on the Edit buon.
. Ubuntu will now open a window called “Editing 〈connection name〉”,
where 〈connection name〉 is the name of the connection you are editing.
is window will display a number of tabs.
. Above the tabs, there is a ﬁeld called Connection name where you can
change the name of the connection to give it a more recognizable name.
. If the Connect automatically option is not selected, Ubuntu will detect
the wireless network but will not aempt a connection until it is selected from the NetworkManager menu. Select or deselect this option as
needed.
. On the Wireless tab, you may need to edit the  ﬁeld. A  is the
wireless connection’s network name. If this ﬁeld isn’t set correctly,
Ubuntu will not be able to connect to the wireless network in question.
. Below the  is a Mode ﬁeld. e “Infrastructure” mode means that
you would be connecting to a wireless router or Access Point. e “adhoc” mode is for a computer-to-computer connection (where one computer shares another’s connection) and is oen only used in advanced
cases.
. On the Wireless Security tab, you can change the Security ﬁeld. A
selection of “None” means that you are using an open network that
doesn’t require a password. Other selections in this tab may require
additional information:
 /-bit Key is an older security seing still in use by some older
wireless devices. If your network uses this method of security, you
will need to enter a key in the Key ﬁeld that will appear when this
mode is selected.
 -bit Passphrase is the same older security as above. However,
instead of having a key, your network administrator should have
provided you with a passphrase to connect to the network.
 &  Personal is the most common security mode for wireless
networking. Once you select this mode, you will need to enter a
password in the Password ﬁeld.
If your network administrator requires , Dynamic  or  &
 Enterprise then you will need to have the administrator help
you with those modes.
. In the v Settings tab, you can change the Method ﬁeld from “Automatic ()” to “Manual” or one of the other methods. For seing up
manual seings (also known as a static address), please see the section
above on manual setup for wired network connections.
. When you ﬁnish making changes to the connection, click Apply to save
your changes and close the window. You can click Cancel at any time to
close the window without saving any changes.
. Finally, click Close on the “Network Connections” window to return to
the desktop.
Aer clicking Apply, any changes made to the network connection will
take eﬀect immediately.

  



Other connection methods

ere are other ways to get connected with Ubuntu:
‣ With NetworkManager, you can conﬁgure mobile broadband connections to connect to the Internet through your cellular data carrier.
‣ You can connect to digital subscriber line () networks, a method of
connecting to the Internet through your phone line via a modem.
‣ It is also possible for NetworkManager to establish a virtual private
network () connection. ese are most commonly used to create a
secure connection to a workplace network.
e instructions for making connections using mobile broadband, , or
 are beyond the scope of this guide.
Browsing the web

Once you have connected to the Internet, you should be able to browse the
web. Mozilla Firefox is the default application for this in Ubuntu.
Figure 3.6: The default Ubuntu home page for
the Firefox web browser.

Starting Firefox

ere are several ways to start Firefox. By default Ubuntu has the Firefox
icon within the Launcher (the vertical bar down the le side of the screen).
Select this icon to open Firefox. Or, open the Dash (the top-most icon in the
Launcher) and search for firefox using the search box. If your keyboard
has a “” buon, you can press that buon to start Firefox.
Navigating web pages
Viewing your homepage

When you start Firefox, you will see your home page. By default, this is the
Ubuntu Start Page.
To quickly go to your home page, press Alt+Home on your keyboard or
press on the home icon in Firefox.
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Navigating to another page

To navigate to a new web page, you need to enter its Internet address (also
known as a ) into the Location Bar. s normally begin with “http://”
followed by one or more names that identify the address. One example
is “http://www.ubuntu.com/.” (Normally, you can omit the “http://” part.
Firefox will ﬁll it in for you.)

URL stands for uniform resource locator, which
tells the computer how to ﬁnd something on
the Internet—such as a document, web page or
an email address. WWW stands for World Wide
Web, which means the web pages by which
most people interact with the Internet.

Figure 3.7: You can enter a web address or
search the Internet by typing in the location bar.

To navigate:
. Double-click in the Location Bar, or press Ctrl+L, to highlight the 
that is already there.
. Enter the  of the page you want to visit. e  you type replaces
any text already in the Location Bar.
. Press Enter.
If you don’t know the  that you need, type a search term into the
Search Bar to the right of the Location bar. Your preferred search engine
—Google by default—will return a list of websites for you to choose from.
(You can also enter your query directly into the Location Bar).
Selecting a link

Most web pages contain links that you can select. ese are known as
“hyperlinks.” A hyperlink can let you move to another page, download a
document, change the content of the page, and more.
To select a link:
. Move the mouse pointer until it changes to a pointing ﬁnger. is happens whenever the pointer is over a link. Most links are underlined text,
but buons and pictures on a web page can also be links.
. Click the link once. While Firefox locates the link’s page, status messages will appear at the boom of the window.
Retracing your steps

If you want to visit a page you have viewed before, there are several ways
to do so.
‣ To go back or forward one page, press the Ba or Forward buon by
the le side of the Location Bar.
‣ To go back or forward more than one page, click-and-hold on the respective buon. You will see a list of pages you have recently visited. To
return to a page, select it from the list.
‣ To see a list of any s you have entered into the Location Bar, press
the down arrow at the right end of the Location Bar. Choose a page from
the list.
‣ To choose from pages you have visited during the current session, open
the History menu and choose from the list in the lower section of the
menu.
‣ To choose from pages you have visited over the past few months, open
the History ‣ Show All History (or press Ctrl+Shift+H). Firefox opens a
“Library” window showing a list of folders, the ﬁrst of which is “History.”
Select a suitable sub-folder, or enter a search term in the search bar (at

To go backwards and forwards you can also use
Alt+Left and Alt+Right respectively.

  



the top right), to ﬁnd pages you have viewed before. Double-click a
result to open the page.
Stopping and reloading

If a page is loading too slowly or you no longer wish to view a page, press
Esc to cancel it. To reload the current page if it might have changed since
you loaded it, press on the Reload buon or press Ctrl+R.

The Reload button is at the right end of the
Location Bar.

Opening new windows

At times, you may want to have more than one browser window open. is
may help you to organize your browsing session beer, or to separate web
pages that you are viewing for diﬀerent reasons.
ere are four ways to create a new window:
‣ On the top bar, select File ‣ New Window.
‣ Press Ctrl+N.
‣ Right-click on Firefox’s icon on the Launcher and select Open New
Window.
‣ Click on Firefox’s icon on the Launcher using your middle mouse buon.
Once a new window has opened, you can use it exactly the same as
the ﬁrst window—including navigation and opening tabs. You can open
multiple windows.
Opening a link in a new window

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own independent window.
ere are two ways to open a link in its own window:
‣ Right-click a link and select Open Link in New Window.
‣ Press-and-hold the Shift key while clicking a link.
Tabbed browsing

An alternative to opening new windows is to use Tabbed Browsing instead.
Tabbed browsing lets you open several web pages within a single Firefox
window, each independent of the other. is frees space on your desktop
as you do not have to open a separate window for each new web page. You
can open, close, and reload web pages in one place without having to switch
to another window.
You can alternate quickly between diﬀerent tabs by using the keyboard
shortcut Ctrl+Tab.
Opening a new blank tab

ere are three ways to create a new blank tab:
‣ Click on the Open new tab buon (a green plus-sign) on the right side of
the last tab.
‣ On the top bar, open File ‣ New Tab.
‣ Press Ctrl+T.

A new tab is independent of other tabs in the
same way that new windows are independent
of other windows. You can even mix-and-match
—for example, one window may contain tabs
for your emails, while another window has tabs
for your work.



    .

When you create a new tab, it contains a blank page with the Location
Bar focused. Type a web address () or other search term to open a website in the new tab.
Opening a link in its own tab

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own tab.
ere are several ways to open a link in its own tab.
‣ Right-click a link and select Open Link in New Tab.
‣ Press-and-hold the Ctrl key while clicking a link.
‣ Click the link using either the middle mouse buon or both le and right
mouse buons simultaneously.
‣ Drag the link to a blank space on the tab bar or onto the Open new tab
buon.
‣ Press-and-hold Ctrl+Shift while clicking a link.
Closing a tab

Once you have ﬁnished viewing a web page in a tab, you have various ways
to close it:
‣
‣
‣
‣

Click on the Close buon on the right side of the tab.
Click the tab with the middle mouse buon or the mouse wheel.
Press Ctrl+W.
Right-click the tab and select Close Tab.

Restoring a closed tab

Sometimes, you may close the wrong tab by accident, or want to bring back
a tab that you have recently closed. Bring back a tab in one of the following
two ways:
‣ Press Ctrl+Shift+T to re-open the most recently closed tab.
‣ Select History ‣ Recently Closed Tabs, and choose the name of the tab to
restore.
Changing the tab order

Move a tab to a diﬀerent location on the tab bar by dragging it to a new
location using your mouse. While you are dragging the tab, Firefox displays
a small indicator to show the tab’s new location.
Moving a tab between windows

You can move a tab into a new Firefox window or, if one is already open,
into a diﬀerent Firefox window.
Drag a tab away from the tab bar, and it will open into a new window.
Drag it from the tab bar into the tab bar of another open Firefox window,
and it will move there instead.
Searching

You can search the web from within Firefox without ﬁrst visiting the home
page of the search engine. By default, Firefox will search the web using the
Google search engine.

A tab always opens “in the background”—in
other words, the focus remains on the original
tab. The last method (Ctrl+Shift) is an
exception; it focuses the new tab immediately.

  



Searching the web

To search the web in Firefox, type a few words into the Firefox search Bar.
For example, if you want to ﬁnd information about Ubuntu:
. Move your cursor to the Sear Bar using your mouse or press Ctrl+K.
. Type the phrase Ubuntu. Your typing replaces any text currently in the
Search Bar.
. Press the magnifying glass or Enter to search.
Search results from Google for “Ubuntu” will appear in the Firefox window.
Selecting search engines

If you do not want to use Google as your search engine in the Search Bar,
you can change the search engine that Firefox uses.
To change your preferred search engine, press the search logo (at the
le of your Search Bar—Google by default) and choose the search engine of
your choice. Some search engines, such as Bing, Google and Yahoo, search
the whole web; others, such as Amazon and Wikipedia, search only speciﬁc
sites.

Figure 3.8: These are the other search engines
you can use—by default—from the Firefox
search bar.

Searching the web for words selected in a web page

Sometimes, you may want to search for a phrase that you see on a web
page. You can copy and paste the phrase into the Search Bar, but there is a
quicker way.
. Highlight the word or phrase in a web page using your le mouse button.
. Right-click the highlighted text and select Sear [Sear Engine] for
[your selected words].
Firefox passes the highlighted text to the search engine, and opens a new
tab with the results.
Searching within a page

Figure 3.9: You can search within web pages
using the Find Toolbar.

You may want to look for speciﬁc text within the web page you are
viewing. To ﬁnd text within the current page in Firefox:
. Choose Edit ‣ Find or press Ctrl+F to open the Find Toolbar at the
boom of Firefox.
. Enter your search query into the Find ﬁeld in the Find Toolbar. e
search automatically begins as soon as you type something into the ﬁeld.
. Once some text has been matched on the web page, you can:
‣ Click on Next to ﬁnd text in the page that is below the current cursor
position.
‣ Click on Previous to ﬁnd text that is above the current cursor position.
‣ Click on Highlight all to highlight all occurrences of your search
words in the current page.
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‣ Select the Mat case option to limit the search to text that has the
same capitalization as your search words.
To quickly ﬁnd the same word or phrase again, press F3.
You can skip opening the Find Toolbar altogether.
. Turn on the relevant Accessibility option with Edit ‣ Preferences ‣
Advanced ‣ General ‣ Accessibility ‣ Sear for text when I start typing ‣ Close.
. Now, provided your cursor is not within a text ﬁeld, when you start
typing, it will automatically start searching for text.
Viewing web pages full screen

To display more web content on the screen, you can use Full Screen mode.
Full Screen mode hides everything but the main content. To enable Full
Screen mode, choose View ‣ Full Screen or press F11. While in full-screen
mode, move your mouse to the top of the screen to reveal the  and
search bars.
Press F11 to return to normal mode.
Copying and saving pages

With Firefox, you can copy part of a page so that you can paste it elsewhere,
or save the page or part of a page as a ﬁle on your computer.
Copying part of a page

To copy text, links or images from a page:
. Highlight the text and images with your mouse.
. Right-click the highlighted text and select Copy, or press Ctrl+C.
To copy just a single image, it is not necessary to highlight it. Just rightclick the image and select Copy.
You can paste the results into another application, such as LibreOﬃce.
Copying a link

To copy a text or image link () from a page:
. Position the pointer over the text, link or image. Your mouse pointer
changes to a pointing ﬁnger.
. Right-click the link or image to open a pop-up menu.
. Select Copy Link Location.
You can paste the link into other applications or into Firefox’s Location
Bar.
Saving all or part of a page

To save an entire page in Firefox:
. Choose File ‣ Save Page As from the top bar, or press Ctrl+S. Firefox
opens the “Save As” window.
. Choose a location for the saved page.
. Type a ﬁle name for the page.

  



. Press Save.
To save an image from a page:
. Position the mouse pointer over the image.
. Right-click the image and select Save Image As. Firefox opens the “Save
Image” window.
. Choose a location for the saved image.
. Enter a ﬁle name for the image.
. Press Save.
Changing your home page

Firefox shows the home page when it opens. By default, this is the Ubuntu
Start Page. You can change your default home page to a new one, or even to
several new ones.
Figure 3.10: Change Firefox settings in this
window.

To change your home page:
. Navigate to the page that you would like to become your new home
page. If you want Firefox to open more than one tab when it starts, open
a new tab and navigate to the extra page as many times as you would
like.
. Choose Edit ‣ Preferences ‣ General ‣ Startup ‣ Use Current Pages ‣
Close.

The home page can also be set by entering the
addresses that should be open in the Home
Page, with a pipe (“|”) separating pages to be
opened in separate tabs.

Download settings

In Edit ‣ Preferences ‣ General ‣ Downloads, you can hide or show the
Downloads window, tell Firefox where to place downloaded ﬁles, and
whether or not to ask where each time.
Bookmarks

When browsing the web you may want to come back to certain web pages
again without having to remember the . To do this, you bookmark each
page. ese bookmarks are saved in the web browser, and you can use them
to re-open to those web pages.

The Downloads window shows the progress
of currently downloading ﬁles, and lists ﬁles
downloaded in the past. It can be used to open
or re-download ﬁles.
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Bookmarking a page

Aer navigating to a web page you can save its location by bookmarking it.
ere are two ways to bookmark a page:
‣ From the top bar, choose Bookmarks ‣ Bookmark is Page, or press
Ctrl+D. A window opens, allowing you to provide a descriptive name for
the bookmark and a location (within the browser’s bookmarks) to save it.
Press Done to save.
‣ Press the star on the right-hand side in the Location Bar. It turns yellow.
is saves the page in the Unsorted Bookmarks folder.
Navigating to a bookmarked page

To navigate to a bookmarked page, open the Bookmarks menu from the top
bar, and choose your bookmark. Firefox opens the bookmark in the current
tab.
You can reveal the bookmarks, including the Unsorted Bookmarks, in a sidebar
on the le of the browser window. Select View ‣ Sidebar ‣ Bookmarks, or press
Ctrl+B. Repeat, or press the close button at its top, to hide the sidebar.

Deleting or editing a bookmark

To delete or edit a bookmark, do one of the following:
‣ If you are viewing the page already, the star in the Location Bar will be
yellow. Press it. Firefox opens a small pop-up window, where you can
either Remove Bookmark or edit the bookmark.
‣ Select Bookmarks ‣ Show All Bookmarks or press Shift+Ctrl+O. In
the window that opens, you can navigate to bookmarks. Select the one
you would like to change. To delete, right-click and choose Delete or
press Delete on your keyboard. To edit, change the details shown at the
boom of the window.
History

Whenever you are browsing the web, Firefox saves your browsing history.
is allows you to come back to a web page that you have recently visited
without needing to remember or bookmark the page’s .
To see your most recent history, open the History menu from the top
bar. e menu displays several of the most recent web pages that you have
viewed. Choose one of the pages to return to it.
To view the complete history, either:
‣ Select View ‣ History or press Ctrl+H to view the history in a sidebar;
this replaces the bookmarks sidebar if it is open. (Repeat, or press the
close button at its top, to hide the sidebar.)
‣ Select History ‣ Show All History or press Shift+Ctrl+H to view the
history in a pop-up window.
Your browsing history is categorized as “Today,” “Yesterday,” “Last 
days,” “is month,” the previous ﬁve months by name, and ﬁnally “Older
than  months.” If the history for a category does not exist, that category
will not be listed. Select one of the date categories in the sidebar to expand

  



it and reveal the pages that you visited during that time. Once you ﬁnd the
page you want, select it to re-display it.
You can also search for a page by its title or . Enter a few leers
from one or more words or, optionally, the  in the Sear ﬁeld at the
top of the history sidebar. e sidebar displays a list of web pages matching
your search words. Select the page you want. (You can even do this in the
Location Bar, saving you from having to open the History sidebar or pop-up
window.)
Clearing private data

Firefox stores all its data only on your computer. Nevertheless, if you share
your computer, you may at times want to delete all private data.
Select Tools ‣ Clear Recent History or press Shift+Ctrl+Delete. Choose
your Time range to clear, and under Details which items to clear, and press
Clear Now.
Preventing Firefox from recording private data

You can start a “private browsing” session during which Firefox will not
record anything permanently. is lasts until you disable private browsing
or restart Firefox.
Choose Tools ‣ Start Private Browsing or press Shift+Ctrl+P. Press the
Start Private Browsing buon to conﬁrm. As long as you remain in this
mode, Firefox will not record browsing, download, form or search history,
or cookies, nor will it cache ﬁles. However, if you bookmark anything or
download ﬁles, these will be retained.
Repeat Tools ‣ Start Private Browsing or Shift+Ctrl+P, or restart Firefox, to end private browsing.
Using a diﬀerent web browser

Figure 3.11: The Default Applications where you
can change your preferred browser.

If you choose to install a diﬀerent web browser on your computer,
you may want to use it as the default browser when you click links from
emails, instant messages, and other places. Canonical supports Firefox and
Chromium (Google’s open-source version of Chrome), but there are several
others that you can install.
To change your preferred web browser, open Session Indicator from the
top panel on the far right-hand side, and open System Settings ‣ Details ‣
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Default Applications. Choose your preferred web browser from the dropdown menu Web.
Reading and composing email
Introduction to Thunderbird

underbird is an email client developed by Mozilla and is easy to setup and
use. It is free, fast, and comes packed full of useful features. Even if you are
new to Ubuntu and underbird, you will be up and running in no time,
checking your email and staying in touch with friends and family.
Setting up Thunderbird

In the top right corner of the Ubuntu desktop you will see an envelope
icon in the notiﬁcation area. is is the messaging menu. From here, you
can launch underbird by clicking Set up Mail. Alternatively, you can
click the Ubuntu buon in the top le corner of the screen at the top of the
Launcher to bring up the Dash and type thunderbird into the search box.
Once underbird opens, you will be greeted by a pop-up box prompting
you to setup your email account.
Figure 3.12: Setting up Thunderbird

Before a valid email account is set up in underbird, the ﬁrst screen to
appear will be an introductory message from Mozilla inviting you to set
up an email account through a local service provider in your area. For the
purposes of these instructions, we will assume you already have an email
address, so you can click on the buon in the lower right corner of the
screen that says Skip this and use my existing email.
On the next screen titled Mail Account Setup, enter your name in the
ﬁrst text box, your email address in the second text box (for example, username@domain.com), and your email password in the third text box.
Once completed, click the Continue buon. underbird will automatically set up your email account for you. When underbird ﬁnishes
detecting your email seings, click Create Account and underbird will do
the rest. You can also set underbird as your default news and  reader
by checking the boxes in the pop-up box that appear aer you click Create
Account. If you don’t want to see this message box every time you start
underbird, simply deselect Always perform this e when starting
underbird. You are now ready to start using underbird.

If Thunderbird fails to create the account,
you may need to conﬁgure it manually, using
the parameters that were sent to you by your
email address provider and your ISP. If you
are still unable to set up your account, you
can get help from community members at
http://ubuntuforums.org.

  

Around the Thunderbird workspace

Now that you have your email account set up, let’s get to know the underbird workspace. underbird is designed to be very user-friendly and
easy to navigate. When you open the application, you will see the main
workspace with your email folders (all folders window) on the le. On the
right of the screen, you will see two windows. e top-right window displays a list of your received email, and the boom-right window displays
the current email you are viewing. e size of these windows can be easily
resized to suit your viewing environment. To resize the windows, simply
le-click and hold the dividing bar that separates two windows and drag it
to the desired position. e All Folders window is where you can see your
mail folders. is window can also include:
Inbox Where your email is stored and accessed
Email address folder You will see one of these folders for each of the accounts you have setup
Dras Where your dra emails are stored
Sent mail Where the emails you have sent are stored
Spam is is where suspected spam email is stored so you can check them
to make sure you haven’t lost any important emails
Trash is is where messages you’ve deleted are stored so you can double
check to make sure you haven’t accidentally deleted an important email
(also one of the local folders)
Important is is where emails you have marked as important are stored
Starred is is where emails you have marked with a star are stored
Personal is is where emails you have marked as personal are stored
Receipts You can move important receipts to this folder.
Travel You can use this folder to store travel emails such as ﬂight times and
bookings
Work You can store work emails in this folder to keep them separate from
your personal email
Outbox Where the emails you are in the process of sending are stored (also
one of the local folders)
Across the top of the underbird workspace, you will see at least four
control buons, Get Mail, Write, Address Book, and Tag. ese are used to
get your mail, write your mail, access your address book, and tag your email
messages.
At the top-right of the All Folders window, you will see a set of quick
ﬁlter buons, Unread, Starred, Contact, Tags, and Attament. You can use
these buons to ﬁlter your email messages so that you only see your unread
mail, your favorite mail (starred), mail from people in your address book,
mail you have tagged, and mail that includes aachments.
If you are accustomed to a more traditional desktop and you have underbird maximized to full screen, you might be wondering where the menus
are located. ey are still there, and if you want to access them, move your
mouse to the top of the screen and you will see the familiar menus: File,
Edit, View, Go, Message, Tools, and Help.
At the top of the window that displays your email, you can see six action
buons, Reply, Reply All, Forward, Arive, Junk, and Delete. You will
ﬁnd these very useful for quickly replying to email, forwarding your email
to another person, archiving (backing up) your email, marking an email as
junk mail, and quickly deleting an email. To the le of these quick action
buons, you will see information about the email you are viewing that
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includes the sender’s name, the subject of the email, the reply address, and
the recipient of the email.
Using your address book

At the top of the main workspace, you will see the Address Book buon.
Click this buon to access your address book. e address book opens in a
new window. From here, you can easily organize your contacts. At the top
of the address book window, you will see ﬁve buons, New Contact, New
List, Properties, Write, and Delete. ey function in the following ways:
New Contact is buon allows you to add a new contact and add as much
detail as you wish to save, including name, nickname, address, email,
additional email, screen name, work number, home number, fax, pager
and mobile/cell number.
New List is buon allows you to add lists for your contacts such as
family, friends, acquaintances, etc.
Properties is buon allows you to rename your address book name. e
default name is personal address book, but you can change the name as
you see ﬁt.
Write is buon allows you to quickly send an email to a selected contact
without needing to go back to the main underbird workspace. Simply
select a contact from your contacts list and click the Write buon to
send them an email.
Delete is buon allows you to quickly delete a contact from your address
book. Just select the contact you want to delete and press Delete to
remove the contact from your address book.
Checking and reading messages

underbird will automatically check your email account for new messages every ten minutes, but if you need to manually check for new messages at any time, le-click the Get Mail buon in the top le corner of
the workspace. underbird will then check your email account for new
messages and download them.
As they are downloaded, you will see the new email appear in the message window on the right side of the workspace. When you click on one of
your emails, it will appear in the window below your email list. If you want
to view your email in a full window, double-le-click your chosen email,
and underbird will display the email in a full window in its own tab.
At the top of the open email, you will see information about the email
and the ﬁve quick action buons, Reply, Forward, Arive, Junk and
Delete as previously discussed. If an email has remote content, you will
see a message asking if you want to display the email or not.
You may want to ﬁlter your emails from time to time; this is easily done
with underbird. When you have an email selected and you want to tag
the email, simply click the Tag buon and a drop-down list will be displayed. In this drop-down list, you have the options to Remove All Tags or
Mark as…, Important, Work, Personal, To Do, Later. You can also create a
New Tag more suited to your own personal requirements.
Composing Messages

To compose a new email message, click the Write buon in the top le of
the workspace. is will bring up a new window where you can compose

Remote content represent parts of an email
that may be hosted elsewhere. Remote content
might consist of video or audio, but most
often is graphics or HTML content. For security
purposes, Thunderbird will ask you if you wish
to view this remote content.

  

your new email. In the To: ﬁeld, enter the email address of the destination
—the contact to whom you are sending this email. If there is more than one
contact to whom you are writing, separate multiple recipients with commas.
If a contact that you are addressing is in your address book, you can
address them by name. Start typing the name of the contact; underbird
will display the list of mailing contacts below your text. Once you see the
contact you intend to address, click on their email address or use the down
arrow key and then press Enter to select the address.
If you would like to carbon-copy (Cc) some contacts, click the To: ﬁeld
and select Cc:. Contacts who are listed on the To: and Cc: lines will receive
the email, and will see the rest of the contacts to whom an email was sent.
If you would like to send an email to some contacts without disclosing to
whom your email was sent, you can send a blind carbon-copy, or Bcc. To
enable Bcc, select Bcc: by clicking the To: ﬁeld and selecting Bcc:. Any
contacts entered in the Bcc: ﬁeld will receive the message, but none of the
recipients will see the names or emails of contacts on the Bcc: line.
Instead of typing the email addresses or names of the contacts you are
addressing in the message, you can select the contacts from your address
book. Start typing a few leers from your contact’s ﬁrst or last name in the
To: ﬁeld to ﬁlter the list to only show mailing contacts. Once you identify
the contact you would like to address, click on their name in the list. If
you’ve added the contact in error, delete their address and enter the correct
address.
You may enter a subject for your email in the Subject ﬁeld. Messages
should have a subject to help the recipient identify the general contents of
the email while glancing at their message list. Enter the contents of your
message in the big text ﬁeld below the subject. ere is no practical limit on
the amount of text you can include in your message.
By default, underbird will auto-detect the correct format for your
email but you can change this by clicking Options then mouse over Format
and select your preferred option from the list. You have a choice of AutoDetect, Plain Text Only, Rich Text (HTML) Only, and Plain and Rich (HTML)
Text.
When you have ﬁnished composing your email, click on the Send buon
on the window’s toolbar. Your message will be placed in the Outbox, and
will be sent to your desired recipient.



If you do not include a subject in your email,
Thunderbird will warn you about this omission.

Attaching ﬁles

At times, you may want to send ﬁles to your contacts. To send ﬁles, you
will need to aach them to your email message. To aach a ﬁle to an email
you are composing, click on the Atta buon. When the new window
opens, select the ﬁle you want to send and click Open. e ﬁle you selected
will then be aached to the email when you click send.
Replying to Messages

In addition to composing new messages, you may want to reply to messages
that you receive. ere are three types of email replies:
Reply or Reply to Sender sends your reply only to the sender of the message
to whom you are replying.
Reply to All sends your reply to the sender of the message as well as any
address in To: or Cc: lines.

You can attach quite a few diﬀerent ﬁle types
to emails, but be careful about the size of the
attachments! If they are too big, some email
systems will reject the email you are sending,
and your recipient will never receive it!
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Forward allows you to send the message, with any additional comments
you may add, to some other contacts.
To use any of these methods, click on the message to which you want
to reply and then click the Reply, Reply to All, or Forward buon on the
message toolbar. underbird will open the reply window. is window
should look much like the window for composing new messages, but the
To:, Cc:, Subject:, and main message content ﬁelds should be ﬁlled in from
the message to which you are replying. Edit the To:, Cc:, Bcc:, Subject: or
main body as you see ﬁt. When your reply is ﬁnished, click on the Send
buon on the toolbar. Your message will be placed in the Outbox and will
be sent.
Using instant messaging

Instant messaging allows you to communicate with people in real time
online. Ubuntu includes the Empathy application that lets you use instant
messaging features to keep in touch with your contacts. Empathy lets
you connect to many instant messaging networks. You can connect to:
Facebook, Google Talk, Windows Live, Salut, Jabber, Yahoo!, and . To
start Empathy, open the Messaging Menu (the envelope icon on the menu
bar), then select Empathy. Note that you will only ﬁnd it there aer you
have run Empathy for the ﬁrst time (see below).

Figure 3.13: This is the icon that Empathy
displays in the launcher.

Figure 3.14: Access Empathy from the Messaging Menu in the menu bar.

Running Empathy for the ﬁrst time

To run Empathy for the ﬁrst time you need to start it from the Dash (see
e Dash). You should see a screen similar to that in ﬁgure .. At this
time, Empathy does not know about any of your instant messaging accounts.
Adding accounts

You must have existing chat accounts to that are compatible with Empathy. If
you do not have an existing account, you will need to create one before continuing.

You can add accounts to be used with empathy by clicking the Account
Settings buon, as shown in ﬁgure ., or you can use the menu bar to
navigate to Empathy ‣ Accounts. You should see a dialog similar to that in
ﬁgure .. is is the Online Accounts manager.
Click Add account… on the le-hand side of the window if it is not
already selected. At the top of the window, where it says Show accounts that
integrate with:, select Empathy from the drop-down menu. Now click on

Be aware that when you Add or Remove
accounts using the Online Accounts manager
you will be adding or removing those accounts
to or from all the applications that they
integrate with, not just Empathy.

  



Figure 3.15: You should see a window like this
the ﬁrst time you open Empathy.

Figure 3.16: Add your existing chat accounts
for use in Empathy using the Online Accounts
manager.

the name of the chat service with which you have an account. Shown in
ﬁgure ., we have selected a Google account. You must now enter your
login credentials and authorize Ubuntu to access your account.
When you have authorized Ubuntu to access your account, you are
shown all the applications that integrate with the account, including Empathy. All the applications have an ON/OFF buon to control their integration with the account. Make sure the ON/OFF buon is set to ON for
Empathy. ere is also an Options buon for you to edit details used by
Empathy. e details shown are speciﬁc to each application. Aer adding
your accounts, you can now use Empathy to chat with all of your friends,
right from your Ubuntu desktop!
Communicating with contacts
Text

To communicate with a contact, select the contact in Empathy’s main window and double-click their name. Empathy should open a new window
where you can type messages to your contact and see a record of previously
exchanged messages.
To send a message to the contact, enter your message in the text ﬁeld
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Figure 3.17: You must enter your account
credentials and authorize Ubuntu to use your
account.

Figure 3.18: Chatting with friends in Empathy.

below the conversation history. When you have typed your message press
the Enter key to send the message to your contact. When the person you
are chaing with is typing to you, a small keyboard icon will appear next to
their name in the chat window.
If you are communicating with more than one person, then all of the
conversations will be shown either in tabs in your Empathy window or in
separate windows, depending on the option you have chosen in the menu
item Empathy ‣ Preferences.
Audio and Video Calling

You can use Empathy to chat with your friends using audio and video,
too. To start an audio or video call, right click on the Contact name, then
select Audio Call or Video Call, as shown in ﬁgure .. is will notify the
person you are trying to call, and they will be asked if they would like to
answer the call.
If the person you are calling accepts your call request, you will be connected, and you can begin talking. If the person you are calling cannot see
or hear you, your webcam or microphone may not be properly conﬁgured;
see the sections on Sound and Using a webcam, respectively. You can end
the call by clicking on the red telephone buon in the chat window.

Figure 3.19: Right-clicking a contact exposes
many ways to communicate.

  

Sending and receiving ﬁles
Sending a ﬁle

When you are in a conversation with a contact and you would like to send
them a ﬁle, right-click the contact in the contact list—as in ﬁgure .—
and select Send File. Empathy should open the “Select ﬁle” window. Find
the ﬁle you wish to send, and click on the Send buon. A “File Transfers”
window will open showing the ﬁle and its transfer progress. When the ﬁle
transfer is complete, you can close the “File Transfers” window.
Changing your status

You can use your status to show your contacts how busy you are or what
you are doing. Your contacts see your status next to your name when they
chat with you. You can use the standard statuses, which are:
‣
‣
‣
‣
‣

Available
Busy
Away
Invisible
Oﬄine

Two of these statuses have additional functionality. e Invisible status
lets you see which of your contacts are online, but does not allow them to
see that you are online. e Oﬄine status logs you out entirely; you will
not be able to see which of your contacts are online, nor can they see you or
chat with you.
You can change your status in one of two ways. e ﬁrst method is
in the main Empathy window from the drop-down list at the top of the
window.
e same drop-down list lets you set a custom status by choosing “Custom Message…” next to the icon that matches your status. Enter what you
would like your status to say, and click on the green check mark.
e second method is to click the Messaging Icon on the menu bar, as
shown in ﬁgure .. From this menu, you will see all of the same options
that Empathy presents, but accessible without having to open Empathy.
Desktop Sharing

Desktop sharing is a very nice feature available with Ubuntu. It can be used
for a lot of purposes, like troubleshooting, online meetings, or just showing
oﬀ your cool desktop to your friend. It is very easy to get remote desktop
sharing working between two Ubuntu machines.
To share your screen, you will ﬁrst have to set up Desktop Sharing. Open
the Desktop Sharing application from the Dash (see e Dash). Next, select
Allow other users to view your desktop; you may want to deselect Allow
other users to control your desktop.
Aer you have Desktop Sharing conﬁgured, open Empathy. To begin
sharing your desktop, right-click on the contact you wish to share your
desktop with, and select Share my desktop.
It should be noted that the other user will obviously be able to see the
information displayed on your screen. Please be sure to keep this in mind
if you have documents or ﬁles that are of a private nature open on your
desktop.
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Changing account settings

If you need to add more accounts aer the initial launch of Empathy, open
the Empathy menu on the menu bar, then select Accounts. Empathy will
then display the Online Accounts manager window.
Editing an account

You might need to edit the details of an account. Select the account you
want to change on the le side of the Online Accounts window then click
the Options buon for Empathy. e Online Accounts manager should
show the current information for the account. Once you have made your
changes, click Done.
Removing an account from Empathy

To stop an account from showing in Empathy, select the account on the
le hand side of the Online Accounts manager window. en click on the
ON/OFF buon for Empathy and set it to OFF.
Editing contacts
Adding a contact

To add a contact open Empathy ‣ Contacts ‣ Add contacts.. from the menu
bar. Empathy opens the “New Contact” window.
In the Account drop-down list, choose the account you want to add
contacts for. When creating a contact you must select the service that
matches the service your contact is using.
Aer choosing the account you wish to add the contact to, enter their
login , their username, their screen name, or their email address in the
Identiﬁer text ﬁeld. Next, in the Alias text ﬁeld, enter the name you want to
see in your contact list. Click Add to add the contact to your list of contacts.
Removing a contact

Right click on the contact that you want to remove, then select Remove.
is will open the “Removing contact” window. Click on the Delete buon
to conﬁrm that you want to remove this contact, or click Cancel to keep the
contact.
Viewing and editing photos

Shotwell Photo Manager is the default photo application in Ubuntu. is
application allows you to view, tag, edit, and share photos. To start Shotwell
Photo Manager, click on the Dash near the top-le of the screen, then select
the Shotwell Photo Manager icon labeled View Photos. If you do not see
Shotwell Photo Manager, simply type Shotwell in the search bar at the top
of the Dash; the Shotwell Photo Manager application will soon appear.
Importing Photos

When you launch Shotwell Photo Manager for the ﬁrst time, you will be
greeted with the “Welcome!” window which provides instructions on how
to import photos. Click OK. You can now import photos by dragging photos

  



Figure 3.20: Manage your photo collection,
enhance your photos while keeping the original,
and share your memories online using Shotwell
Photo Manager.

into the Shotwell Photo Manager window or by connecting your camera or
external storage device to the computer.
From a digital camera Connect your camera to the computer using the
data cable, and power on your camera. If your camera is properly detected,
you will see a new window prompting you to launch an application. Select
Shotwell Photo Manager in the drop-down menu, then click OK. Your
camera will be listed in the Shotwell Photo Manager sidebar. Select your
camera in the sidebar. You will see a preview of the contents stored in the
camera’s memory. Select individual photos by pressing and holding Ctrl
and clicking on each photo you want to import, and then click Import
Selected on the boom bar of the window. Or, you can choose to import all
photos by clicking Import All.
From your computer You can import photos into Shotwell Photo Manager
by dragging photos from the ﬁle browser into the Shotwell Photo Manager
window. Alternatively, you can click File ‣ Import From Folder, then select
the folder containing the photos you want to import.
From external hard drive,  ﬂash drive, or / Importing photos
from external storage is similar to importing from your computer. Your
external storage device may also appear under the Camera label on the
Shotwell Photo Manager sidebar. Follow the instructions for importing from
a camera or computer.
Choosing where Shotwell Photo Manager saves photos

e default location for the Shotwell Photo Manager Library is your Pictures folder in your home directory. When importing pictures using the
“Import” window, you will be given the option to copy the ﬁles to your
Library or keep the ﬁles in place.
If you have your photos stored on your computer, the option Import in
Place will be suitable. is will prevent photos from being duplicated. If
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you are importing photos from an external source, such as a portable hard
drive,  ﬂash drive, or /, you should select Copy into Library so
the photos are copied to your computer—otherwise the photos won’t appear
when you remove the external source.
Viewing photos

Choose Library or any collection in the sidebar to display photos from
your selection. Use the slider on the boom bar to adjust the size of the
thumbnails. To view a full-window image, double-click an individual photo.
In the full-window view, you can navigate through the collection using
the backward and forward arrows, zoom in on the image using the slider,
pan by clicking and dragging the image, and exit the full-window view by
double-clicking the image.
To view the collection in full-screen mode, press F11 or go to View ‣
Fullscreen. You can navigate through the collection using the toolbar by
moving your mouse to the boom of the screen. To view a slideshow presentation of the collection, press F5 or go to View ‣ Slideshow. Press the Esc
key to exit the Fullscreen or Slideshow views.
Organizing photos

Shotwell Photo Manager makes ﬁnding photos of the same type easier by
using tags. You can apply as many tags to a photo as you like. To apply tags
to photos, ﬁrst select the photos. en right-click on the photos and select
Add Tags. Enter the tags you want into the text ﬁeld, separated by commas.
If you are adding new tags, these will appear in the side bar on the right
under the Tags label.
Editing images

You may want to edit some of the photos you import into Shotwell Photo
Manager. For example, you may want to remove something at the edge,
adjust the color, reduce the red-eye eﬀect, or straighten the image. To edit a
photo, double-click on the photo you want to edit, and then click on one of
the following buons:
Rotate

Click Rotate to rotate the image ° clockwise. You can click the buon
more than once and it will rotate the image clockwise in ° intervals.
Crop

Click Crop to change the framing of the photo. e image will darken and a
selection will appear. Adjust the selection to your desired crop by dragging
a corner or side. If you want to choose a speciﬁc aspect ratio, use the dropdown menu to select one of the preset ratios or enter your own custom
ratio. A pivot buon is provided to change your selection from landscape to
portrait and vice versa. Once you are happy with the selection, click OK to
apply the crop or Cancel to discard it.

  

Red-eye reduction

If you have taken a photo and the ﬂash has caused the subject to have red
eyes, you can ﬁx this problem in Shotwell Photo Manager.
Click the Red-eye buon. A circle will appear.
Drag this circle over one of the subjects eyes and then use the slider to
adjust the circle size.
When the circle is over the eye, click Apply to ﬁx the red eye. You will
need to repeat this for each individual eye. Use caution when adjusting
the size of the circle. A circle too large that covers the skin may cause
discoloration when applying the red-eye reduction.
Adjust

Clicking Adjust will bring up a window that lets you edit a few things:
Level Similar to contrast
Exposure How bright the image is
Saturation How colorful the image is
Tint e overall color
Temperature Whether the image is warm (more yellow) or cool (more blue)
Shadows How dark the shadows are
To change these values, drag the sliders until you are satisﬁed with the
image. Click OK to apply the changes, Reset to undo the changes and start
over, or Cancel to discard the changes.
Auto-adjustment with Enhance

Click Enhance to let Shotwell Photo Manager automatically adjust the
color, levels, exposure, contrast, and temperature to create a more pleasing
image.
Reverting an edited photo to the original

When you edit a photo in Shotwell Photo Manager, your original image remains untouched. You can undo all of the changes and revert to the original
version by right-clicking on the photo, then selecting Revert to Original.
is option is only available for edited photos.
Sharing your photos

You can easily share your photos on the web using Shotwell Photo Managers’s Publish feature. Select the photos you want to share, then go to the
top menu and click File ‣ Publish. A new window will appear asking where
the photos are to be published. Choose Facebook, Flickr, or Picasa Web Albums in the upper right-hand drop-down menu. Some services may require
you to authorize Shotwell Photo Manager before allowing the application to
publish photos. Follow the instructions in the window, select your desired
options, and click Publish to upload your images to the web.
Further information

We’ve only just touched on the features of Shotwell Photo Manager. To
get more help, select Help ‣ Contents. is will load the online manual,
where you can get more detailed instructions on how to use Shotwell Photo
Manager eﬀectively.





    .

Watching videos and movies

To watch videos or s in Ubuntu, you can use the Videos application. To
start Videos, click on the Dash, then search for “Videos” and select it. is
will open the “Videos” window.
Figure 3.21: Videos (Totem) plays music and
videos.

Codecs

Watching s may require Ubuntu to install a coder-decoder (also known
as a “codec”), a piece of soware allowing your computer to understand the
contents of the  and display the video.
Legal Notice: Patent and copyright laws diﬀer depending on which country you
are in. Please obtain legal advice if you are unsure whether a particular patent or
restriction applies to a media format you wish to use in your country.

So that you can play all videos and s, you will need to install codecs.
To install the codecs, open the Ubuntu Soware Center either through the
Dash or the Launcher. When the “Ubuntu Soware Center” window opens,
use the search box in the top right and search for the following:
‣ ubuntu-restricted-extras
‣ libdvdread
‣ libdvdnav
Double-click each item above and then click the Install buon. is
may open an “Authenticate” window. If so, enter your password, then click
Authenticate to start the installation process.
Playing videos from ﬁle

Open the Movie menu, then select Open…. is will open the “Select
Movies or Playlists” window. Find the ﬁle or ﬁles that you want to play
and click on the Add buon. e video or videos will start playing.
Playing a DVD

When you insert a  in the computer, Ubuntu should open the “You have
just inserted a Video . Choose what application to launch” window.

  

Make sure that Open Movie Player is chosen in the drop-down list and
then click OK. e “Movie Player” window will open and the movie will
begin.
If the “Movie Player” window is already open, open the Movie menu,
then select Play Disc… and the movie will begin.
Listening to audio and music

Ubuntu comes with the Rhythmbox Music Player for listening to your
music, streaming Internet radio and managing playlists and podcasts.
Rhythmbox can also help you ﬁnd and purchase music, along with managing subscriptions to your favorite  feeds.
Figure 3.22: Rhythmbox Music Player

Starting Rhythmbox

ere are several ways to start Rhythmbox.
‣ Open the Dash, type Rhythmbox or Music and click on the Rhythmbox
Music Player icon.
‣ Ubuntu comes with an indicator menu in the top bar for sound-related
applications and devices. is indicator looks like a speaker. Aer you’ve
opened Rhythmbox the ﬁrst time, a link to start Rhythmbox and basic
controls will be placed here.
If you close Rhythmbox by pressing Alt+F4 or clicking the red close buon
( ), it will disappear from view but continue to play in the background.
You can still control your music or reopen from the sound indicator. To quit
Rhythmbox completely, press Ctrl+Q or choose Music ‣ it from the menu
bar.
Playing music

To play music, you must ﬁrst import music into your library. Choose Music ‣ Add Music… or press Ctrl+O on your keyboard to import a folder con-
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taining audio ﬁles. You can use the dropdown box to select the folder where
your music resides or click the Other option to ﬁnd an alternate folder.
e Rhythmbox toolbar contains most of the controls that you will use
for browsing and playing your music. If you want to play a song, doubleclick a track; or click it and press the Play buon on the toolbar, choose
Control ‣ Play from the menu bar, or press Ctrl+Space. When a song is
playing, the Play buon will become a Pause buon. Use this buon, Control ‣ Play, or Ctrl+Space to toggle between playing and pausing the track.
Next and Previous buons are next to the Play/Pause buon. Click on
these buons to play the next and previous songs in your library or playlist.
Rhythmbox also has options to toggle repeat mode (Repeat, Control ‣
Repeat or Ctrl+R) and shuﬄe mode (Shuﬄe, Control ‣ Shuﬄe or Ctrl+U).
Playing Audio CDs

To play your , insert it into your  drive. It will automatically appear
within Rhythmbox in the Side Pane beneath your Music Library. You can
click the  (named Audio , or the name of the album) and double-click a
track in it to play the tracks on the .
Importing (Ripping) Audio CDs

Begin by inserting a . Rhythmbox will automatically detect it and add it
to the side menu. If you have an active Internet connection, Rhythmbox will
try to ﬁnd the album details via the web. Click the . Uncheck any tracks
you don’t want imported. Press the Extract buon, located at the upper-le
corner of the right panel. Rhythmbox will begin importing the . As it
ﬁnishes each track, it will appear in your Music Library.
Listening to streaming audio

Rhythmbox is pre-conﬁgured to enable you to stream audio from various
sources. ese include Internet broadcast stations (Radio from the Side
Pane), Last.fm and Libre.fm. To listen to an Internet radio station, click on
the Radio icon in the Side Pane for a list of pre-conﬁgured stations. You can
ﬁlter by genre in the middle pane. To add a new radio station, select Add
and enter the radio station .
Connect digital audio players

Streaming audio stations are “radio stations”
that broadcast over the Internet. Some of these
are real radio stations that also stream over the
Internet, and others broadcast only over the
Internet.

You can browse a selected list of radio stations
at http://en.wikipedia.org/wiki/List_of_
Internet_stations or you can use your browser
to search for “Internet radio stations.”

Rhythmbox can connect with many popular digital media players. Connected players will appear in the Devices list. Features will vary depending
on the player (and oen the player’s popularity), but common tasks like
transferring songs and playlists should be supported. If your device isn’t
show on the Devices list, try searching for it by clicking on the Music ‣
Che for New Devices.
Listen to shared music

If you are on the same network as other Rhythmbox users (or most other
music player soware), you can share your music and listen to their shared
music. To do this, click Music ‣ Connect to DAAP Share… en enter the
 address and the port number. Click OK. Clicking a shared library will
enable you to browse and play songs from other computers.

DAAP stands for “Digital Audio Access Protocol,” and is a method designed by Apple to let
software share media across a network.

  

Figure 3.23: Rhythmbox connected to an
Android device

Manage podcasts

Rhythmbox can manage all of your favorite podcasts. Select Podcasts from
the Side Pane to view all added podcasts. e toolbar will display additional
options to Browse, Show All, Add and Update. Choose Add on the toolbar
and enter the  of the podcasts to save it to Rhythmbox. Podcasts will be
automatically downloaded at regular intervals or you can manually update
feeds. Select an episode and click Play. You can also delete episodes.
Party mode

Rhythmbox comes with the option of a “party mode.” To enter party mode
press F11 on your keyboard or use the global menu bar (View ‣ Party
Mode); to exit from party mode press F11 again. Rhythmbox also has a
browser bar that is enabled by default (this area is the top-right half of the
program window). It gives you the option to search your music by artist or
album.
Rhythmbox preferences

e default conﬁguration of Rhythmbox may not be exactly what you want.
Choose Edit ‣ Preferences to alter the application seings. e Preferences
tool is broken into four main areas: general, playback, music, and Podcasts.
General includes how you want Rhythmbox to display artist and track
information. You can adjust the columns visible in your library and how
the toolbar icons are displayed.
Playback options allow you to enable crossfading and the duration of the
fade between tracks.
Music includes where you would like to place your music ﬁles and the
library structure for new tracks added to Rhythmbox. You can also set
your preferred audio format.
Podcasts designates where podcasts are stored on your computer along
with the ability to change how oen podcast information is updated.
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Plugins

Rhythmbox supports a wide array of plugins, which add functionality to
Rhythmbox. Many of the plugins provide basic audio playback, and you
may check a few more boxes, for example, to access the Magnatune Store.
To view or change the activated plugins, use the global menu bar (Edit ‣
Plugins).
Managing your music

Rhythmbox supports creating playlists. Playlists either are static lists of
songs to be played in order, or can be smart playlists based on ﬁlter criteria.
Playlists contain references to songs in your library. ey do not contain
the actual songs, but only reference them. So, if you remove a song from
a playlist (right-cli on the song ‣ Remove from Playlist), the song will
remain in your library and on your hard drive.
To create a playlist, choose Music ‣ Playlist ‣ New Playlist, press Ctrl+N,
or right-click in the lower blank area of the side bar and select New Playlist.
It appears in the sidebar as “New Playlist.” Right-click and select Rename
to give the new playlist a name of your choosing. Drag songs from your
library to the new playlist in the side pane or right-click on songs and select
Add to Playlist and pick the playlist.
Smart Playlists are created in a similar way. Choose Music ‣ Playlist ‣
New Automatic Playlist or right-click in the lower blank area of the side
bar and select New Automatic Playlist. Deﬁne the ﬁlter criteria. You
can add multiple ﬁlter rules and select a name. Save. You can update any
playlist (including the predeﬁned ones) by right-clicking on the name and
choosing Edit.
Rhythmbox supports song ratings. Right-cli a song in your library ‣
Properties ‣ Details and click on the number of stars. To remove a rating,
select zero stars. Other song information such as Title, Artist and Album
can be changed. Right-cli a song in your library ‣ Properties ‣ Basic.
To remove a song, right-cli ‣ Remove. To delete a song from your hard
drive entirely, right-cli ‣ Move to the Rubbish Bin. If you ever want to
move a song, highlight the song (or group of songs) from your library and
drag it to a folder or to your desktop. is will make a copy of the audio ﬁle
in the new location.
Audio codecs

Diﬀerent audio ﬁles (, , , , etc.) require unique tools to decode them and play the contents. ese tools are called codecs. Rhythmbox
aempts to detect any missing codecs on your system so you can play all of
your audio ﬁles. If a codec is missing, it automatically tries to ﬁnd the codec
online and guides you through its installation.
Rhythmbox support

Rhythmbox is used by many users throughout the world. ere are a variety of support resources available in many languages.
‣
‣
‣
‣

Help ‣ Contents or F1 for the main help.
Help ‣ Get Help Online to ask questions and report bugs.
e Rhythmbox website at http://www.rhythmbox.org/.
e Multimedia & Video category of Ubuntu Forums at http://ubuntuforums.
org/forumdisplay.php?f=.

  



Burning CDs and DVDs

To create a  or , open the Dash and search for Brasero Disc Burner.
Once you ﬁnd Brasero, double-click it. is opens the Brasero application.
e burning options appearing within Brasero are explained below.
Figure 3.24: Brasero burns music, video, data
DVDs and CDs.

Getting Started

Before you can use Brasero, you need to Create a new project. ere are
three types of media projects available: Audio Project, Data Project, and
Video Project. ere are also two utility projects available: Disc Copy and
Burn Image. Make your selection based on your requirements.
e following options apply for all projects except Disc Copy and Burn
Image.
Adding ﬁles to a project

To add ﬁles to the list, click the + buon. is buon will open the “Select
Files” window. Navigate to the ﬁle you want to add, click the desired ﬁle,
then click the Add buon. Repeat this process for each ﬁle until all desired
ﬁles have been added.
Removing ﬁles

If you want to remove a ﬁle from the project, click the ﬁle in the list and
click on the - buon. To remove all the ﬁles in the list click on the Broom
shaped buon.
Saving a project

To save an unﬁnished project, choose Project ‣ Save. e “Save Current
Project” window will be opened. Choose where you would like to save the
project. In the Name: text ﬁeld, enter a name for the project. Click the Save
buon, and your unﬁnished project will be saved. When saving a project,
you are only saving the parameters of the project; you’ve burned nothing to
the disc at this time.

At this current time, Brasero does not support
Blu-Ray.
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Burning the disc

When you click the Burn… buon, you will see the “Properties of …” window.
You can specify the burning speed in the Burning speed drop-down. It is
best to choose the highest speed.
To burn your project directly to the disc, select the Burn the image
directly without saving it to disc option. With this option selected, no
image ﬁle is created, and no ﬁles are saved to the hard disk. All data is
saved to the blank  or . Note that Brasero only burns information
onto standard CDs and DVDs; Brasero does not burn data onto Blu-Ray
DVDs at this time.
e Simulate before burning option is useful if you encounter problems
burning discs. Selecting this option allows you to simulate the disc burning
process without actually writing data to a disc—a wasteful process if your
computer isn’t writing data correctly. If the simulation is successful, Brasero
will burn the disc aer a ten second pause. During those ten seconds, you
have the option to cancel the burning process.
Blanking a disk

Some CDs and DVDs have an  marking on them.  simply indicates
the disc is Re-Writable, meaning the current data on the disc can be completely erased and new data can be wrien to it. To erase a disc, open the
Tools menu, then select Blank. e “Disc Blanking” window will be open.
In the Select a disc drop-down choose the disc that you would like to erase.
You can enable the Fast blank option if you would like to shorten the
amount of time to perform the blanking process. However, selecting this
option will not fully remove the ﬁles; if you have any sensitive data on your
disc, it would be best not to enable the Fast blank option.
Once the disc is erased (blank), you will see e disc was successfully
blanked. Click the Close buon to ﬁnish.
Audio project

If you record your own music, then you may want to transfer this music
onto an audio  so your friends and family can listen. You can start an
audio project by clicking Project ‣ New Project ‣ New Audio Project.
When burning a music , it is important to remember that commercial
music s usually contains a two-second gap between the songs. To ensure
your music has this same gap between songs, click the ﬁle and then click
the pause buon.
You can slice ﬁles into parts by clicking the Knife buon. is opens a
“Split Track” window. e Method drop-down gives you four options; each
option lets you split the track in a diﬀerent way. Once you have split the
track, click OK.
In the drop-down list at the boom of the main “Brasero” window, make
sure that you have selected the disc where you want to burn the ﬁles. en
click the Burn buon.
Data project

If you want to make a back up of your documents or photos, it would
be best to make a data project. You can start a data project by clicking
Project ‣ New Project ‣ New Data Project.

  

If you want to add a folder, click the Folder picture, then enter the name
of the folder.
In the drop-down list at the boom of the main “Brasero” window, be
sure to select the disc where you want to burn the ﬁles. en click the Burn
buon.
Video project

If you want to make a  of your family videos, it would be best to make a
video project.
You can start a video project by clicking Project ‣ New Project ‣ New
Video Project.
In the drop-down list at the boom of the main “Brasero” window, be
sure to select the disc where you want to burn the ﬁles. en click the Burn
buon.
Disc copy

You can copy a disc by clicking Project ‣ New Project ‣ Disc copy. is
opens the “Copy /” window.
If you have two / drives, you can copy a disc from one to the
other, assuming the source disc is in one drive and the destination disc (with
blank media) is in the other drive. If you have only one drive you will need
to make an image and then burn it to a disc. In the Select disc to copy dropdown choose the disc to copy. In the Select a disc to write to drop-down
either choose image ﬁle or the disc that you want to copy to.
Image ﬁle

You can make an image ﬁle of your data as well An image is a single-ﬁle
representation of the contents of the disk. e ﬁle usually has an .iso or
.img extension. An image ﬁle is similar a set of zipped ﬁles. Change where
the image ﬁle is saved by clicking Properties. is shows the “Location for
Image File”. You can edit the name of the ﬁle in the Name: text ﬁeld.
e default location to save the image ﬁle is your home folder, but you
can change the location by clicking the + buon next to Browse for other
folders. Once you have chosen where you want to save the photo or image,
click Close.
Returning to the “Copy /” window, click Create Image. Brasero
will open the “Creating Image” window and will display the job progress.
When the process is complete, click Close.
Burn image

To burn an image, open the Project ‣ New Project ‣ Burn Image. Brasero
will open the “Image Burning Setup” window. Click on the Cli here to
select a disc image drop-down and the “Select Disc Image” window will
appear. Navigate your way to the image you wish to burn, click on it, and
then click Open.
In the Select a disc to write to drop-down menu, click on the disc to
which you’d like to write, then click Create Image.





    .

Working with documents, spreadsheets, and presentations

LibreOﬃce Suite is the default oﬃce suite when working with documents,
spreadsheets, and slide presentations.
Working with documents

If you need to work with documents, you can use the LibreOﬃce Word
Processor. Writer has all the features you need from a modern, full-featured
word processing and desktop publishing tool including an in-built PDF
creator. It’s simple enough for a quick memo, but powerful enough to create
complete books with contents, diagrams, indexes, and more. You’re free to
concentrate on your message, while Writer will make it look great. To start
the word processor, open the Dash and search for LibreOffice Writer.
en select LibreOﬃce Writer.
Working with spreadsheets

If you need to work with spreadsheets, you can use LibreOﬃce Spreadsheet
(Calc). Calc is the spreadsheet program you’ve always needed. Newcomers
ﬁnd it intuitive and easy to learn. Professional data miners and number
crunchers will appreciate the comprehensive range of advanced functions.
To start the spreadsheet application, open the Dash and search for LibreOffice Calc. en select LibreOﬃce Calc.
Working with presentations

If you need to work with slides for a presentation, you can use LibreOﬃce
Impress. Impress is a truly outstanding tool for creating eﬀective multimedia presentations. Your presentations can be enhanced with D and D clip
art, special eﬀects and transition styles, animations, and high-impact drawing tools. To start the presentation application, open the Dash and search
for LibreOffice Impress. en select LibreOﬃce Impress.
Getting more help

Each of these applications comes with a comprehensive set of help screens.
If you are looking for more assistance with these applications, press the F1
key aer starting the application.
Ubuntu One
What is Ubuntu One?

Ubuntu One is a service for storing your ﬁles online in your Ubuntu One
Personal Cloud. Your Ubuntu One Personal Cloud is your personal online storage space, and it can be accessed in any web browser or using an
Ubuntu One application (available for Ubuntu, Mac  , Windows, iPhone,
and Android). Because Ubuntu One stores your ﬁles online, it’s the perfect
way to backup your ﬁles to prevent data loss. You can also use Ubuntu One
to share ﬁles with other people—this makes Ubuntu One a great tool for
friends, families, and collaborative teams. Ubuntu One also provides services for backing up your contacts and streaming music to mobile devices.
e Ubuntu One service is provided by Canonical.

The LibreOﬃce Word Processor is known as
LibreOﬃce Writer. LibreOﬃce Spreadsheet is
known as Calc, and LibreOﬃce Presentation is
known as Impress.

  



How safe is Ubuntu One?

Before using Ubuntu One, you should keep the following points in mind:
‣ Uploading, downloading and synchronizing your information with
Ubuntu One is done over an encrypted connection which prevents anyone from eavesdropping on your information as it is being transferred.
‣ Files are not stored by Canonical in encrypted form. It is important to
keep this in mind when deciding what to upload to Ubuntu One. You can
use other means to encrypt you data, such as an encrypted zip ﬁle.
‣ Information uploaded to Ubuntu One can potentially be accessed by
Canonical. As with similar online services and websites, you are implicitly trusting them to respect your privacy, so if you feel you cannot trust
them with certain information, don’t upload it to Ubuntu One.
‣ If you violate the Ubuntu One terms and conditions and store illegal
material, Canonical may be required to hand the information over to law
enforcement agencies without your consent.
‣ Your online information can be accessed by anybody who knows (or can
guess) your account name and password. For this reason, you should
choose a strong password and keep it secure.
Getting started with Ubuntu One

To use Ubuntu One, you will need to create a free Ubuntu One account
using an email address. is free account gives you access to   of online
storage and the contact syncing service; this amount of space is enough
to store about , music ﬁles or , photographs (depending media
quality). Increased data storage or the music streaming service requires a
paid subscription.
ere are two ways to create an Ubuntu One account. You can either
sign up using the Ubuntu One Control Panel (pre-installed in Ubuntu), or
you can sign up on the Ubuntu One website https://one.ubuntu.com by
clicking the Sign Up link.
Figure 3.25: This Launcher icon opens the
Ubuntu One Control Panel.

Creating an Ubuntu One account using the Ubuntu One Control Panel

In the Launcher, click the Ubuntu One icon, as shown in ﬁgure .. is
should open the dialog shown in ﬁgure ..
Click the I don’t have an account yet – sign me up buon.
Fill in the details requested as shown in ﬁgure .. Make sure you use a
valid email address to which you are the only person who has access.
You will also see a captcha as part of the registration process. e
captcha acts as a check that it really is a person ﬁlling in the form and not a
computer (because a computer won’t be able to read the captcha text). You
should also review the Terms of Service and Privacy Policy before signing
up. When you’re satisﬁed, click Set Up Account.
Within a few minutes, you will receive an email containing the veriﬁcation code. Enter the veriﬁcation code into the box as shown in ﬁgure .
and click Next.
If all goes well, you will see a window saying, “You are now logged into
Ubuntu One.” Click the Finish buon to dismiss this window. You will

If you do not have an email address, you can get
one for free at gmail.com.
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Figure 3.26: The Ubuntu One Control Panel
Welcome Page.

Figure 3.27: Fill in all ﬁelds with your information to sign up for an Ubuntu One account.

Figure 3.28: Enter the veriﬁcation code into the
ﬁeld.

also receive another email welcoming you to Ubuntu One. Now that you
are logged in to Ubuntu One, you can conﬁgure your Ubuntu machine for
Ubuntu One ﬁle syncing.

  



Conﬁgure your Ubuntu machine for ﬁle syncing

e Ubuntu One desktop application syncs your Ubuntu One Personal
Cloud with ﬁles on your local ﬁle system. e term “sync” is short for
“synchronize”, meaning the contents of your Ubuntu One local ﬁle system
and your Ubuntu One Personal Cloud will be kept identical. Aer logging
into the Ubuntu One desktop application the following dialog (ﬁgure .)
should appear, allowing you to select which ﬁles to sync with your Ubuntu
One Personal Cloud.
Figure 3.29: This setup dialog lets you select
which existing Ubuntu One folders you would
like synced with your machine.

If you have already used your Ubuntu One account, you may have more
folders in this view (ﬁgure .). You can choose which Ubuntu One cloud
folders you would like synced with your local ﬁle system. If this is the ﬁrst
time you are using Ubuntu One, just click the Next buon.
You can also change your Ubuntu One sync connection seings at this time by
clicking on the Che Settings buon; you can change things like the maximum
upload and download rate, or if notiﬁcations should be allowed.

Figure 3.30: This setup dialog lets you select
which folders of your local ﬁle system you
would like synced with your Ubuntu One cloud
storage.

In the next dialog (ﬁgure .), you can choose which of your local ﬁle
system folders you would like synced with your Ubuntu One cloud storage.
e folder Ubuntu One is selected for syncing by default, but you can select
additional folders you may want synced—your pictures, for instance. Once
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you’re ﬁnished selecting folders, click the Finish buon to complete the
setup process. You are now ready to begin using Ubuntu One!
Using Ubuntu One with Files, the ﬁle manager

Ubuntu One integrates with Files, the program you use to view your ﬁle
system. You can add, sync, and share ﬁles directly from Files.
Adding and Modifying Files

You can add ﬁles to your Ubuntu One folder (or any other folder that you
have selected for sync) just as you normally would, and Ubuntu One will
automatically sync them to your personal cloud. For example, if you add
your vacation photos, you should see a notiﬁcation message on the screen
similar to ﬁgure ..
Figure 3.31: When you add ﬁles to an Ubuntu
One synced folder, they automatically sync to
your personal cloud.

Aer moving the ﬁles into the Ubuntu One synced folder, you should
receive a notiﬁcation informing you that syncing has begun. When syncing completes, the another notice will appear stating that the syncing has
completed.
Whenever you add or modify ﬁles that are in folders synced with Ubuntu
One, they will automatically sync to your personal cloud. Aer syncing is
complete, you can view the ﬁles on the Ubuntu One Web , and they will
also be synced to any other computers or mobile devices that you are using
Ubuntu One on.
Managing Folders to Sync

To view which ﬁles on your system are currently syncing with Ubuntu One,
open the Ubuntu One Control Panel by clicking the Ubuntu One Launcher
icon as shown in ﬁgure .; a dialog similar to that in ﬁgure . should
appear.
Figure 3.32: The Ubuntu One Control Panel
shows you which folders in your ﬁle system are
synced with your Ubuntu One Personal Cloud.

  



In the Ubuntu One Control Panel you can see which of your folders are
synced with your Ubuntu One Personal Cloud. You can also add ﬁles from
here, by clicking the Add a folder from this computer buon.
Using Ubuntu One with the Ubuntu One Web UI

You can access your ﬁles from any computer using the Ubuntu One Web 
at https://one.ubuntu.com. A Web UI (User Interface) is a web site that you
can go to and do the same things that you do on your computer. Emails, for
instance, are commonly accessed through a Web UI. When you ﬁrst reach
the web page, you will need to log in by clicking Log in or Sign up in the
upper right-hand corner of the page. On the following page, ﬁll in your
email address and Ubuntu One password, then click the Continue buon.
Once logged in, you should be taken to your Dashboard. e Dashboard
shows you a summary of your data usage and keeps you informed of new
features in Ubuntu One. To view your ﬁles, click the Files link in the navigation bar in the upper portion of the page.
Downloading and Uploading Files

To access your ﬁles from the Ubuntu One Web , you can simply download
them from your personal cloud. To download a ﬁle, click More shown to
the right of the ﬁle as shown in the browser, then click on Download ﬁle as
shown in ﬁgure .. Clicking Download ﬁle will initiate a ﬁle download
through your browser.
If you make changes to the ﬁle or want to add a new ﬁle to your personal
cloud, simply click the Upload ﬁle buon in the upper portion of the page.
is will upload the ﬁle into the current folder and overwrite any old versions of the ﬁle. Once you have uploaded the ﬁle, it will be available in your
personal cloud, and will sync to your Ubuntu machine’s local ﬁle system.
Figure 3.33: A ﬁle’s More button in the Web UI
gives you many options.
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Making Files Public

You can make a ﬁle public on the web by clicking More and choosing the
Publish ﬁle buon—this is also shown in ﬁgure .. Aer clicking the
Publish ﬁle buon, the Web  will generate a Public ; you can share
this  with anyone. By directing a browser to the Public  of the ﬁle,
the browser will begin to download the ﬁle or, depending on the type of ﬁle,
display it.
You can make the ﬁle private again at any time by clicking the Stop
publishing buon located to the le of the Public . Aer you click the
Stop publishing buon the Public  ﬁeld will go away, and the  will
stop working. If someone tries to use a Public  for a ﬁle that has been
made private, they will receive an error message and the ﬁle will not be
downloaded or displayed.
e Ubuntu One Control Panel, on your desktop, lists all of your public
ﬁles in one place under the Share links tab. is is a convenient way to
keep track of the ﬁles you are publishing, and allows you to easily copy
their links by clicking the Copy link buon located next to each public ﬁle.
Sharing Files

Ubuntu One lets you share ﬁles with other Ubuntu One users, leing you
collaborate on ﬁles with ease. When one user makes a change to a shared
ﬁle, the changes automatically sync to the other users’ personal clouds
and their local ﬁle system, so all users automatically have the most recent
version of the ﬁle.
Figure 3.34: Sharing folders with other users
makes collaborating on ﬁles simple.

To share ﬁles in Ubuntu One, you must share an entire folder. Before you
begin to share ﬁles, you should make sure only the ﬁles you want to share
are in this folder. en to share this folder, navigate to it in the Ubuntu One
Web  and click the More buon to the right of the folder name. In the
More menu, click on Share folder. A dialog box similar to that shown in
ﬁgure . should appear. Complete the ﬁelds in the dialog box, and click
the Share this folder buon when you are ﬁnished.

  

Once you share the folder, the user you are trying to share the folder
with should receive an email informing them that you would like to share
folder. ey will then have to accept the share request. If the email addressee you provide does not yet have an Ubuntu One account, they must
ﬁrst sign up for an Ubuntu One account before they can access the shared
folder.
To stop sharing a folder, navigate to it, click the More buon, and click
Stop sharing.
If another user shares a folder with you, you will receive an email informing you of the share, and a link to click on to accept the share request.
Folders that are shared with you by other users will appear in the Shared
With Me folder inside your Ubuntu One folder (~/Ubuntu One/Shared With
Me/).
To stop syncing ﬁles that are shared with you, navigate to the folder in
the Ubuntu One Web , click the More buon, then click the Delete this
share buon.
Exceeding your Ubuntu One Storage Limit

If you exceed the storage limit of your Ubuntu One account—  is the
free limit—Ubuntu One will stop syncing your ﬁles to your Ubuntu One
Personal Cloud.
Remedying an Exceeded Storage Limit

You can do several things to remedy an exceeded storage limit. Among
them are:
‣ Delete any ﬁles you no longer need.
‣ Move any ﬁles you no longer need synced to another location that is not
synced with Ubuntu One.
‣ Purchase additional storage space—you can purchase additional storage
in   blocks.
Purchasing Additional Storage Space

You can purchase additional storage space by clicking the Get more storage
buon at the top of the Ubuntu One Control Panel, or at https://one.ubuntu.
com/services/. Additional storage is available in   blocks. See https://
one.ubuntu.com/services/ for the price of additional storage blocks.
Getting Ubuntu One Mobile Apps
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Figure 3.35: You can purchase additional
storage space on the Ubuntu One website.
Note that the prices shown here were correct at
the date this manual was published.

Figure 3.36: Ubuntu One accepts credit cards,
and PayPal for purchasing additional storage.

Ubuntu One has mobile applications for Android and iPhone mobile
devices. ese applications allow you to access your personal cloud ﬁles
on-the-go. You can get more information about the Android and iPhone
applications at https://one.ubuntu.com/downloads/android/ and https://one.
ubuntu.com/downloads/iphone/, respectively.
Getting Ubuntu One for Windows or Mac

Ubuntu One also has standalone applications which can sync your Ubuntu
One Personal Cloud ﬁles to the ﬁle system of a Windows or Mac   operating system. More information can be found at https://one.ubuntu.com/

Figure 3.37: This is the icon for the Ubuntu One
Android and iPhone apps.

  

downloads/windows/ or https://one.ubuntu.com/downloads/mac/, respectively.
Music Streaming Service of Ubuntu One

In addition to ﬁle syncing, Ubuntu One oﬀers music streaming services.
is service is not discussed in this manual, but additional information can
be found at https://one.ubuntu.com/services/music/. e music streaming
service requires a paid subscription. See https://one.ubuntu.com/services/
for the price of the service and some aractive special oﬀers.



4 Hardware
Using your devices

Ubuntu supports a wide range of hardware, and support for new hardware
improves with every release.
Hardware identiﬁcation

ere are various ways to identify your hardware in Ubuntu. e easiest
would be to install an application from the Ubuntu Soware Center, called
Sysinfo.
Firstly, open the “Ubuntu Soware Center”, then use the search box in
the top right corner to search for sysinfo. Select the Application, click
Install. Enter your password when prompted, to install the application.
To run the application, search for Sysinfo at the Dash search bar. Click
on the program once you ﬁnd it. e Sysinfo program will open a window
that displays information about the hardware in your system.
Displays
Hardware drivers

A driver is a piece of soware which tells your computer how to communicate with a piece of hardware. Every component in a computer requires a
driver to function, whether it’s the printer,  player, hard disk, or graphics card.
e majority of graphics cards are manufactured by three well-known
companies: Intel, /, and  Corp. You can ﬁnd your video card
manufacturer by referring to your computer’s manual, by looking for the
speciﬁcations of your computer’s model on the Internet, or by using the
command lspci in a terminal. e Ubuntu Soware Center houses a number of applications that can tell you detailed system information. SysInfo is
one such program that you can use to ﬁnd relevant information about your
System devices. Ubuntu comes with support for graphics devices manufactured by the above companies, and many others, out of the box. at means
you don’t have to ﬁnd and install any drivers yourself, Ubuntu takes care of
it all.
Keeping in line with Ubuntu’s philosophy, the drivers that are used by
default for powering graphics devices are open source. is means that the
drivers can be modiﬁed by the Ubuntu developers and problems with them
can be ﬁxed. However, in some cases a proprietary driver (restricted driver)
provided by the company may provide beer performance or features that
are not present in the open source driver. In other cases, your particular
device may not be supported by any open source drivers yet. In those
scenarios, you may want to install the restricted driver provided by the
manufacturer.
For both philosophical and practical reasons, Ubuntu does not install
restricted drivers by default but allows the user to make an informed choice.
Remember that restricted drivers, unlike the open source drivers for your
device, are not maintained by Ubuntu. Problems caused by those drivers

Your graphics card is the component in your
computer which outputs to the display.
Whether you are watching videos on YouTube,
viewing DVDs, or simply enjoying the smooth
transition eﬀects when you maximize/minimize
your windows, your graphics device is doing the
hard work behind the scenes.
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will be resolved only when the manufacturer wishes to address them. To
see if restricted drivers are available for your system, go to System Settings,
then open Soware and Updates and go to the Additional Drivers tab. If
a driver is provided by the company for your particular device, it will be
listed there. You can simply click Activate to enable the driver. is process
requires an active Internet connection and it will ask for your password.
Once installation is complete you may have to reboot your computer to
ﬁnish activating the driver.
e Ubuntu developers prefer open source drivers because they allow
any problem to be identiﬁed and ﬁxed by anyone with knowledge within
the community. Ubuntu development is extremely fast and it is likely that
your device will be supported by open source drivers. You can use the
Ubuntu Live  to check your device’s compatibility with Ubuntu before
installing, or go online to the Ubuntu forums or to http://www.askubuntu.
com to ask about your particular device.

Another useful resource is the oﬃcial online
documentation (http://help.ubuntu.com), which
contains detailed information about various
graphics drivers and known problems. This
same documentation can be found by searching
for Help in the Dash search bar or by pressing
F1 on your keyboard.

Setting up your screen resolution

One of the most common display related tasks is seing the correct screen
resolution for your desktop monitor or laptop.
Ubuntu correctly identiﬁes your native screen resolution by itself and
sets it for you. However, due to a wide variety of devices available, sometimes it can’t properly identify your resolution.
To set or check your screen resolution, go to System Settings ‣ Displays.
e “Displays” window detects automatically the type of display and shows
your display’s name, size. e screen resolution and refresh rate is set to
the recommended value by Ubuntu. If the recommended seings are not to
your liking, you can change the same from the Resolution drop-down to
the resolution of your choice.
Adding an extra display

Sometimes, you may want to add more than one display device to your
desktop, or may want to add an external monitor to your laptop. Doing
this is quite simple. Whether it’s an extra monitor,  , or a projector,
Ubuntu can handle it all. Ubuntu supports the addition of multiple displays
by default, which is as easy as plug and play.
Ubuntu recognizes almost all the latest monitors, s and projectors
by default. Sometimes it may happen that your additional display is not
detected when you connect it to the machine. To resolve this, go to System Settings ‣ Displays and click on Detect Displays. is will detect the
monitors connected to the machine. is menu can also be found from the
Power Oﬀ menu on the top panel. You can also search for Displays at the
Dash search bar.
Now, there are two modes which you can enable for your displays. One
option is to spread your desktop across two or more monitors. is is particularly useful if you are working on multiple projects and need to keep
an eye on each of them at the same time. You can conﬁgure the screen to
be on any side of your primary screen i.e. to your right, your le or on the
top(particularly nice if you are working on a large screen i.e. a big monitor
or a TV connected to your - inch laptop); just move the screen on the
Displays seings to the side of your choice.
e second option is to mirror the desktop onto each of the displays.
is is useful when you are using a laptop to display something on a larger

Displays are made up of thousands of tiny
pixels. Each pixel displays a diﬀerent color,
and when combined they all display the image
that you see. The native screen resolution is a
measure of the amount of actual pixels on your
display.

 

screen e.g. projector. To enable this option just check the box beside Mirror displays and click Apply to save the seings. You will get a pop-up
notiﬁcation asking if you want to keep the current seing or revert to the
previous seing. Click to keep the current seing. Starting from Ubuntu
., you can also select whether you want the Unity Launcher in both
the displays or only in the primary display. Ubuntu . introduces beer
multi-monitor support for higher resolutions.
Connecting and using your printer

Ubuntu supports most new printers. You can add, remove, and change
printer properties by navigating to System Settings ‣ Printing. You can also
search for Printing from the Dash search bar. Opening Printing will display
the “Printing-localhost” window.
When you want to add a printer, you will need to make sure that it is
switched on, and plugged into your computer with a  cable or connected
to your network.
Adding a local printer

If you have a printer that is connected to your computer with a  cable
then this is termed a local printer. You can add a printer by clicking on the
Add Printer buon.
In the le hand pane of the “New Printer” window any printers that you
can install will be listed. Select the printer that you would like to install and
click Forward.
You can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally, click Apply.
Adding a network printer

Make sure that your printer is connected to your network either with an
Ethernet cable or via wireless and is turned on. You can add a printer by
clicking Add Printer. e “New Printer” window will open. Click the “+”
sign next to Network Printer.
If your printer is found automatically it will appear under Network
Printer. Click the printer name and then click Forward. In the text ﬁelds
you can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally click Apply.
You can also add your network printer by entering the  address of the
printer. Select “Find Network Printer,” enter the  address of the printer
in the box that reads Host: and press the Find buon. Ubuntu will ﬁnd the
printer and add it. Most printers are detected by Ubuntu automatically. If
Ubuntu cannot detect the printer automatically, it will ask you to enter the
make and model number of the printer.
Changing printer options

Printer options allow you to change the printing quality, paper size and
media type. ey can be changed by right-clicking a printer and choosing
Properties. e “Printer Properties” window will show; in the le pane,
select Printer Options.

If your printer can automatically do double
sided printing, it will probably have a duplexer.
Please refer to the instructions that came with
the printer if you are unsure. If you do have a
duplexer, make sure the Duplexer Installed
option is checked and then click the Forward
button.

The default printer is the one that is automatically selected when you print a ﬁle. To set a
printer as default, right-click the printer that
you want to set as default and then click Set As
Default.
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You can now specify seings by changing the drop-down entries. Some
of the options that you might see are explained.
Media size

is is the size of the paper that you put into your printer tray.
Media source

is is the tray that the paper comes from.
Color Model

is is very useful if you want to print in Grayscale to save on ink, or to
print in Color, or Inverted Grayscale.
Media type

Depending on the printer you can change between:
‣
‣
‣
‣
‣

Plain Paper
Automatic
Photo Paper
Transparency Film
 or  Media

Print quality

is speciﬁes how much ink is used when printing, Fast Dra using the
least ink and High-Resolution Photo using the most ink.
Sound

Ubuntu usually detects the audio hardware automatically during installation. Audio in Ubuntu is provided by a sound server named PulseAudio.
e audio preferences are easily conﬁgurable with the help of a very easy to
use  which comes preinstalled with Ubuntu.
Volume indicator and sound preferences

A volume icon is present on the top panel which provides quick access to a
number of audio related functions. When you click on the volume icon you
are greeted with four options: A mute option at the very top, a slider buon
which you can move horizontally to increase/decrease volume, a shortcut to
the default music player, Rhythmbox, and an option for accessing the Sound
Seings. Selecting Sound Seings opens up another window, which provides
access to options for changing input and output hardware preferences for
speakers, microphones and headphones. It also provides options for seing
the volume level for each application. Sound Seings can also be found
from System Settings. It is known as Sound.
Output e Output tab will have a list of all the sound cards available
in your system. Usually there is only one listed; however, if you have a
graphics card which supports  audio, it will also show up in the list.
e Output tab is used for conﬁguring the output of audio. You can in-

A microphone is used for making audio/video
calls which are supported by applications like
Skype or Empathy. It can also be used for sound
recording.
If you change your sound output device, it will
remain as default.

 

crease/decrease and mute/unmute output volume and select your preferred
output device. If you have more than one output device, it will be listed in
the section which reads “Choose a device for sound output.” e default
output hardware, which is automatically detected by Ubuntu during installation will be selected. is section also allows you to change the balance of
sound on the le and right speakers of your desktop/laptop.
Input e second tab is for conﬁguring audio Input. You will be able to
use this section when you have an in-built microphone in your system or
if you’ve plugged in an external microphone. You can also add a Bluetooth
headset to your input devices which can serve as a microphone. You can
increase/decrease and mute/unmute input volume from this tab. If there is
more than one input device, you will see them listed in the white box which
reads Choose a device for sound input. If you run voip applications such as
Skype, you will ﬁnd the microphone slider just below the volume slider in
the top panel sound menu during a voice or video call.
Sound Eﬀects e third tab is Sound Eﬀects. You can enable, disable, or
change the existing sound theme from this section. You can also change the
alert sounds for diﬀerent events.
Applications e Applications tab is for changing the volume for running
applications. is comes in handy if you have multiple audio applications
running, for example, if you have Rhythmbox, Totem Movie Player and a
web-based video playing at the same time. In this situation, you will be able
to increase/decrease, mute/unmute volume for each application from this
tab.

You should note that by default in any Ubuntu
installation, the input sound for mic is either
very low or muted. You will have to manually
increase the volume or unmute the input to
enable your microphone to record sound or use
it during audio/video calls.

By default, the volume in Ubuntu is set to
maximum during installation.
You can add new sound themes by installing
them from Software Center (e.g., Ubuntu
Studio’s GNOME audio theme.) You will get the
installed sound themes from the drop-down
menu. You can also enable window and button
sounds.
The Ubuntu Design Team have made a few
changes to the volume icon post Ubuntu 11.10.

More functionality

e icon can control various aspects of the system, application volume
and music players like Rhythmbox, Banshee, Clementine and Spotify. e
volume indicator icon can now be easily referred to as the sound menu,
given the diverse functionality of the icon. Media controls available include
play/pause, previous track, and next track. You can also switch between
diﬀerent playlists from the Choose Playlist option. If the current playing
song has album art, it will show up beside the name of the current track,
otherwise you will see only the details of the song. It displays the track
name, the artist name and the album name of the current track.

You can start and control the default music
player, Rhythmbox, by simply left clicking on
the sound menu and selecting Rhythmbox from
the list. Clicking the play button also starts the
player.

Using a webcam

Webcams oen come built into laptops and netbooks. Some desktops, such
as Apple iMacs, have webcams built into their displays. If you purchase a
webcam because your computer doesn’t have its own, it will most likely
have a  connection. To use a  webcam, plug it into any empty 
port of your desktop.
Almost all new webcams are detected by Ubuntu automatically. You can
conﬁgure webcams for individual applications such as Skype and Empathy
from the application’s setup menu. For webcams which do not work right
away with Ubuntu, visit https://wiki.ubuntu.com/Webcam for help.

There are several applications which are useful
if you have a webcam. Cheese can capture
pictures with your webcam and VLC media
player can capture video from your webcam.
You can install these from the Ubuntu Software
Center.
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Scanning text and images

Scanning a document or an image is very simple in Ubuntu. Scanning is
handled by the application Simple Scan. Most of the time, Ubuntu will
simply detect your scanner and you should just be able to use it. To scan a
document, follow these steps:
.
.
.
.
.
.
.

Place what you want to scan on the scanner.
Click to open the Dash and enter scan.
Click on Simple Scan.
Click to choose between Text or Photo from Document ‣ Scan ‣ Text.
Click Scan.
Click the Paper Icon to add another page.
Click Save to save.

You can save the scanned documents and pictures in . You can also
save in  format to enable opening in Acrobat Reader. To do that, add the
extension .pdf at the end of the ﬁlename.
Troubleshooting your scanner

If your scanner is not detected, Ubuntu may give you a “No devices available” message when trying to scan. ere may be a reason why Ubuntu
cannot ﬁnd your scanner.
‣ Simply unplug the scanner and plug it back in. If it is a newer  scanner, it is likely that it will just work.
‣ e driver for your scanner is not being automatically loaded. Restart
your system. It might help!
‣ Your scanner is not supported in Ubuntu. e most common type
of scanner not supported is old parallel port or Lexmark All-in-One
printer/scanner/faxes.
‣  project listing of supported scanners. e  (Scanner Access
Now Easy) project provides most of the back-ends to the scanning soware on Ubuntu.
‣ Check https://wiki.ubuntu.com/HardwareSupportComponentsScanners
to ﬁnd out which scanners work with Ubuntu.
Keyboard and mouse

e keyboard and mouse are essential input devices for a large number
of computer users today. ere are many diﬀerent makes and models of
keyboards and mice, including lots of keyboards with support for diﬀerent
languages.
In this section we will look at the diﬀerent seings for your keyboard
and mouse. is will be of great use to international users.
Keyboard

e keyboard is likely to be one of the main ways that you interact with
your computer. Unfortunately not all keyboards are uniform in design;
they can diﬀer by country, by language or appearance. In Ubuntu ., the
default language set for the keyboard now appears as an applet menu right
next to the Network Manager icon. Clicking on the keyboard applet menu
will show you what is the default language set for the keyboard and also

 

enable you to access three options : . Character Map . Keyboard Layout .
Text Entry Seings..
Mouse and Touchpad

A mouse is another mode of input and goes hand in hand with the keyboard. Ubuntu supports all types of plug and play mice, including touchpads and trackballs. If you are planning to use a mouse with your laptop,
just plug it in and Ubuntu will recognize it instantly.
ere is a seings menu under System Settings ‣ Mouse and Toupad where you can change the mouse seings such as double-click speed,
pointer speed, drag and drop threshold and le handed or right handed
clicks. If you are using touchpad on your laptop/netbook you can also increase the sensitivity of your touchpad. You can also enable horizontal, edge
scrolling and two ﬁnger scrolling on your laptop/netbook.

Figure 4.1: Keyboard applet menu.

Multitouch and gesture support

Introduced in Ubuntu ., multi-touch and gesture support has been
gaining good amount of aention from developers at Canonical. Ubuntu
now has full support for multitouch gestures. is means that anyone with
a touch-enabled device or interface can use the multitouch features. Once
triggered, resizing and moving windows in touch-friendly devices can be
done using three ﬁngered tap on an application window.
Ubuntu . improves upon the functionalities incorporated in Ubuntu
. for options to enable two-ﬁnger scrolling similar to Mac   laptops
and desktops. is seing can be enabled from System Setting ‣ Mouse
and Toupad ‣ Toupad. Select “Two-ﬁnger scrolling” from the Scrolling
options. You can also search for Mouse and Touchpad from the Dash search
bar and enable the option. Please note that enabling two ﬁnger scrolling
will disable edge scrolling.
Other devices
USB

 ports are available as standard on almost all computers available now.
ey are used to connect a multitude of devices to your computer. ese
could include portable hard drives, ﬂash drives, removable //Blu-ray
drives, printers, scanners and mobile phones.
When connected, ﬂash drives and portable hard drives are automatically
detected—the ﬁle manager will open and display the contents of the drive.
You can then use the drives for copying data to and from the computer.
All new cameras, camcorders and mobile phone  cards are automatically detected by Ubuntu. ese  cards have diﬀerent types of data, so a
window will appear with a drop-down menu to choose between video, audio import and the ﬁle manager—you can choose your desired action from
this menu.
Firewire

Firewire is a connection on some computers that allows you to transfer data
from devices. is port is generally used by camcorders and digital cameras.
If you want to import video from your camcorder you can do so by
connecting your camcorder to the Firewire port. You will need to install a

Firewire is oﬃcially known as IEEE 1394. It
is also known as the Sony i.LINK and Texas
Instruments Lynx.
To ﬁnd out more about Kino, visit http://www.
kinodv.org/.
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program called Kino which is available in the Ubuntu Soware Center.
Bluetooth

Bluetooth is a wireless technology that is widely used by diﬀerent types of
devices to connect to each other. It is common to see a mouse or a keyboard
that supports Bluetooth. You can also ﬁnd  devices, mobile phones,
headsets, music players and many other devices that can connect to your
desktops or laptop and let you transfer data, listen to music, or play games
as an example.
If your computer has Bluetooth support then you should be able to see
a Bluetooth icon on the top panel, usually on the le side of the volume
icon. If you click on the Bluetooth icon it will open a drop down menu with
choices to Turn on/oﬀ Bluetooth, to Turn on/oﬀ visibility of the device,
setup a access to a Bluetooth device and also access Bluetooth seings.
e Bluetooth preferences can also be accessed from System Settings ‣
Bluetooth. If you want to connect(pair) a new device—for example, to have
a mobile phone send pictures or videos to your computer—click on the
Bluetooth icon on the top panel and select Setup new device….
Ubuntu will open a window for new device setup. When you click Forward, Ubuntu will show you how many Bluetooth devices are present near
your computer. e list of available devices might take a minute or so to
appear on the screen as your system scans for these devices. Each device
will be displayed as soon as it is found by Ubuntu. Once a device you’d like
to connect with appears in the list, click on it. en, choose a  number
by selecting PIN options.
ree predeﬁned  numbers are available, but you can also create a
custom . You will need to enter this  on the device you will be pairing
with Ubuntu.
Once the device has been paired, Ubuntu will open the “Setup completed” window. In Ubuntu, your computer is hidden by default for security
reasons. is means that your Ubuntu system can search other Bluetooth
devices, but others cannot ﬁnd your Ubuntu system when they perform a
search on their own computer. If you would like to let another device ﬁnd
your computer, you will have to explicitly allow your computer to be found.
To allow your computer to be found by other bluetooth devices, turn ’on’
the “Visibility of yourcomputername” from System Settings ‣ Bluetooth. You
can also click on the Bluetooth icon and click on Visible to turn on visibility
which will make your computer discoverable.
You can also add a fancy name for your Bluetooth-enabled Ubuntu system by changing the text under Friendly Name.
Another feature present in the Bluetooth icon menu is “Send ﬁles to
device.” Use this option to send a ﬁle to a mobile phone without pairing
with the computer.

Figure 4.2: The Bluetooth applet menu.

When you pair two Bluetooth devices, you are
letting each device trust the other one. After
you pair two devices, they will automatically
connect to each other in the future without
requiring a PIN.

Android devices need to be paired at all times,
even while transferring ﬁles.

5 Software Management
Software management in Ubuntu

Installing soware in Ubuntu extends the functionality and usability of this
operating system. is chapter describes the way Ubuntu manages soware
installation and how it keeps all soware current.
Package management system

Ubuntu and various other Linux variants use a collection of soware tools
called a package management system, or package manager. A package manager is a collection of tools that make installing, deleting, upgrading, and
conﬁguring soware easy. A package management system has a database
of soware called a repository where individual soware is arranged into
a collection called a packages. ese packages, apart from the soware,
contain important information about the soware itself, such as the soware’s name, description, version, name of the vendor, and a list of various
dependencies upon which the soware relies for proper installation.
Most other operating systems require a user to purchase commercial
soware (online or through a physical store) or search the Internet for
a free alternative (if one is available). e correct installation ﬁle must
then be veriﬁed for integrity, downloaded, and located on the computer,
followed by the user proceeding through a number of installation prompts
and options. A package management system removes the user interaction
from these steps and automates most, if not all, of the installation process.
Ubuntu comes with a package management system called Advanced
Packaging Tool or .
As discussed in Chapter : Working with Ubuntu, Ubuntu oﬀers a wide
range of applications for your daily work. Ubuntu comes with a basic set
of applications for common tasks, like surﬁng the Internet, checking email,
listening to music, and organizing photos and videos. At times, you may
need an extra level of specialization. For example, you may want to retouch
your photos, run soware for your business, or play new games. In each of
these cases, you can search for an application, install it, and use it—usually
with no extra cost.
By default, Ubuntu provides a centralized point with two diﬀerent ways
to browse the repositories for searching, installing, and removing soware.
‣ Ubuntu Soware Center
‣ Command line apt-get
Ubuntu Soware Center makes searching, installing, and/or removing
applications easy and convenient; it is most oen the application management system used by both beginning and expert Ubuntu users. We highly
recommend the Ubuntu Soware Center for searching, installing, and
removing applications, although you can still use the command-line application apt-get or install and use the advanced application Synaptic Package
Manager. Since soware in Ubuntu is delivered in the form of packages,
soware installation becomes a one-click, one-step process when using the
Ubuntu Soware Center.

Figure 5.1: Software Center icon
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Using the Ubuntu Software Center

ere are numerous ways to install soware on an operating system. In
Ubuntu, the quickest and easiest way to ﬁnd and install new applications is
through the Ubuntu Soware Center.
To start the application, click on the Dash and search for Ubuntu Soware Center.
Figure 5.2: You can install and remove applications from your computer using the Software
Center.

e Ubuntu Soware Center can be used to install applications available
in the oﬃcial Ubuntu repositories. e Ubuntu Soware Center window has
four sections—a list of categories on the le, a banner at the top, a “What’s
New” panel below the top banner, then a “Recommended For You” panel,
and ﬁnally a “Top Rated” panel at the boom. Clicking on a category will
take you to a list of related applications. For example, the Internet category
contains the Firefox web browser application.
e featured areas highlight “What’s New” and “Top Rated” soware.
Each area shows diﬀerent application icons. Just click an icon to get more
information on the application or to install it. To see all soware contained
in the area, click the More buon in the upper-right corner of each panel.
e three sections at the top represent your current view of the Soware
Center’s catalog. Click the All Soware buon to see all installable soware, click the Installed buon to see a list of soware already installed on
your computer, and click History to see previous installations and deletions
organized by date.
Find your application

e Ubuntu Soware Center displays diﬀerent sources in the “All Soware”
section. Clicking the arrow next to “All Soware” will show a list of individual sections. Selecting “Provided by Ubuntu” will show free, oﬃcial
soware. “For Purchase” will show soware available to buy, and “Canonical Partners” will show soware from partners of Canonical, such as Adobe.
If you are looking for an application, you may already know its speciﬁc
name (for example,  Media Player), or you may just have a general
category in mind (for example, the Sound and Video category includes a

  

number of diﬀerent soware applications, such as video converters, audio
editors, and music players).
To help you ﬁnd the right application, you can browse the Soware Center catalog by clicking on the category reﬂecting the type of soware you
seek. When you select a category, you will be shown a list of applications.
Some categories have sub-categories—for example, the Games category has
subcategories for Simulation and Card Games. To move through categories,
use the ba and forward buons at the top of the window.
As you view a category of soware, you’ll notice a search box in the
upper-right corner of the window. is search box can be used for speciﬁc
names or keyword searches within this category.
Figure 5.3: Searching for an application in the
Ubuntu Software Center.

Installing software

Once you have found an application you would like to try, installing it is
just one click away.
To install soware:
. Click the Install buon to the right of the selected package. If you would
like to read more about the soware package before installing it, ﬁrst
click on More Info buon just below the selected soware. is will take
you to a short description of the application as well as a screenshot and
a web link when available. Related add-ons will be listed below the application’s description. You can click Install from this screen as well. You
must be connected to the Internet in order to install soware through the
Ubuntu Soware Center. To learn how to set up your Internet connection, see Geing online.
. Aer clicking Install, enter your password into the authentication window. is is the same password you use to log in to your account. You
are required to enter your password whenever installing or removing
soware in order to prevent someone without administrator access from
making unauthorized changes to your computer. If you receive an Authentication Failure message aer typing in your password, check that
you typed it correctly and try again.
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Figure 5.4: Here, clicking on “Install” will
download and install the package “Stellarium.”

. Wait until the package is ﬁnished installing. During the installation
(or removal) of programs, you will see an animated icon of rotating
arrows to the right of the History buon at the top of the screen. is
animated icon is labelled Progress. If you like, you can go back to the
main browsing window and choose additional soware packages to be
installed by following the steps above. At any time, clicking the Progress
buon on the top will take you to a summary of all operations that are
currently processing. You can also click the X to cancel any operation
listed.
Once the Soware Center has ﬁnished installing an application, it is
ready to be used. You can start the newly installed application by going to
the Dash and typing the name of the application in the search bar.
Removing software

Removing applications is very similar to installing soware. First, ﬁnd the
installed soware in the Ubuntu Soware Center. You can click on the
Installed buon to see all installed soware listed by categories. Scroll
down to the application you wish to remove. If you click on the arrow next
to the Installed buon, you will ﬁnd a list of soware providers, which can
help you narrow your search. You can also enter keywords into the Search
ﬁeld to quickly ﬁnd installed soware, or you can search by date in the
History tab (more on History below).
To remove soware:
. Click the Remove buon to the right of the selected application.
. Enter your password into the authentication window. Similar to installing soware, removing soware requires your password to help
protect your computer against unauthorized changes. e package will
then be queued for removal and will appear under the progress section at
the top.
Removing a package will also update your menus accordingly.

  

Figure 5.5: Here, clicking on “Remove” will
remove the package “SuperTux 2.”

Software history

e Ubuntu Soware Center keeps track of past soware management in
the History section. is is useful if you wish to reinstall an application
previously removed and do not remember the application’s name.
ere are four buons in the history section—All Changes, Installations,
Updates, and Removals. If you click the arrow next to a day, a list of individual packages will be shown, along with what was done with them and at
what time.
Software Recommendations

e Ubuntu Soware Center recommends soware based on the soware
already installed on your systems. When you enable recommendations,
a list of locally installed soware will be periodically sent to servers of
Canonical. Recommendations will appear in the same panel. If you want to
disable these recommendations, go to View ‣ Turn Oﬀ Recommendations.
Figure 5.6: You can turn on Software Recommendations via clicking on the Turn On
Recommendations button.

Figure 5.7: The “People Also Installed” section
shows applications installed by users who also
installed the application which you are about to
install.

Managing additional software

Although the Ubuntu Soware Center provides a large library of applications from which to choose, only those packages available within the
oﬃcial Ubuntu repositories are listed. At times, you may be interested in
a particular application not available in these repositories. It is important
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to understand alternative methods for accessing and installing soware in
Ubuntu, such as downloading an installation ﬁle manually from the Internet, or adding extra repositories. First, we will look at how to manage your
repositories through Soware & Updates.
Software Sources

e Ubuntu Soware Center lists only those applications that are available
in your enabled repositories. Repositories can be added or removed through
the Soware & Updates application. You can open Soware & Updates from
the Ubuntu Soware Center. Simply go to Edit ‣ Soware Sources… or open
the  (le Alt key) and search for “sources.”
Figure 5.8: The Software & Updates program
enables you to add, remove and manage
package repositories.

Managing the oﬃcial repositories

When you open Soware & Updates, you will see the Ubuntu Soware tab
where the ﬁrst four options are enabled by default.
Canonical-supported free and open-source soware (main) is repository
contains all the open-source packages maintained by Canonical.
Community-maintained free and open-source soware (universe) is repository contains all the open-source packages developed and maintained by
the Ubuntu community.
Proprietary drivers for devices (restricted) is repository contains proprietary drivers which may be required to utilize the full capabilities of
some of your devices or hardware.
Figure 5.9: Drivers can be installed or removed
via the Additional Drivers application.

  

Soware restricted by copyright or legal issues (multiverse) is repository
contains soware possibly protected from use in some states or countries
by copyright or licensing laws. By using this repository, you assume
responsibility for the usage of any packages that you install.
Source code is repository contains the source code used to build soware
packages from some of the other repositories. Building applications from
source is an advanced process for creating packages, and usually only
concerns developers. e Source code option should not be selected
unless you have experience with building applications from source.
Selecting the best software server

To distribute applications and soware, Ubuntu grants permission to many
servers all across the world to act as oﬃcial mirrors to host an exact copy of
all the ﬁles contained in the oﬃcial Ubuntu repositories.
When selecting a server, you may want to consider the following:
Distance to server. is will aﬀect the speed you can achieve with the ﬁle
server—the closer the server to your location, the faster the potential
connection.
Internet Service Provider. Some Internet service providers oﬀer low-cost or
unlimited free downloads from their own servers.
ality of server. Some servers may only oﬀer downloads at a capped
speed, limiting the rate at which you can install and update soware on
your computer.
Ubuntu will automatically choose an appropriate server while installing.
It is recommended these seings not be changed unless your physical location signiﬁcantly changes or if you feel a higher speed should be achieved
by your Internet connection. e guide below will help in choosing an
optimal server.
Ubuntu provides a tool for selecting the server that provides the fastest
connection with your computer.
Figure 5.10: You can use automatic selection or
choose a server manually.

. Click the dropdown box next to “Download from:” in the Soware &
Updates window.
. Select “Other…” from the list.
. In the “Choose a Download Server” window, click the Select Best Server
buon in the upper-right. Your computer will now aempt a connection
with all the available servers, then select the one with the fastest speed.
If you are happy with the automatic selection, click Choose Server to
return to the Soware & Updates window.
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If you are not happy with the automatic selection or prefer not to use
the tool, the fastest server is oen the closest server to you geographically.
In this case, simply choose “Other” then ﬁnd the nearest location to your
location. When you are happy with the selection, click Choose Server to
return to the Soware & Updates window.
If you do not have a working Internet connection, updates and programs
can be installed from the installation media itself by inserting your media
and clicking the box under “Installable from /.” Once this box
is checked, the media within the / drive will function as an
online repository, and the soware on the media will be installable from the
Ubuntu Soware Center.
Adding more software repositories

Ubuntu makes it easy to add additional third-party repositories to your list
of soware sources. e most common repositories added to Ubuntu are
called s. A  is a Personal Package Archive. ese are online repositories used to host the latest versions of soware packages, digital projects,
and other applications. s allow you to install soware packages that are
not available in the oﬃcial repositories. s also allow you to automatically be notiﬁed whenever updates for these packages are available.
If you know the web address of a ’s Launchpad site, adding it to your
list of soware sources is relatively simple. To do so, you will need to use
the Other Soware tab in the “Soware & Updates” window.
On the Launchpad site for a , you will see a heading to the le called
“Adding this PPA to your system.” Underneath will be a short paragraph
containing a unique  in the form of ppa:test-ppa/example. Highlight this
 by selecting it with your mouse, then right-click and select Copy.
Figure 5.11: This is an example of the Launchpad page for the Ubuntu Tweak PPA. Ubuntu
Tweak is an application that is not available
in the oﬃcial Ubuntu repositories. However,
by adding this PPA to your list of software
sources, it will be easy to install and update this
application through the Software Center.

Return to the “Soware & Updates” window, and in the Other Soware
tab, click Add… at the boom. A new window will appear, and you will
see the words “Apt line:” followed by a text ﬁeld. Right-click on the empty
space in this text ﬁeld and select Paste. You should see appear the  you
copied from the ’s Launchpad site earlier. Click Add Source to return
to the “Soware & Updates” window. You will see a new entry has been
added to the list of sources in this window with a selected check box in
front (meaning it is enabled).
If you click Close in the boom right corner of this window, a message

  

will appear informing you that “e information about available soware
is out-of-date.” is is because you have just added a new repository to
Ubuntu, and it now needs to connect to that repository and download a list
of the packages it provides. Click Reload, and wait while Ubuntu refreshes
all of your enabled repositories (including this new one you just added).
When it has ﬁnished, the window will close automatically.
Congratulations, you have just added a  to your list of soware
sources. You can now open the Ubuntu Soware Center and install applications from this  in the same way you previously installed applications
from the default Ubuntu repositories.
Manual software installation

Although Ubuntu has extensive soware available, you may want to manually install a soware package not available in the repositories. If no 
exists for the soware, you will need to install it manually. Before you
choose to do so, make sure you trust the package and its maintainer.
Packages in Ubuntu have a .deb extension. Double-clicking a package
will open an overview page in the Ubuntu Soware Center which will give
you more information about that package.
e overview provides technical information about that package, a
website link (if applicable), and the option to install. Clicking Install will
install the package just like any other installation in the Ubuntu Soware
Center.
Figure 5.12: Installing .deb ﬁles manually using
software center.

Updates and upgrades

Ubuntu also allows you to decide how to manage package updates through
the Updates tab in the Soware & Updates window.
Ubuntu updates

In this section, you are able to specify the kinds of updates you wish to
install on your system. e type of update usually depends upon your
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preferences with regards to system stability versus having access to the
latest developments.
Figure 5.13: You can update installed software
by using the Software Updater application in
Ubuntu.

Important security updates (saucy-security) ese updates are highly recommended to ensure your system remains as secure as possible. ese
updates are enabled by default.
Recommended updates (saucy-updates) ese updates are not as important
in keeping your system secure. Rather, updates listed in this section will
keep your soware updated with the most recent bug ﬁxes or minor
updates that have been tested and approved. is option is also enabled
by default.
Pre-released updates (saucy-proposed) is option is for those who would
rather remain up-to-date with the very latest releases of applications
at the risk of installing an update that has unresolved bugs or conﬂicts.
Note that it is possible you will encounter problems with these updated
applications, therefore, this option is not enabled by default.
Unsupported updates (saucy-backports) ese are updates that have not
yet been fully tested and reviewed by Canonical. Some bugs may occur
when using these updates, and so this option is also not enabled by
default.

Automatic updates

e middle section of this window allows you to customize how your system manages updates, such as the frequency with which it checks for new
packages, as well as whether it should install important updates right away
(without asking for your permission), download them only, or just notify
you about them.
Release upgrade

At the boom of the Updates tab in the Soware & Updates window, you
will see a dropdown box labeled Notify me of a new Ubuntu version:. is
option allows you to tell Ubuntu how you would like to handle release
updates. is dropdown box contains the following options for notiﬁcation:
Never Choose this option if you would rather not be notiﬁed about any
new Ubuntu releases.
For any new version Choose this option if you always want to have the
latest Ubuntu release, regardless of whether it is a long-term support
release or not. is option is recommended for normal home users.

  

For long-term support versions Choose this option if you need a release
that will be more stable and have support for a longer time. If you use
Ubuntu for business purposes, you may want to consider selecting this
option.
Canonical will release a new version of the Ubuntu operating system
every six months. Most every release is called a normal release. However,
every fourth release—or every  months—Canonical releases a longterm support () version of the operating system. Long-term support
releases are intended to be the most stable releases available and are
supported for a longer period of time. Ubuntu . is a normal release.
Ubuntu . will be an LTS release.

6 Advanced Topics
Ubuntu for advanced users

To this point, we’ve provided detailed instructions on geing the most from
Ubuntu’s basic features. In this chapter, we’ll detail some of Ubuntu’s more
advanced features—like the terminal, a powerful utility that can help you
accomplish tasks without the need for a graphical user interface (). We’ll
also discuss some advanced security measures you can implement to make
your computer even safer.
is chapter has been wrien with advanced users in mind. If you’re
new to Ubuntu, don’t feel as though you’ll need to master these topics to
get the most out of your new soware (you can easily skip to the next chapter without any adverse impact to your experience with Ubuntu). However,
if you’re looking to expand your knowledge of Ubuntu, we encourage you
to keep reading.
Introduction to the terminal

roughout this manual, we have focused primarily on the GUI. In order
to fully realize the power of Ubuntu, you will need to learn how to use the
terminal.
What is the terminal?

Most operating systems, including Ubuntu, have two types of user interfaces. e ﬁrst is a GUI. is is the desktop, windows, menus, and toolbars
you click to get things done. e second, much older type of interface is the
command-line interface ().
e terminal is Ubuntu’s CLI. It is a method of controlling some aspects
of Ubuntu using only commands that you type on the keyboard.
Why would I want to use the terminal?

You can perform most day-to-day activities without ever needing to open
the terminal. However, the terminal is a powerful and invaluable tool that
can be used to perform many useful tasks you might not be able to accomplish with a . For example:
‣ Troubleshooting any diﬃculties that may arise when using Ubuntu
sometimes requires you to use the terminal.
‣ A command-line interface is sometimes a faster way to accomplish a
task. For example, it is oen easier to perform operations on many ﬁles
concurrently using the terminal.
‣ Learning the command-line interface is the ﬁrst step towards more
advanced troubleshooting, system administration, and soware development skills. If you are interested in becoming a developer or an advanced
Ubuntu user, knowledge of the command-line is essential.
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Opening the terminal

You can open the terminal by clicking Dash then searching for word “term”.
You’ll see an application named terminal. Click on this application to open
a terminal. Alternatively, you can open the terminal by hiing Ctrl+Alt+T
simultaneously.
e terminal gives you access to what is called a shell. When you type
a command in the terminal, the shell interprets this command, resulting in
the desired action. Diﬀerent types of shells accept slightly diﬀerent commands. e most popular is called “bash,” and is the default shell in Ubuntu.
When the terminal window opens, it will be largely blank with the exception of some text at the top le of the screen, followed by a blinking block,
known as a cursor. is text is your prompt—it displays, by default, your
login name and your computer’s name, followed by the current directory.
e tilde (~) means that the current directory is your home directory. Finally, the blinking block is called the cursor—this marks where text will be
entered as you type.
To test a terminal command, type pwd and press Enter. e terminal
should display /home/yourusername. is text is called the “output.” You
have just used the pwd (print working directory) command, which outputs
(displays) the current directory.
Figure 6.1: The default terminal window allows
you to run hundreds of useful commands.

All commands in the terminal follow the same approach: Type a command, possibly followed by some parameters, and press Enter to perform
the speciﬁed action. Parameters (also called switches) are extra segments
of text, usually added at the end of a command, that change how the command itself is interpreted. ese usually take the form of -h or --help, for
example. In fact, --help can be added to most commands to display a short
description of the command, as well as a list of any other parameters that
can be used with that command.
Oen, some type of output will be displayed conﬁrming the action was
completed successfully, although this can depend on the command being
executed. For example, using the cd command to change your current directory (see above) will change the prompt but will not display any output.
e rest of this chapter covers some very common uses of the terminal. roughout the second part of this manual, we will continue to refer
to the command line, particularly when discussing steps involved in troubleshooting as well as when describing more advanced management of your
computer.

  

Ubuntu ﬁle system structure

Ubuntu uses the Linux ﬁle system, which is based on a series of folders
in the root directory. ese folders contain important system ﬁles that
cannot be modiﬁed unless you are running as the root user or use sudo. is
restriction exists for both security and safety reasons; computer viruses will
not be able to change the core system ﬁles, and ordinary users should not
be able to accidentally damage anything vital.
Figure 6.2: Some of the most important
directories in the root ﬁle system.

We begin our discussion of the Ubuntu ﬁle system structure at the top
—also known as the root directory—as denoted by /. e root directory
contains all other directories and ﬁles on your system. Below the root
directory are the following essential directories:
and /sbin Many essential system applications (equivalent to C:\Windows).
System-wide conﬁguration ﬁles.
/home Each user will have a subdirectory to store personal ﬁles (for
example, /home/yourusername) which is equivalent to C:\Users or
C:\Documents and Settings in Microso Windows.
/lib Library ﬁles, similar to .dll ﬁles on Windows.
/media Removable media (s and  drives) will be mounted in this
directory.
/root is contains the root user’s ﬁles (not to be confused with the root
directory).
/usr Pronounced “user,” it contains most program ﬁles (not to be confused with each user’s home directory). is is equivalent to C:\Program
Files in Microso Windows.
/var/log Contains log ﬁles wrien by many applications.
/bin
/etc

Every directory has a path. e path is a directory’s full name—it describes a way to navigate the directory from anywhere in the system.
For example, the directory /home/yourusername/Desktop contains all the
ﬁles that are on your Ubuntu desktop. It can be broken down into a handful
of key pieces:
‣
‣
‣

/—indicates

that the path starts at the root directory
the root directory, the path goes into the home directory
yourusername/—from the home directory, the path goes into the yourusername directory
‣ Desktop—from the yourusername directory, the path ends up in the
Desktop directory
home/—from
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Every directory in Ubuntu has a complete path that starts with the / (the
root directory) and ends in the directory’s own name.
Directories and ﬁles that begin with a period are hidden. ese are usually only visible with a special command or by selecting a speciﬁc option.
In the Files ﬁle manager, you can show hidden ﬁles and directories by
selecting the View Options buon located in the upper-right of the window. is will show a dropdown list of options. Select Show Hidden Files.
Hidden ﬁles can also be shown by simply pressing Ctrl+H in the Files ﬁle
manager. If you are using the terminal, then you would type ls -a and
press Enter to see the hidden ﬁles and directories. ere are many hidden
directories in your home folder used to store program preferences. For example, /home/yourusername/.thunderbird stores preferences used by the
underbird mail application.
Mounting and unmounting removable devices

Any time you add storage media to your computer—an internal or external
hard drive, a  ﬂash drive, a —it needs to be mounted before it is
accessible. Mounting a device means to associate a directory name with the
device, allowing you to navigate to the directory to access the device’s ﬁles.
When a device, such as a  ﬂash drive or a media player, is mounted in
Ubuntu, a folder is automatically created for it in the media directory, and
you are given the appropriate permissions to be able to read and write to
the device.
Most ﬁle managers will automatically add a shortcut to the mounted
device in the side bar of your home folder or as a shortcut directly on the
desktop so that the device is easily accessible. You shouldn’t have to physically navigate to the media directory in Ubuntu unless you choose to do so
from the command line.
When you’ve ﬁnished using a device, you can unmount it. Unmounting a
device disassociates the device from its directory, allowing you to eject it. If
you disconnect or remove a storage device before unmounting it, you may
lose data.
Securing Ubuntu

Now that you know a bit more about using the command line, we can use it
to make your computer more secure. e following sections discuss various
security concepts, along with procedures for keeping your Ubuntu running
smoothly, safely, and securely.
Why Ubuntu is safe

Ubuntu is secure by default for a number of reasons:
‣ Ubuntu clearly distinguishes between normal users and administrative
users.
‣ Soware for Ubuntu is kept in a secure online repository containing no
false or malicious soware.
‣ Open-source soware like Ubuntu allows security ﬂaws to be easily
detected.
‣ Security patches for open-source soware like Ubuntu are oen released
quickly.

  

‣ Many viruses designed to primarily target Windows-based systems do
not aﬀect Ubuntu systems.
Just because Ubuntu implements strong security model by default doesn’t
mean the user can “throw caution to the wind.” Care should always be
taken when downloading ﬁles, opening email, and browsing the Internet.
Using a good antivirus program is warranted as well.
Basic security concepts

e following sections discuss basic security concepts—like ﬁle permissions,
passwords, and user accounts. Understanding these concepts will help you
in securing your computer.
Permissions

In Ubuntu, ﬁles and folders can be set up so that only speciﬁc users can
view, modify, or run them. For instance, you might wish to share an important ﬁle with other users, but do not want those users to be able to edit the
ﬁle. Ubuntu controls access to ﬁles on your computer through a system of
“permissions.” Permissions are seings conﬁgured to control exactly how
ﬁles on your computer are accessed and used.
To learn more about modifying permissions, visit https://help.ubuntu.
com/community/FilePermissions.
Passwords

You should use a strong password to increase the security of your computer.
Your password should not contain names, common words, or common
phrases. By default, the minimum length of a password in Ubuntu is four
characters. We recommend a password with more than the minimum number of characters. A password with a minimum of eight characters which
includes both upper and lower case leers, numbers, and symbols is considered strong.
Locking the screen

When you leave your computer unaended, you may want to lock the
screen. Locking your screen prevents another user from using your computer until your password is entered. To lock the screen:
‣ Click the session menu icon in the right corner of the top panel, then
select Lo, or
‣ press Ctrl+Alt+L to lock the screen. is keyboard shortcut can be
changed by going to Session Indicator ‣ System Settings… ‣ Keyboard ‣
Shortcuts and then selecting System from the list in the le column and
clicking on Lo Screen in the right column.
Users and groups
User accounts

When Ubuntu is installed, it is automatically conﬁgured for use by a single
user. If more than one person will use the computer, each person should
have his or her own user account. is way, each user can have separate
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seings, documents, and other ﬁles. If necessary, you can also protect ﬁles
from being viewed or modiﬁed by users without administrative privileges.
Like most operating systems, Ubuntu allows you to create separate user
accounts for each person. Ubuntu also supports user groups, which allows
you to administer permissions for multiple users at the same time.
Every user in Ubuntu is a member of at least one group. At a bare minimum, the user of the computer has permissions in a group with the same
name as the user. A user can also be a member of additional groups. You
can conﬁgure some ﬁles and folders to be accessible only by a user and a
group. By default, a user’s ﬁles are only accessible by that user, and system
ﬁles are only accessible by the root user.
Figure 6.3: Add, remove and change the user
accounts.

Managing users

If the account you are using is an administrator account, you can manage
users and groups using the Users and Groups administration application.
To ﬁnd this application, click Session Indicator ‣ System Settings… ‣ User
Accounts. en click the Unlo buon and enter your password to unlock
the user seings. Next, select the user that you want to modify from the list.
en click on the element that you want to change.
Adding a user Click the + buon underneath the list of the current user
accounts. A window will appear with three ﬁelds. e Account Type ﬁeld
contains a list of user account types. Take care in determining what type
of account to assign a user. An Administrator has full access to all areas
of Ubuntu, whereas the Standard account type is more limited. e Full
Name ﬁeld contains a friendly display name. e Username ﬁeld is for the
actual username. As you enter the user’s full name, the Username ﬁeld will
automatically ﬁll with a lowercase, no space version of the user’s full name.
If you prefer to use a diﬀerent username for this user, highlight the existing
username and type in the username of your choice. Once all ﬁelds are
ﬁlled in, click Add. A new dialog box will appear showing the user account
details. New accounts are disabled by default. To enable an account, click
the Account disabled ﬁeld next to the Password label. A new window will
appear allowing you to set the password for the new user.
At the top of the new window is a dropdown menu next to the label
Action. By default, the “set a password now” option will be automatically
selected. You may also choose “log in without a password”, however, this
is not advised as the account will be available to anyone. e ﬁnal option,
“enable this account” is available once a password has been set. Using this

  

option allows an administrator to enable or disable an account without
losing the password.
Ubuntu provides a way to create a secure password by clicking the gears
buon located inside of the New password ﬁeld. A random sequence of
numbers, leers, and symbols will be entered into this ﬁeld. You can also
simply enter a password of your choosing by entering it into the New
password ﬁeld. en, re-enter this same password into the space next to
Conﬁrm password.
Ubuntu enforces the password policies on this screen, so pay aention to the
status information located between the New password and Conﬁrm password
ﬁelds for information about the password you’re seing. If there are problems
with the password, Ubuntu will tell you what is wrong with the password and
will prevent you from entering the same password into the Conﬁrm password
ﬁeld until the new password meets the requirements.

Modifying a user Click on the name of a user in the list of users, then click
on the text entry next to any of the following options:
‣
‣
‣
‣

Account type:
Language:
Password:
Automatic Login:

You may also change the username by clicking on the username at the top
and entering a new name.
Deleting a user Select a user from the list and click -. Ubuntu will deactivate the user’s account, and you can choose whether to remove the user’s
home folder or leave it in place. If a user is removed and the user’s ﬁles remain, the only user who can access the ﬁles are the root user—also known
as the superuser—or anyone associated with the ﬁle’s group.
Managing groups

Group management is accomplished through the command line (Terminal)
or by adding third-party applications (the laer is beyond the scope of this
manual). You will ﬁnd more information in the section below titled “Using
the command line”.
Adding a group To add a group, type sudo addgroup groupname and press
Enter, replacing groupname with the name of the group you wish to add.
For example, sudo addgroup ubuntuusers will add the group ubuntuusers
to the list of groups.
Modifying a group To alter the users in an existing group, type sudo
adduser username groupname to add a user, or sudo deluser username
groupname and press Enter to remove a user replacing username and groupname in these commands with the actual user and group name with which
you’re working.
Deleting a group To delete a group, type sudo delgroup groupname and
press Enter, replacing groupname with the name of the group you wish to
delete.

     .

Applying groups to ﬁles and folders

To change the group associated with a ﬁle or folder, open the Files ﬁle manager and navigate to the appropriate ﬁle or folder. en, either select the
folder and then click the gears buon in the upper-right of the window and
choose Properties, or right-click on the ﬁle or folder and select Properties.
In the Properties dialog window, click on the Permissions tab and select the
desired group from the Groups drop-down list. en close the window.
Using the command line

You can also modify user and group seings via the command line, but
we recommend you use the graphical method above unless you have a
good reason to use the command line. For more information on using the
command line to modify users and groups, see the Ubuntu Server Guide at
https://help.ubuntu.com/./serverguide/user-management.html.
System updates

Good security happens with an up-to-date system. Ubuntu provides free
soware and security updates. You should apply these updates regularly.
See Updates and upgrades to learn how to update your Ubuntu computer
with the latest security updates and patches.
Trusting third party sources

Normally, you will add applications to your computer via the Ubuntu Soware Center which downloads soware from the Ubuntu repositories as
described in Chapter : Soware Management. However, it is occasionally
necessary to add soware from other sources. For example, you may need
to do this when an application is not available in the Ubuntu repositories or
when you need a version of soware newer than what is currently in the
Ubuntu repositories.
Additional repositories are available from sites such as http://www.
getdeb.net and Launchpad s which can be added as described in Soware Sources. You can download the  packages for some applications
from their respective project sites on the Internet. Alternatively, you can
build applications from their source code.
Using only recognized sources, such as a project’s site,  or various
community repositories (such as http://www.getdeb.net), is more secure
than downloading applications from an arbitrary (and perhaps less reputable) source. When using a third party source, consider its trustworthiness, and be sure you know exactly what you’re installing on your computer.
Firewall

A ﬁrewall is an application that protects your computer against unauthorized access by people on the Internet or your local network. Firewalls
block connections to your computer from unknown sources. is helps
prevent security breaches.
Uncomplicated Firewall () is the standard ﬁrewall conﬁguration program in Ubuntu. It runs from the command line, but a program called Gufw
allows you to use it with a graphical user interface . See Chapter :
Soware Management to learn more about installing the Gufw package.

  

Once Gufw is installed, start Gufw by clicking Dash ‣ Applications ‣
Firewall conﬁguration. To enable the ﬁrewall, select the Enable option. By
default, all incoming connections are denied. is seing should be suitable
for most users.
If you are running server soware on your Ubuntu system (such as a
web server, or an  server), then you will need to open the ports these
services use. If you have no need to run any server applications or services,
you will likely not need to open any additional ports.
To open a port click on the Add buon. For most purposes, the Preconﬁgured tab is suﬃcient. Select Allow from the ﬁrst box and then select the
program or service required.
e Simple tab can be used to allow access on a single port, and the
Advanced tab can be used to allow access on a range of ports.
Encryption

You may wish to protect your sensitive personal data—for instance, ﬁnancial records—by encrypting it. Encrypting a ﬁle or folder essentially “locks”
that ﬁle or folder by encoding it with an algorithm that keeps it scrambled
until it is properly decoded with a password. Encrypting your personal data
ensures that no one can open your personal folders or read your private
data without your authorization through the use of a private key.
Ubuntu includes a number of tools to encrypt ﬁles and folders. is
chapter will discuss two of them. For further information on using encryption with either single ﬁles or email, see Ubuntu Community Help
documents at https://help.ubuntu.com/community.
Home folder

When installing Ubuntu, it is possible to encrypt a user’s home folder. See
Chapter : Installation for more on encrypting the home folder.
Private folder

If you have not chosen to encrypt a user’s entire home folder, it is possible
to encrypt a single folder—called Private—in a user’s home folder. To do
this, follow these steps:
. Install the ecryptfs-utils soware package from the Ubuntu Soware
Center. (For more information about the Soware Center, review Using
the Ubuntu Soware Center.)
. Use the terminal to run ecryptfs-setup-private to set up the private
folder.
. Enter your account’s password when prompted.
. Either choose a mount passphrase or generate one.
. Record both passphrases in a safe location. ese are required if you ever
have to recover your data manually.
. Log out and log back in to mount the encrypted folder.
Aer the Private folder has been set up, any ﬁles or folders in it will
automatically be encrypted.
If you need to recover your encrypted ﬁles manually see https://help.
ubuntu.com/community/EncryptedPrivateDirectory.
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Running Windows Programs on Ubuntu

As many Windows users will know, some programs that you can use on a
Windows system cease to work on Ubuntu. For example, LibreOﬃce works
on both Windows and Ubuntu systems, but Microso Oﬃce works only on a
Windows system. Since many Windows users who use Ubuntu want all of
their Windows programs back, many programmers have worked together to
create Wine. Wine is an acronym for “W ine I s N ot an Emulator”.
is section will discuss what Wine is, and how to use it on your Ubuntu
installation. For recent information about Wine, please visit the oﬃcial
Wine website at http://www.winehq.org.
What is Wine?

Wine is a background application that allows Linux and Mac users to install
and run Windows programs on their system. While not every Windows
program is compatible with Wine, many programs seem to be completely
compatible with Wine while running on Linux or Mac OS. For example,
Microso Oﬃce may not be compatible without installing additional components (such as Microso.NET Framework .). e current stable version
of Wine is ., and the most recent development version is ...
Installing Wine

To install Wine Version ., follow the following steps:
If you have a previous version of Wine installed, uninstall Wine before continuing
using the command, sudo apt-get remove --purge wine1.* winetricks &&
sudo apt-get autoremove

. Open the terminal and type: sudo apt-add-repository ppa:ubuntuwine/ppa. is will install the Oﬃcial Wine .
. Aer the terminal has ﬁnished installing the Wine , type: sudo aptget update. is will update the  list.
. Once the terminal has ﬁnished refreshing the  list, type: sudo aptget install -y wine1.6 winetricks. is will install Wine . and
Winetricks. Winetricks is a soware center for Wine, and is, in most
cases, optional.
Figure 6.4: The Terminal showing the installation of the Wine PPA.

During the installation of Wine and Winetricks, you will have to accept the Microso End User License Agreement and the Microso Core

  

Fonts License Agreement so that the Microso fonts and native ﬁles can be
installed.
Figure 6.5: The Microsoft Core Fonts EULA
dialog opened in the Terminal.

When accepting the Microso Core Fonts License Agreement, the Ok
buon is not highlighted. To highlight and accept the Microso EULA,
press the Tab key and then the Enter key. e Microso End User License
Agreement will be shown aer you accept the Microso Core Fonts EULA.
By default, the No buon is highlighted. To highlight the Yes buon and
accept the Microso EULA, press the Tab key and then the Enter key.
Figure 6.6: The Microsoft Core Fonts EULA
dialog opened in the Terminal.

Please Note: It is recommended to reboot your system aer installing
Wine and Winetricks, although this is not always required.
Installing Wine (Alternative)

For an alternative installation of Wine . (which does not involve the
terminal), follow these steps:
If you have a previous version of Wine installed, uninstall Wine before continuing by opening the Ubuntu Soware Center, going to the Installed menu, and
selecting and uninstalling the version of Wine you have installed. (EX. Wine.,
Wine.)

. Open the Ubuntu Soware Center and go to the Application Menu.
. Select Edit ‣ Soware Sources….
. When a pop-up appears, enter your password to ensure that any and all
changes have your approval. en, click OK.
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. Another window should appear aer you press OK, assuming you have
typed your password correctly. On the top of the window, there will be
a row of tabs. Click on the second tab, Other Soware. Click on this
menu.
. On the boom of the window, click the Add… buon.
. On the next window, key: ppa:ubuntu-wine/ppa. en, click the Add
Source buon.
. Search for and install Wine . and Winetricks like you would any other
application in the Ubuntu Soware Center.
During the installation of Wine and Winetricks, the Soware Center
will probably freeze. While the Soware Center is frozen, a new window,
that opened underneath the Soware Center’s window is waiting for you to
accept the Microso End User License Agreement and the Microso Core
Fonts License Agreement so that the Microso fonts and native ﬁles can be
installed. In this window, titled “Debconf on your-computer” (Replace yourcomputer with your computer’s name.), the Microso Core Fonts EULA
will be shown. To accept the Microso Core Fonts EULA, check the Do you
accept the EULA license terms? checkbox and click the Forward buon.
Figure 6.7: The Microsoft Core Fonts EULA
dialog opened in the Software Center.

It is recommended to reboot your system aer installing Wine and
Winetricks, although this is not always required.
Conﬁguring Wine

Wine ./.. contains many features that will change the look and feel
of the Windows applications you are trying to run. For example, you can
change the theme of the Windows interface, and what version of Windows
you would like to run (from Windows . to Windows ).
To change these seings, open the Dash and search for Configure Wine.
en, open the application.
Application Tab In the Application tab, you can change the way Wine
runs applications. Some Windows programs work only for speciﬁc versions
of Windows. is feature allows you to change the version of Windows
Wine will run as for a speciﬁc application, or for all of them to run under
one version.
Libraries Tab In the Libraries tab, you can change core Windows ﬁles,
to suit your needs. Many Windows programs install  ﬁles, or Dynamic
Link Libraries. ese ﬁles contain all of the information needed for an
application to work on a Windows system. Many  ﬁles are needed for

  

Figure 6.8: The Wine conﬁguration open to the
Application Tab.

a Windows system to run, and are diﬀerent between versions of Windows.
In this feature, you may edit or replace existing  ﬁles. is allows you to
change the Windows System ﬁles, to suit you needs.
ese ﬁles should not be edited. ese are core ﬁles needed for Wine to run
correctly. Only edit these ﬁles if you have to.

Graphics Tab In the Graphics tab, you can change the look and feel of
how Wine runs. You can make Wine emulate a Virtual Desktop (this feature
opens a new window that will contain any Windows application that is
currently running while this option is in eﬀect), how the applications look,
and what resolution to run the application in.
Desktop Integration Tab In the Desktop Integration tab, you can change
the way buons, menus, and other elements appear in an application. Each
version of Windows has brought its own unique visual style for its applications. In this feature, you can install and change the applied theme.
In this tab, you can also change major ﬁle folders. For example, while
using Ubuntu, your picture folder is located at /home/user/Pictures/
but in Windows, your picture folder is located at C:\Documents and Settings\User\My Documents\My Pictures\ or C:\Users\User\My Pictures\.
is feature allows you tell Wine where your folders are, for quick reference.
Drives Tab In the Drives tab, you can manage the connected drives that
Wine will be able to access. Unlike Ubuntu, Windows applies a Drive Leer
to each drive. is leer identiﬁes the drive. For example, on every Windows system, the C: drive is the core drive. It contains all of the needed ﬁles
for the operating system to work. e C: drive is the equivalent to root (File
System, or / ) in Ubuntu. is feature allows you to change the drive leers
for any drive, or add a drive leer for a speciﬁc folder in your ﬁle system, or
for a  drive.
Audio Tab In the Audio tab, you can change the audio seings. is feature allows you to change the audio source that Wine will use for Windows
applications (speakers, microphones, etc.).
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About Tab In the About tab, you can see the current Wine version you
have installed, including Wine’s note to all users. is feature also allows
you to add a Name and Company Name to the Windows information. Applications use this information to identify you by name.
Microsoft .NET Framework and Wine

Microso has created many programs that are needed to run commonly
used applications, Microso .NET Framework being the most common. .NET
Framework is needed to run most of the newer applications created by
Microso, and by other companies as well. Wine is not fully supported by
all versions of .NET, but is compatible with most versions. Here is a list of
.NET versions, and their compatibility with Wine:
‣
‣
‣
‣
‣
‣
‣
‣

.NET Framework .
.NET Framework .
.NET Framework .*
.NET Framework .*
.NET Framework .
.NET Framework .
.NET Framework .*
.NET Framework ..**

For some of the most recent .NET Frameworks to work properly, you
may have to install Wine ... To install Wine .., open the Terminal, and
key sudo apt-get install -y wine1.7.
For more compatibility information about installing and running Microso .NET Framework using Wine, go to: http://appdb.winehq.org/
objectManager.php?sClass=application&iId=.

* This framework has known issues running
under Wine and is, in most cases, installable and
stable enough to use for most applications.

** This framework has not been tested using a
current version of Wine running on Ubuntu, so it
is unknown if it will be compatible or not. Use at
your own risk.

7 Troubleshooting
Resolving problems

Sometimes things may not work as they should. Luckily, problems encountered while working with Ubuntu are oen easily ﬁxed. is chapter is
meant as a guide for resolving basic problems users may encounter while
using Ubuntu. If you need any additional help beyond what is provided
in this chapter, take a look at other support options that are discussed in
Finding additional help and support later in this book.
Troubleshooting guide

e key to eﬀective troubleshooting is to work slowly, complete all of the
troubleshooting steps, and to document the changes you made to the utility
or application you are using. is way, you will be able to undo your work,
or give fellow users the information about your previous aempts—the
laer is particularly helpful in cases when you look to the community of
Ubuntu users for support.
Ubuntu fails to start after I’ve installed Windows

Occasionally you may install Ubuntu and then decide to install Microso
Windows as a second operating system running side-by-side with Ubuntu.
is is supported in Ubuntu, but you might also ﬁnd aer installing Windows that you will no longer be able to start Ubuntu.
When you ﬁrst turn on your computer, a “bootloader” is responsible for
initiating the start of an operating system, such as Ubuntu or Windows.
When you installed Ubuntu, you automatically installed an advanced bootloader called .  allows you to choose between the various operating systems installed on your computer, such as Ubuntu, Windows, Solaris,
or Mac  . If Windows is installed aer Ubuntu, the Windows installation
removed  and replaced the bootloader with it’s own. As a result, you
can no longer choose an operating system to use. You can restore  and
regain the ability to choose your operating system by following the steps
below, using the same  you used to install Ubuntu.
First, insert your Ubuntu  into your computer and then restart the
computer, making sure to instruct your computer to boot from the 
drive and not the hard drive (see Chapter : Installation). Next, choose your
language (e.g., English) and select Try Ubuntu. Once Ubuntu starts, click
on the top-most icon in the Launcher (the Dash icon). en, search for
Terminal using the search box. en, select Terminal in the search results
(or press Ctrl+Alt+T). A window should open with a blinking prompt line.
Enter the following, and press the Enter key:
$ sudo fdisk -l
Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot
/dev/sda1

Start

End

1

1224

Blocks
64228+

Id

System

83

Linux

A bootloader is the initial software that loads
the operating system when the computer is
powered up.
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1225

2440

/dev/sda3

/dev/sda2

*

2441

14593

/dev/sda4

14532

14593

9767520
97618972+
498015

a5
5
82

Windows
Extended
Linux swap

Partition table entries are not in disk order

is output shows that your system (Linux, on which Ubuntu is based)
is installed on device /dev/sda1, but as indicated by the asterisk in the
Boot column, your computer is booting to /dev/sda2 (where Windows is
located). We need to ﬁx this by telling the computer to boot to the Linux
device instead.
To do this, create a place to connect your existing Ubuntu installation
with your temporary troubleshooting session:
$ sudo mkdir /mnt/root

Next, link your Ubuntu installation and this new folder:
$ sudo mount /dev/sda1 /mnt/root

If you’ve done this correctly, then you should see the following:
$ ls /mnt/root
bin dev home lib mnt root srv usr
boot etc initrd lib64 opt sbin sys var
cdrom initrd.img media proc selinux tmp vmlinuz

Now, you can reinstall :
$ sudo grub-install --root-directory=/mnt/root /dev/sda
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script grub-install.
(hd0) /dev/sda

Next you’ll want to unmount the hard drive. is ensures that the drive
won’t become corrupted when you reboot:
$ sudo umount /mnt/root

Finally, remove the Ubuntu disc from your  drive, reboot your
computer, and then start enjoying your Ubuntu operating system once
again.
is guide may not work for all Ubuntu users due to diﬀerences in the
various system conﬁguration. Still, this is the recommended and most
successful method for restoring the  bootloader. If you are following
this guide and if it does not restore  on your computer, then try the
other troubleshooting methods at https://help.ubuntu.com/community/
RecoveringUbuntuAfterInstallingWindows.
I forgot my password

If you forgot your password in Ubuntu, you will need to reset it using the
“Recovery mode.”
To start the Recovery mode, shut down your computer and then start
again. As the computer starts up, press Shift. Select the Recovery mode
option using the arrow keys on your keyboard. Recovery mode should be
under the heading Advanced Options in the list.
Wait until Ubuntu starts up—this may take a few minutes. Once booted,
you will not be able to see a normal login screen. Instead, you will be presented with the Recovery Menu. Select root using the arrow keys and press
Enter.
You will now be at a terminal prompt:
root@ubuntu:~#

The device (/dev/sda1, /dev/sda2, etc.) we
are looking for is identiﬁed by the word “Linux”
in the System column. Modify the instructions
below if necessary, replacing /dev/sda1 with
the name of your Linux device.

 

Figure 7.1: This is the grub screen in which you
can choose recovery mode.

To reset your password, enter:
# passwd username

Replace “username” above with your username, aer which Ubuntu will
prompt you for a new password. Enter your desired password, press the
Enter key, and then re-type your password again, pressing Enter again
when done. (Ubuntu asks for your password twice to make sure you did
not make a mistake while typing). Once you have restored your password,
return to the normal system environment by entering:
# init 2

Login as usual and continue enjoying Ubuntu.
I accidentally deleted some ﬁles that I need

If you’ve deleted a ﬁle by accident, you may be able to recover it from
Ubuntu’s Trash folder. is is a special folder where Ubuntu stores deleted
ﬁles before they are permanently removed from your computer.
To access the Trash folder click on the trash icon at the boom of the
Unity Launcher.
If you want to restore deleted items from the Trash:
. Open Trash
. Click on each item you want to restore to select it. Press and hold Ctrl
to select multiple items.
. Click Restore Selected Items to move the deleted items back to their
original locations.
How do I clean Ubuntu?

Ubuntu’s soware packaging system accumulates unused packages and
temporary ﬁles through regular updates and use. ese temporary ﬁles, also
called caches, contain ﬁles from all of the installed packages. Over time, this
cache can grow quite large. Cleaning out the cache allows you to reclaim
space on your computer’s hard drive for storing your documents, music,
photographs, or other ﬁles.
To clear the cache, you can either use the clean, or the autoclean option
for the command-line program apt-get.
To run clean, open Terminal and enter:
$ sudo apt-get clean

Packages can also become unused over time. If a package was installed
to assist with running another program—and that program was subse-

The clean command will remove every
single cached item, while the autoclean
command only removes cached items that can
no longer be downloaded (these items are
often unnecessary).
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quently removed—you no longer need the supporting package. You can
remove it with apt-get autoremove.
Load Terminal and enter:
$ sudo apt-get autoremove

I can’t play certain audio or video ﬁles

Many of the formats used to deliver rich media content are proprietary,
meaning they are not free to use, modify, or distribute with an open-source
operating system like Ubuntu. erefore, Ubuntu does not include the capability to use these formats by default; however, users can easily conﬁgure
Ubuntu to use these proprietary formats. For more information about the
diﬀerences between open source and proprietary soware, see Chapter :
Learning More.
If you ﬁnd yourself in need of a proprietary format, you can install the
required ﬁles from the Ubuntu Soware Center. Ensure that you have the
Universe and Multiverse repositories enabled before continuing. See the
Soware Sources section to learn how to enable these repositories. When
you are ready to continue, install the necessary soware as follows:
. Open the Ubuntu Soware Center by searching for it from the Dash (the
top-most buon on the Launcher).
. Search for ubuntu-restricted-extras by typing “Ubuntu restricted
extras” in the search box on the right-hand side of the Ubuntu Soware
Center main window. When the Soware Center ﬁnds the appropriate
soware, click the arrow next to its title.
. Click Install, then wait while Ubuntu installs the soware.
One program that can play many of these formats is  media player.
It can be installed from the Ubuntu Soware Center. Once Ubuntu has
successfully installed this soware, your rich media content should work
properly.
How can I change my screen resolution?

e image on every monitor is composed of millions of lile colored dots
called pixels. Changing the number of pixels displayed on your monitor is
called “changing the resolution.” Increasing the resolution will make the
displayed images sharper, but will also tend to make them smaller. e
opposite is true when screen resolution is decreased. Most monitors have
a “native resolution,” which is a resolution that most closely matches the
number of pixels in the monitor. Your display will usually be sharpest when
your operating system uses a resolution that matches your display’s native
resolution.
e Ubuntu conﬁguration utility Displays allows users to change the
resolution. Open it by clicking on the session indicator and then on Displays…. e resolution can be changed using the drop-down list within
the program. Picking options higher up on the list (for example, those with
larger numbers) will increase the resolution.
You can experiment with various resolutions by clicking Apply at the
boom of the window until you ﬁnd one that is comfortable. Typically,
the highest resolution will be the native resolution. Selecting a resolution
and clicking Apply will temporarily change the screen resolution to the
selected value, and a dialog box will also be displayed for  seconds. is
dialog box allows you to revert to the previous resolution seing or keep

 

Figure 7.2: You can change your display
settings.

the new resolution seing. If you’ve not accepted the new resolution and/or
 seconds have passed, the dialog box will disappear and the display’s
resolution will return to its previous seing.
Figure 7.3: You can revert back to your old
settings if you need to.

is feature was implemented to prevent someone from being locked out
of the computer by a resolution that distorts the monitor output and makes
it unusable. When you have ﬁnished seing the screen resolution, click
Close.
Ubuntu is not working properly on my Apple MacBook or MacBook Pro

When installed on notebook computers from Apple—such as the MacBook
or MacBook Pro—Ubuntu does not always enable all of the computer’s
built-in components, including the iSight camera and the Airport wireless
Internet adapter. Luckily, the Ubuntu community oﬀers documentation
on ﬁxing these and other problems. If you are having trouble installing or
using Ubuntu on your Apple notebook computer, please follow the instructions at https://help.ubuntu.com/community/MacBook. You can select the
appropriate guide aer identifying your computer’s model number.
Ubuntu is not working properly on my Asus EeePC

When installed on netbook computers from Asus—such as the EeePC—
Ubuntu does not always enable all of the computer’s built-in components,
including the keyboard shortcut keys and the wireless Internet adapter.
e Ubuntu community oﬀers documentation on enabling these components and ﬁxing other problems. If you are having trouble installing
or using Ubuntu on your Asus EeePC, please follow the instructions at
https://help.ubuntu.com/community/EeePC. is documentation page contains information pertaining speciﬁcally to EeePC netbooks.
To enable many of the features and Function Keys, a quick ﬁx is to add
“acpi_osi=Linux” to your grub conﬁguration. From the Terminal
$ gksudo gedit /etc/default/grub
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and very carefully change the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Save and close the ﬁle. en, from the terminal:
$ sudo update-grub

Aer the command ﬁnishes, and you restart the computer, you will be able
to use the Fn keys normally.
My hardware is not working properly

Ubuntu occasionally has diﬃculty running on certain computers, usually
when hardware manufacturers use non-standard or proprietary components. e Ubuntu community oﬀers documentation to help you troubleshoot many common issues in this situation, including problems with
wireless cards, scanners, mice, and printers. You can ﬁnd the complete
hardware troubleshooting guide on Ubuntu’s support wiki, accessible at
https://wiki.ubuntu.com/HardwareSupport. If your hardware problems
persist, please see Geing more help for more troubleshooting options or
information on obtaining support or assistance from an Ubuntu user.
Getting more help

is guide does not cover every possible workﬂow, task, issue, or problem
in Ubuntu. If you require assistance beyond the information in the manual,
you can ﬁnd a variety of support opportunities online.
More details about many support options available to you can be found
at Finding additional help and support later in this book.

8 Learning More
What else can I do with Ubuntu?

At this point, you should now be able to use Ubuntu for most daily activities—such as browsing the web, sending email, and creating documents.
Now, you may be interested in learning about other versions of Ubuntu
that may integrate into your digital lifestyle. In this chapter, we’ll introduce
additional versions of Ubuntu designed and specialized for certain tasks.
We’ll also provide resources for answering any remaining questions as well
as direct you to how you can get involved in the worldwide community
of Ubuntu users. First, we’ll discuss the technologies that make Ubuntu a
powerful collection of soware and a progressive operating system.
Open source software

Ubuntu is open source soware (OSS). OSS diﬀers from proprietary soware. Proprietary soware is deﬁned as soware whose source code is
not freely available for modiﬁcation or distribution by anyone but the
rightsholder. Microso Windows and Adobe Photoshop are examples of
proprietary soware.
Unlike proprietary soware applications, the soware included with
Ubuntu is speciﬁcally licensed to promote sharing and collaboration. e
legal rules governing Ubuntu’s production and distribution ensure that
anyone can obtain, run, or share it for any purpose. Users can modify open
source soware to suit their individual needs, to share it, to improve it, or to
translate it into other languages—provided they release the source code for
these modiﬁcations so others can do the same. In fact, the terms of many
open source licensing agreements actually make it illegal not to do so. is
understanding helps explain why Ubuntu is called open source soware.
For more information regarding Ubuntu’s soware licensing standards, see
http://www.ubuntu.com/project/about-ubuntu/licensing.
Because OSS is developed by large communities of programmers located
throughout the world, it beneﬁts from both rapid development cycles and
speedy security releases when bugs are identiﬁed in the soware. In other
words, OSS is updated, enhanced, and made more secure every day as
programmers all over the world continue to improve it.
In addition to these technical advantages, OSS also has economic beneﬁts. While users must adhere to the terms of an OSS licensing agreement
when installing and using Ubuntu, they needn’t pay to obtain this license.
While not all OSS is free of monetary costs, a vast majority of OSS is available for free.
To learn more about open source soware, see the Open Source Initiative’s open source deﬁnition, available at http://www.opensource.org/docs/
definition.php.
Distribution families

Ubuntu is one of several popular operating systems based on Linux. ese
Linux-based operating systems—called Linux “distributions”—may look
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diﬀerent from Ubuntu at ﬁrst glance, but they share similar characteristics
because of their common roots.
Linux distributions can be divided into two broad families: the Debian
family and the Red Hat family. Each family is named for a distribution on
which subsequent distributions are based. For example, “Debian” refers to
both the name of a Linux distribution as well as the family of distributions
derived from Debian. Ubuntu is part of this family. When describing relationships between various open source projects, soware developers oen
use the metaphor of tributaries connecting to a common body of water.
For this reason, you may hear someone say that Ubuntu is located “downstream” from Debian, because alterations to the Debian family ”ﬂow” into
new versions of Ubuntu. Additionally, improvements to Ubuntu usually
trickle “upstream”—back to Debian and its family members as the Debian
family beneﬁts from the work of the Ubuntu community. Other distributions in the Debian family include Linux Mint, Xandros, and CrunchBang
Linux. Distributions in the Red Hat family include Fedora and Mandriva.
e most signiﬁcant diﬀerence between Debian-based and Red Hatbased distributions is the system each uses for installing and updating
soware. ese systems are called Package management systems. Package
management systems are the means by which users can install, remove,
and organize soware installed on computers with open source operating
systems like Ubuntu. Debian soware packages are  ﬁles, while Red Hat
soware packages are  ﬁles. e two systems are generally incompatible. For more information about package management, review the chapter
on Chapter : Soware Management.
You will also ﬁnd specialized Linux distributions for certain tasks. Next,
we’ll describe these versions of Ubuntu and explain the uses for which each
has been developed.
Choosing amongst Ubuntu and its derivatives

Just as Ubuntu is based on Debian, several distributions are subsequently
based on Ubuntu. Each diﬀers with respect to the soware included as part
of the distribution. Some are developed for general use, while others are
designed for accomplishing a more narrow set of tasks.
Alternative interfaces

Ubuntu . features a new graphical user interface () based on the
open source  desktop. Previous versions of Ubuntu use the 
desktop. As we explained in Chapter : e Ubuntu Desktop, a “user interface” is a collection of soware elements—icons, colors, windows, themes,
and menus—that determine how someone may interact with a computer.
Some people prefer using alternatives to , so they have created
Ubuntu distributions featuring diﬀerent user interfaces. ese include:
‣ Kubuntu, which uses the  graphical environment
‣ Lubuntu, which uses the  graphical environment
‣ Xubuntu, which uses the  graphical environment
Additionally, each of these distributions may contain default applications
diﬀerent from those featured in Ubuntu. For instance, the default music
player in Ubuntu is Rhythmbox. In Lubuntu, the default music player is
Aqualung, and in Kubuntu, the default is Amarok. Be sure to investigate

 

these diﬀerences if you are considering installing an Ubuntu distribution
with an alternative desktop environment.
For more information about these and other derivative distributions, see
http://www.ubuntu.com/project/derivatives.
Task-speciﬁc distributions

Other Ubuntu distributions have been created to accomplish speciﬁc tasks
or run in specialized environments and seings.
Ubuntu Server Edition

e Ubuntu Server Edition is an operating system optimized to perform
multi-user tasks. Such tasks may include ﬁle sharing, website, or email
hosting. If you are planning to use a computer to perform these types of
tasks, you may wish to use this specialized server distribution in conjunction with server hardware. While it is possible to run a server-type environment using only the desktop version of Ubuntu, it is not advised as the
Server Edition is beer optimized for the multi-user environment.
is manual does not explain the process of running a secure web server
or performing other tasks with Ubuntu Server Edition. For details on using
Ubuntu Server Edition, refer to the manual at http://www.ubuntu.com/
business/server/overview.
Edubuntu

Edubuntu is an Ubuntu derivative customized for use in schools and other
educational institutions. Edubuntu contains soware similar to that oﬀered
in Ubuntu but also features additional applications like a collaborative text
editor and educational games.
For additional information regarding Edubuntu, visit http://www.
edubuntu.org/
Ubuntu Studio

e derivative of Ubuntu called Ubuntu Studio is designed speciﬁcally for
people who use computers to create and edit multimedia projects. Ubuntu
Studio features applications to help users manipulate images, compose
music, and edit video. While users can install these applications on computers running the desktop version of Ubuntu, Ubuntu Studio makes them all
available immediately upon installation.
If you would like to learn more about Ubuntu Studio (or obtain a copy
for yoursel), visit http://ubuntustudio.org/.
Mythbuntu

Mythbuntu allows users to turn their computers into entertainment systems. Mythbuntu helps users organize and view various types of multimedia content such as movies, television shows, and video podcasts. Users
with  tuners in their computers can also use Mythbuntu to record live
video and television shows.
To learn more about Mythbuntu, visit http://www.mythbuntu.org/.
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Finding additional help and support

is guide cannot possibly contain everything you’ll ever need to know
about Ubuntu. We encourage you to take advantage of Ubuntu’s vast community when seeking further information, troubleshooting technical issues,
or asking questions about your computer.
It’s important to note that the Internet is full of third-party resources
as well as individuals who post information on blogs and forums. While
these resources can oen seem like great resources, some could be misleading or outdated. It’s always best to verify information from third-party
sources before taking their advice. When possible, rely on oﬃcial Ubuntu
documentation for assistance with Ubuntu.
Now, let’s discuss a few of the available resources to learn more about
Ubuntu and other Linux distributions.
Live chat

If you are familiar with Internet Relay Chat (), you can use chat clients
such as XChat or Pidgin to join the channel #ubuntu on irc.freenode.net. In
this channel, hundreds of volunteer users can answer your questions or offer technical support in real time. To learn more about using Internet Relay
Chat to seek help with Ubuntu, visit https://help.ubuntu.com/community/
InternetRelayChat.
LoCo teams

e Ubuntu community contains dozens of local user groups called “LoCo
teams.” Distributed throughout the world, these teams oﬀer support and
advice, answer questions, and promote Ubuntu in their communities by
hosting regular events. To locate or contact the LoCo team nearest you,
visit http://loco.ubuntu.com/.
Books and Magazines

Many books have been wrien about Ubuntu, and professional magazines
oen feature news and information related to Ubuntu. You will frequently
ﬁnd these resources at your local bookstore or newsstand. Additionally,
many of these print publications are also available as digital downloads for
purchase in the Ubuntu Soware Center. To ﬁnd these resources, launch the
Soware Center, then click on “Books & Magazines” in the le panel.
Oﬃcial Ubuntu Documentation

e Ubuntu Documentation Team maintains a series of oﬃcial wiki pages
designed to assist both new and experienced users wishing to learn more
about Ubuntu. e Ubuntu community endorses these documents, which
serve as a reliable ﬁrst point of reference for users seeking online help. You
can access these resources at http://help.ubuntu.com. To get to the built-in
Ubuntu Desktop Guide, type help in the Dash.
The Ubuntu Forums

e Ubuntu Forums are the oﬃcial forums of the Ubuntu community. Millions of Ubuntu users use them daily to seek help and support from one
another. You can create an Ubuntu Forums account in minutes. To create

 

an account and learn more about Ubuntu from community members, visit
http://ubuntuforums.org.
Launchpad Answers

Launchpad, an open source code repository and user community, provides a
question and answer service that allows anyone to ask questions about any
Ubuntu-related topic. Signing up for a Launchpad account takes just a few
seconds. You can ask a question by visiting Launchpad at https://answers.
launchpad.net/ubuntu.
Ask Ubuntu

Ask Ubuntu is a free, community-driven website for Ubuntu users and
developers. Like the Ubuntu Forums, it allows users to post questions for
other members of the Ubuntu community to answer. But Ask Ubuntu also
allows visitors to “vote” on the answers users provide, so the most useful or
helpful responses get featured more prominently on the site. Ask Ubuntu is
part of the Stack Exchange network of websites and is one of the best free
Ubuntu support resources available. Visit http://www.askubuntu.com to get
started.
Search Engines

Because Ubuntu is a popular open source operating system, many users
have wrien about it online. erefore, using search engines to locate
answers to your questions about Ubuntu is oen an eﬀective means of
acquiring help. When using search engines to answer questions about
Ubuntu, ensure that your search queries are as speciﬁc as possible. In other
words, a search for “Unity interface” will return results that are less useful
than those associated with the query “how to use Ubuntu Unity interface”
or “how to customize Ubuntu Unity interface.”
Community support

If you’ve exhausted all these resources and still can’t ﬁnd answers to your
questions, visit Community Support at http://www.ubuntu.com/support/
community.
The Ubuntu community

Ubuntu is the ﬂagship product created by a global community of passionate
users who want to help others adopt, use, understand, and even modify or
enhance Ubuntu. By choosing to install and run Ubuntu, you’ve become
part of this community. As you learn more about Ubuntu, you may wish
to collaborate with others as you promote Ubuntu to new users, to share
Ubuntu advice, or to answer other users’ questions. In this section, we’ll
discuss a few community projects that can connect you to other Ubuntu
users.
Full Circle Magazine

Full Circle Magazine is “the independent magazine for the Ubuntu Linux
community.” Released every month, Full Circle Magazine contains reviews
of new soware (including games) for Ubuntu, step-by-step tutorials for
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projects you can accomplish with Ubuntu, editorials discussing important
issues in the Ubuntu community, and Ubuntu tips from other users. Full
Circle Magazine is released in many diﬀerent formats and is always free.
You can download current and back issues of Full Circle Magazine at http://
fullcirclemagazine.org/.
The Ubuntu UK Podcast

Produced by members of the UK’s Ubuntu LoCo team, this bi-weekly online
audio broadcast (or “podcast”) features lively discussion about Ubuntu and
oen includes interviews with Ubuntu community members who work to
improve Ubuntu. Episodes are available at http://podcast.ubuntu-uk.org/.
OMG! Ubuntu!

OMG! Ubuntu! is a weblog that aims to inform the Ubuntu community
about Ubuntu news, events, announcements, and updates in a timely fashion. It also allows Ubuntu users to discuss ways they can promote or share
Ubuntu. You can read this blog or subscribe to it at http://www.omgubuntu.
co.uk/.
Contributing
Contributing to Ubuntu

As we mentioned earlier in this chapter, Ubuntu is a community-maintained
operating system. You can help make Ubuntu beer in a number of ways.
e community consists of thousands of individuals and teams. If you
would like to contribute to Ubuntu, please visit https://wiki.ubuntu.com/
ContributeToUbuntu.
You can also participate in the Ubuntu community by contributing to
this manual. You might choose to write new content for it, edit its chapters
so they are easier for new Ubuntu users to understand and use, or translate
it in your own language. Or maybe taking screenshots is your passion!
Regardless of your talent or ability, if you have a passion to contribute to
the Ubuntu community in a meaningful way, then the Ubuntu Manual
Project invites you to join! To get involved in the Ubuntu Manual Project,
visit http://ubuntu-manual.org/getinvolved.
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. Deﬁnitions
(a) “Adaptation” means a work based upon the Work, or upon the Work
and other pre-existing works, such as a translation, adaptation,
derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes
cinematographic adaptations or any other form in which the Work
may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes
a Collection will not be considered an Adaptation for the purpose of
this License. For the avoidance of doubt, where the Work is a musical
work, performance or phonogram, the synchronization of the Work in
timed-relation with a moving image (“synching”) will be considered
an Adaptation for the purpose of this License.
(b) “Collection” means a collection of literary or artistic works, such
as encyclopedias and anthologies, or performances, phonograms
or broadcasts, or other works or subject maer other than works
listed in Section () below, which, by reason of the selection and
arrangement of their contents, constitute intellectual creations, in
which the Work is included in its entirety in unmodiﬁed form along
with one or more other contributions, each constituting separate and
independent works in themselves, which together are assembled into
a collective whole. A work that constitutes a Collection will not be
considered an Adaptation (as deﬁned below) for the purposes of this
License.
(c) “Creative Commons Compatible License” means a license that is
listed at http://creativecommons.org/compatiblelicenses that has been
approved by Creative Commons as being essentially equivalent to this
License, including, at a minimum, because that license: (i) contains
terms that have the same purpose, meaning and eﬀect as the License
Elements of this License; and, (ii) explicitly permits the relicensing
of adaptations of works made available under that license under this
License or a Creative Commons jurisdiction license with the same
License Elements as this License.
(d) “Distribute” means to make available to the public the original and
copies of the Work or Adaptation, as appropriate, through sale or
other transfer of ownership.

     .

(e) “License Elements” means the following high-level license aributes
as selected by Licensor and indicated in the title of this License: Aribution, ShareAlike.
() “Licensor” means the individual, individuals, entity or entities that
oﬀer(s) the Work under the terms of this License.
(g) “Original Author” means, in the case of a literary or artistic work, the
individual, individuals, entity or entities who created the Work or if
no individual or entity can be identiﬁed, the publisher; and in addition
(i) in the case of a performance the actors, singers, musicians, dancers,
and other persons who act, sing, deliver, declaim, play in, interpret or
otherwise perform literary or artistic works or expressions of folklore;
(ii) in the case of a phonogram the producer being the person or legal
entity who ﬁrst ﬁxes the sounds of a performance or other sounds;
and, (iii) in the case of broadcasts, the organization that transmits the
broadcast.
(h) “Work” means the literary and/or artistic work oﬀered under the
terms of this License including without limitation any production
in the literary, scientiﬁc and artistic domain, whatever may be the
mode or form of its expression including digital form, such as a book,
pamphlet and other writing; a lecture, address, sermon or other work
of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition
with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography;
a work of drawing, painting, architecture, sculpture, engraving or
lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art;
an illustration, map, plan, sketch or three-dimensional work relative
to geography, topography, architecture or science; a performance; a
broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or
circus performer to the extent it is not otherwise considered a literary
or artistic work.
(i) “You” means an individual or entity exercising rights under this License who has not previously violated the terms of this License with
respect to the Work, or who has received express permission from
the Licensor to exercise rights under this License despite a previous
violation.
(j) “Publicly Perform” means to perform public recitations of the Work
and to communicate to the public those public recitations, by any
means or process, including by wire or wireless means or public
digital performances; to make available to the public Works in such a
way that members of the public may access these Works from a place
and at a place individually chosen by them; to perform the Work to
the public by any means or process and the communication to the
public of the performances of the Work, including by public digital
performance; to broadcast and rebroadcast the Work by any means
including signs, sounds or images.
(k) “Reproduce” means to make copies of the Work by any means including without limitation by sound or visual recordings and the right
of ﬁxation and reproducing ﬁxations of the Work, including storage
of a protected performance or phonogram in digital form or other
electronic medium.

 

. Fair Dealing Rights. Nothing in this License is intended to reduce, limit,
or restrict any uses free from copyright or rights arising from limitations
or exceptions that are provided for in connection with the copyright
protection under copyright law or other applicable laws.
. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the
rights in the Work as stated below:
(a) to Reproduce the Work, to incorporate the Work into one or more
Collections, and to Reproduce the Work as incorporated in the Collections;
(b) to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable
steps to clearly label, demarcate or otherwise identify that changes
were made to the original Work. For example, a translation could be
marked “e original work was translated from English to Spanish,”
or a modiﬁcation could indicate “e original work has been modiﬁed.”;
(c) to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
(d) to Distribute and Publicly Perform Adaptations.
(e) For the avoidance of doubt:
i. Non-waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise
by You of the rights granted under this License;
ii. Waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme can be waived, the Licensor waives
the exclusive right to collect such royalties for any exercise by You
of the rights granted under this License; and,
iii. Voluntary License Schemes. e Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary
licensing schemes, via that society, from any exercise by You of the
rights granted under this License.
e above rights may be exercised in all media and formats whether
now known or hereaer devised. e above rights include the right to
make such modiﬁcations as are technically necessary to exercise the
rights in other media and formats. Subject to Section (), all rights
not expressly granted by Licensor are hereby reserved.
. Restrictions. e license granted in Section  above is expressly made
subject to and limited by the following restrictions:
(a) You may Distribute or Publicly Perform the Work only under the
terms of this License. You must include a copy of, or the Uniform
Resource Identiﬁer (URI) for, this License with every copy of the Work
You Distribute or Publicly Perform. You may not oﬀer or impose
any terms on the Work that restrict the terms of this License or the
ability of the recipient of the Work to exercise the rights granted to
that recipient under the terms of the License. You may not sublicense
the Work. You must keep intact all notices that refer to this License
and to the disclaimer of warranties with every copy of the Work
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You Distribute or Publicly Perform. When You Distribute or Publicly
Perform the Work, You may not impose any eﬀective technological
measures on the Work that restrict the ability of a recipient of the
Work from You to exercise the rights granted to that recipient under
the terms of the License. is Section (a) applies to the Work as
incorporated in a Collection, but this does not require the Collection
apart from the Work itself to be made subject to the terms of this
License. If You create a Collection, upon notice from any Licensor You
must, to the extent practicable, remove from the Collection any credit
as required by Section (c), as requested. If You create an Adaptation,
upon notice from any Licensor You must, to the extent practicable,
remove from the Adaptation any credit as required by Section (c), as
requested.
(b) You may Distribute or Publicly Perform an Adaptation only under the
terms of: (i) this License; (ii) a later version of this License with the
same License Elements as this License; (iii) a Creative Commons jurisdiction license (either this or a later license version) that contains the
same License Elements as this License (e.g., Aribution-ShareAlike
. US)); (iv) a Creative Commons Compatible License. If you license
the Adaptation under one of the licenses mentioned in (iv), you must
comply with the terms of that license. If you license the Adaptation
under the terms of any of the licenses mentioned in (i), (ii) or (iii) (the
“Applicable License”), you must comply with the terms of the Applicable License generally and the following provisions: (I) You must
include a copy of, or the URI for, the Applicable License with every
copy of each Adaptation You Distribute or Publicly Perform; (II) You
may not oﬀer or impose any terms on the Adaptation that restrict
the terms of the Applicable License or the ability of the recipient of
the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable License; (III) You must keep intact all
notices that refer to the Applicable License and to the disclaimer of
warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform; (IV) when You Distribute or
Publicly Perform the Adaptation, You may not impose any eﬀective
technological measures on the Adaptation that restrict the ability of a
recipient of the Adaptation from You to exercise the rights granted to
that recipient under the terms of the Applicable License. is Section
(b) applies to the Adaptation as incorporated in a Collection, but this
does not require the Collection apart from the Adaptation itself to be
made subject to the terms of the Applicable License.
(c) If You Distribute, or Publicly Perform the Work or any Adaptations
or Collections, You must, unless a request has been made pursuant
to Section (a), keep intact all copyright notices for the Work and
provide, reasonable to the medium or means You are utilizing: (i) the
name of the Original Author (or pseudonym, if applicable) if supplied,
and/or if the Original Author and/or Licensor designate another party
or parties (e.g., a sponsor institute, publishing entity, journal) for aribution (“Aribution Parties”) in Licensor’s copyright notice, terms of
service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably
practicable, the URI, if any, that Licensor speciﬁes to be associated
with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with
Ssection (b), in the case of an Adaptation, a credit identifying the

 

use of the Work in the Adaptation (e.g., “French translation of the
Work by Original Author,” or “Screenplay based on original Work
by Original Author”). e credit required by this Section (c) may be
implemented in any reasonable manner; provided, however, that in
the case of a Adaptation or Collection, at a minimum such credit will
appear, if a credit for all contributing authors of the Adaptation or
Collection appears, then as part of these credits and in a manner at
least as prominent as the credits for the other contributing authors.
For the avoidance of doubt, You may only use the credit required by
this Section for the purpose of aribution in the manner set out above
and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship
or endorsement by the Original Author, Licensor and/or Aribution
Parties, as appropriate, of You or Your use of the Work, without the
separate, express prior wrien permission of the Original Author,
Licensor and/or Aribution Parties.
(d) Except as otherwise agreed in writing by the Licensor or as may be
otherwise permied by applicable law, if You Reproduce, Distribute
or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take
other derogatory action in relation to the Work which would be prejudicial to the Original Author’s honor or reputation. Licensor agrees
that in those jurisdictions (e.g. Japan), in which any exercise of the
right granted in Section (b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modiﬁcation
or other derogatory action prejudicial to the Original Author’s honor
and reputation, the Licensor will waive or not assert, as appropriate,
this Section, to the fullest extent permied by the applicable national
law, to enable You to reasonably exercise Your right under Section
(b) of this License (right to make Adaptations) but not otherwise.
. Representations, Warranties and Disclaimer
         ,
        
       , , 
,   , ,  ,
  , ,    
, ,        
, ,       ,  
 .       
  ,        .
. Limitation on Liability.       
 ,            
   , , ,  
           
,           
.
. Termination
(a) is License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals
or entities who have received Adaptations or Collections from You
under this License, however, will not have their licenses terminated
provided such individuals or entities remain in full compliance with
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those licenses. Sections , , , , , and  will survive any termination
of this License.
(b) Subject to the above terms and conditions, the license granted here is
perpetual (for the duration of the applicable copyright in the Work).
Notwithstanding the above, Licensor reserves the right to release
the Work under diﬀerent license terms or to stop distributing the
Work at any time; provided, however that any such election will not
serve to withdraw this License (or any other license that has been, or
is required to be, granted under the terms of this License), and this
License will continue in full force and eﬀect unless terminated as
stated above.
. Miscellaneous
(a) Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor oﬀers to the recipient a license to the Work on the
same terms and conditions as the license granted to You under this
License.
(b) Each time You Distribute or Publicly Perform an Adaptation, Licensor
oﬀers to the recipient a license to the original Work on the same
terms and conditions as the license granted to You under this License.
(c) If any provision of this License is invalid or unenforceable under
applicable law, it shall not aﬀect the validity or enforceability of the
remainder of the terms of this License, and without further action
by the parties to this agreement, such provision shall be reformed
to the minimum extent necessary to make such provision valid and
enforceable.
(d) No term or provision of this License shall be deemed waived and no
breach consented to unless such waiver or consent shall be in writing
and signed by the party to be charged with such waiver or consent.
(e) is License constitutes the entire agreement between the parties
with respect to the Work licensed here. ere are no understandings,
agreements or representations with respect to the Work not speciﬁed
here. Licensor shall not be bound by any additional provisions that
may appear in any communication from You. is License may not be
modiﬁed without the mutual wrien agreement of the Licensor and
You.
() e rights granted under, and the subject maer referenced, in this
License were draed utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on
September , ), the Rome Convention of , the WIPO Copyright Treaty of , the WIPO Performances and Phonograms Treaty
of  and the Universal Copyright Convention (as revised on July
, ). ese rights and subject maer take eﬀect in the relevant
jurisdiction in which the License terms are sought to be enforced
according to the corresponding provisions of the implementation of
those treaty provisions in the applicable national law. If the standard
suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are
deemed to be included in the License; this License is not intended to
restrict the license of any rights under applicable law.

 

Creative Commons Notice

Creative Commons is not a party to this License, and makes no warranty
whatsoever in connection with the Work. Creative Commons will not be
liable to You or any party on any legal theory for any damages whatsoever,
including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the
foregoing two () sentences, if Creative Commons has expressly identiﬁed
itself as the Licensor hereunder, it shall have all rights and obligations of
Licensor.
Except for the limited purpose of indicating to the public that the Work
is licensed under the CCPL, Creative Commons does not authorize the use
by either party of the trademark “Creative Commons” or any related trademark or logo of Creative Commons without the prior wrien consent of
Creative Commons. Any permied use will be in compliance with Creative
Commons’ then-current trademark usage guidelines, as may be published
on its website or otherwise made available upon request from time to time.
For the avoidance of doubt, this trademark restriction does not form part of
the License.
Creative Commons may be contacted at http://creativecommons.org/.

Glossary
Access Point A device that allows for a wireless connection to a local network using Wi-Fi, Bluetooth, etc.
applet A small program that runs in a panel. Applets provide useful functions such as starting a program, viewing the time, or accessing the main
menu of an application.
Canonical Canonical, the ﬁnancial backer of Ubuntu, provides support for
the core Ubuntu system. It has over  staﬀ members worldwide who
ensure that the foundation of the operating system is stable, as well as
checking all the work submied by volunteer contributors. To learn
more about Canonical, go to http://www.canonical.com.
  or command-line interface is another name for the terminal.
desktop environment A generic term to describe a  interface for humans
to interact with computers. ere are many desktop environments such
as , ,  and , to name a few.
  stands for Dynamic Host Conﬁguration Protocol, it is used by a
 server to assign computers on a network an  address automatically.
dialup connection A dialup connection is when your computer uses a modem to connect to an  through your telephone line.
distribution A distribution is a collection of soware that is already compiled and conﬁgured ready to be installed. Ubuntu is an example of a
distribution.
dual-booting Dual-booting is the process of being able to choose one of
two diﬀerent operating systems currently installed on a computer from
the boot menu. Once selected, your computer will boot into whichever
operating system you chose at the boot menu. e term dual-booting is
oen used generically, and may refer to booting among more than two
operating systems.
encryption Encryption is a security measure, it prevents others from accessing and viewing the contents of your ﬁles and/or hard drives, the ﬁles
must ﬁrst be decrypted with your password.
Ethernet port An Ethernet port is what an Ethernet cable is plugged into
when you are using a wired connection.
 e  (which stands for Graphical User Interface) is a type of user interface that allows humans to interact with the computer using graphics
and images rather than just text.
  stands for Internet Service Provider, an  is a company that provides
you with your Internet connection.
Live  A Live  allows you to try out an operating system before you
actually install it, this is useful for testing your hardware, diagnosing
problems and recovering your system.
  stands for long-term support and is a type of Ubuntu release that is
oﬃcially supported for far longer than the standard releases.
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maximize When you maximize an application in Ubuntu it will ﬁll the
whole desktop, excluding the panels.
minimize When you minimize an open application, the window will no
longer be shown. If you click on a minimized application’s icon in the
Launcher, it will be restored to its normal state and allow you to interact
with it.
notiﬁcation area e notiﬁcation area is an applet on the panel that provides you with all sorts of information such as volume control, the current song playing in Rhythmbox, your Internet connection status and
email status.
output e output of a command is any text it displays on the next line
aer typing a command and pressing enter, e.g., if you type pwd into a
terminal and press Enter, the directory name it displays on the next line
is the output.
package Packages contain soware in a ready-to-install format. Most of
the time you can use the Soware Center instead of manually installing
packages. Packages have a .deb extension in Ubuntu.
panel A panel is a bar that sits on the edge of your screen. It contains applets which provide useful functions such as running programs, viewing
the time, or accessing the main menu.
parameter Parameters are special options that you can use with other
commands in the terminal to make that command behave diﬀerently, this
can make a lot of commands far more useful.
 A personal package archive () is a custom soware repository that
typically contains either packages that aren’t available in the primary
Ubuntu repositories or newer versions of packages that are available in
the primary repositories.
prompt e prompt displays some useful information about your computer.
It can be customized to display in diﬀerent colors, display the time, date,
and current directory or almost anything else you like.
proprietary Soware made by companies that don’t release their source
code under an open source license.
router A router is a specially designed computer that, using its soware
and hardware, routes information from the Internet to a network. It is
also sometimes called a gateway.
server A server is a computer that runs a specialized operating system and
provides services to computers that connect to it and make a request.
shell e terminal gives access to the shell, when you type a command into
the terminal and press enter the shell takes that command and performs
the relevant action.
Soware Center e Soware Center is where you can easily manage soware installation and removal as well as the ability to manage soware
installed via Personal Package Archives.
Synaptic Package Manager Synaptic Package Manager is a tool that, instead
of listing applications (like the Soware Center) lists individual packages
that can then be installed, removed and ﬁxed.
terminal e terminal is Ubuntu’s text-based interface. It is a method of



controlling the operating system using only commands entered via the
keyboard as opposed to using a  like Unity.
 Universal Serial Bus is a standard interface speciﬁcation for connecting
peripheral hardware devices to computers.  devices range from
external hard drives to scanners and printers.
wired connection A wired connection is when your computer is physically
connected to a router or Ethernet port with a cable. is is the most
common method of connecting to the Internet and local network for
desktop computers.
wireless connection A network connection that uses a wireless signal to
communicate with either a router, access point, or computer.
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